0rCAD® Capture

User’s Guide



Copyright © 1998 OrCAD, Inc. All rights reserved.

Trademarks

OrCAD, OrCAD Layout, OrCAD Express, OrCAD Capture, OrCAD PSpice, and
OrCAD PSpice A/D are registered trademarks of OrCAD, Inc. OrCAD Capture CIS,
and OrCAD Express CIS are trademarks of OrCAD, Inc.

Microsoft, Visual Basic, Windows, Windows NT, and other names of Microsoft
products referenced herein are trademarks or registered trademarks of Microsoft
Corporation.

All other brand and product names mentioned herein are used for identification
purposes only, and are trademarks or registered trademarks of their respective
holders.

60-30-611
First edition 30 November 1998

Technical Support (503) 671-9400
Corporate offices (503) 671-9500

OrCAD Japan K.K. 81-45-621-1911

OrCAD UK Ltd. 44-1256-381-400

Fax (503) 671-9501

General email info@orcad.com
Technical Support email techsupport@orcad.com
World Wide Web http:/ /www.orcad.com

OrCAD Design Network (ODN) http:/ /www.orcad.com/odn

||

OrCAD ™

9300 SW Nimbus Ave.
Beaverton, OR 97008 USA




Contents

Part One

Chapter 1

BeforeYOUbegin © 0 0060000000000 0000000000000 0000000OCOCIOCIGOCESEEOITOTTS xv

Howtousethisguide . . . .. . ... ... ... .. .. ... .. ..... xvii
Symbols and conventions . . . . ... ... L. L oL xvii
Related documentation . . . . ... ....... ... ... .. .. xviii

Capture basics

Getting started . ....oovvuiiineininreonnnecennscsnascasannaasd

Starting Capture . . . . . ... ... ... ... .. L o 3
The Capturesessionframe . . . . .. ... .. ... ............. 4
The Capture work environment ..........cccevviveencennnccannnes d
The projectmanager . . . . ... ... ... ... . ... ... . ... . 6
Project managerfolders. . . . . ... ... ... ............. 6
Project manager tabs—File and Hierarchy . . . . ... ... ... ... 9
Singleview . . . . .. ... L L 9
Part instances and part occurrences . . . . . . ... ... ... ... 10

Project manager pop-upmenus . . . . .. ... ... ... ... 10
The schematic pageeditor . . . ... ... .. ... ... .. ........ 11
Theparteditor . . . ... ... ... .. ... . 12
The Programmer’seditor . . . .. ... ... ... ... ........... 13
Thesessionlog . . . ... ... ... ... .. .. .. .. 14
Thetoolbar . . . ... ... . .. ... 16
Displaying or hiding thetoolbar . . . . . . .. .. ... ... ...... 18
Thetoolpalettes . . . . . ... ... .. .. ... .. ... 19
The schematic page editor tool palette . . . . ... ... ........ 19
The part editor tool palette . . . . ... ... ...... .. ....... 22

Displaying or hiding atool palette . . .. . ... ... ... ...... 23



Contents

Chapter 3

Chapter 4

iv

Thestatusbar . . . . .. ... .. ... .. .. 24
Leftfield. . . . ... ... ... ... . .. .. 24
Centerfield . . . .. ... ... .. .. ... .. ... .. ... 24
Rightfield . . . . ... ... ... .. . .. . . . 24
Displaying or hiding the statusbar . . . . ... ... ......... 25

Selecting and deselecting objects . . . . . ... ... ... ... ... 26
Groupingobjects . . . . . . ... . 28

Editing properties . . .. ... ... ... o oo 29
The Browse spreadsheeteditor . . . . . ... .............. 30
The property editor . . . . ... ... ... ... .. .. ... ... 33

Moving and resizing graphicobjects . . . . . ... ... ... ... .... 37

Undoing, redoing, and repeating anaction . . . ... ... ... ..... 38

Using the Accessoriesmenu . . . ... ................... 40

SiurﬁngaprOiect © 0 0000000000000 0000000000000000O0COCOOLOIELIOIEECEL 4]

Creating new projects, designs, libraries, and VHDL files . . . . . . . .. 42
Opening existing projects, designs, libraries, and VHDL files . . . . . . 45
Working with filesinaproject . . ... ... ... .. .. ... . ... .. 47
Saving projects, designs, and libraries . . . . . ... ... ... ... ... 48
Closingaproject . ... ... ... ... .. .. .. . .. . ... 49

Setting up your project .........ciiiiiiiiiiiiiiiiiiieeeeaess Sl

Defining your preferences . . . . . .. ... .. ... ... .. ... ... 53
Defining colors/printoptions . . . ... ... .. ... ........ 54
Controllingthegrid . . .. ... ...... ... ............. 56
Setting panandzoom . . .. ... ... ... ... .. ... .. ... 57
Defining selectionoptions . . . ... ... ............... 59
Setting miscellaneous options . . . . ... ... ... ... ... ... 61
Setting text editoroptions . . . . . ... .. ... L oL 64

Setting up your projecttemplate . . . . . ... ... ... oL 66
Setting up fonts fornew projects . . . ... ... Lo L 67
Defining title block information . . ... ... ... .......... 68
Setting the schematic page size for new projects . . . ... ... ... 70
Defining the grid reference . . . . . ... ... ........... ... 72
Defining the default hierarchy option for new projects . . . ... .. 74
Setting up compatibility with OrCAD’s Schematic Design Tools . . 75

Changing properties of existing projects . . . . .. ... ......... 76
Assigningfonts . . . . .. .. ... L Lo o o 77
Defining hierarchy . . . . .. ... ... ... ... ... .. . ... 77
Using Capture withSDT . . . ... ... ................ 77
Viewing design information . . . ... .. ... ... .. ....... 78



(ontents

Chapter 5

Part Two
Chapter 6

Chapter 7

Viewing invisible power pins without isolating them . . .. ... .. 79
Changing properties of existing schematicpages . .. ... ........ 80
Changing pagesize . . ... ... .. .. ... .............. 80
Setting up new grid references . . . . . . ... ... ... ... ... .. 81
Viewing miscellaneous schematic page properties . . . . .. ... .. 81

Printingandplotting ...........ccoiiiiiiiiiiiiiiiiiiiiee... 83

Printing or plotting schematicpages . . . ... .. ... .. ... ..... 84
Printing or plotting partsorpackages . . . . . . ... ... .. ... .... 85
Printing the session log and text editor windows . . ... ... ... ... 86
Previewing printer or plotteroutput . . . . ... ... ... ... . .... 87
Scaling printer or plotteroutput . . . .. .. .. ... ... .00 0L 88
Special considerations for plotting . . . . . .. ... ... .. ... . ... 89

Plotterpencolors . . ... . ... ... .. .. ... .. . ...... 89

Creating designs

Design structure .....coviiieeeeiiieereenneecesennccnenness 93

Flatdesigns . . . . . ... ... ... 94
Hierarchicaldesigns . . . . .. .. ... ... ... ... ... ..... 95
Simple hierarchical designs . . . ... ... ............... 95
Complex hierarchies . ... ... ... .................. 97
Connecting schematic folders and schematicpages . . . ... ... .. .. 98
Hierarchicalblocks . ... .. .. ........... ... ....... 98
Hierarchicalports . . . . . ... ... .. ... ... ... .. .. ... 99
Hierarchicalpins . . ... ... .. ... ... ... ... .. ..... 99
Off-pageconnectors . . . . ... .. ..... . ... ... ... .. 100
An example: creating a simple hierarchy . . . ... ... ... ... ... 101

Placing, editing, and connecting parts and electrical symbols .......... 103

Placing and editing parts . . . . . ... .. .. ... .. ... ... .... 105
Placingparts . . . . ... ... ... .. .. ... .. ... 107
Place Partdialogbox . . .. .. ... ................ 109
Searching forparts . ... ... .. ... ... . ... ... .. 111
Editingparts . . .. ... ... ... ... .. . o oo 111
Placing and editing power and ground symbols . . . . .. ... ... .. 114
Placing power and ground symbols . . . . . . ... ... ... ... 114
Place Power and Place Ground dialog boxes . .. ... ... .. 116
Editing power and ground symbols . . . . ... ... ... .. .... 117
Placing and editing no-connect symbols . . . . ... ... ... ... .. 118



Contents

Chapter 8

vi

Placing no-connectsymbols . . ... .. ................ 118
Editing no-connectsymbols . . . .. ... ... oL 119
Placing and editing hierarchical blocks . . . . ... ... ... ...... 120
Placing hierarchicalblocks . . ... ... ................ 120
Place Hierarchical Block dialogbox . . . . . ... ... ...... 122
Editing hierarchicalblocks . . .. ... ................. 124
Placing and editing hierarchical ports and hierarchical pins . . . .. .. 125
Placing hierarchicalports . . . . ... ... ... ... ........ 125
Place Hierarchical Port dialogbox . . ... ... ... ...... 126
Placing hierarchicalpins . . ... ... ................. 127
Place Hierarchical Pin dialogbox . . . ... ... ... ...... 129
Editing hierarchical ports and hierarchical pins . . . . ... ... .. 129
Placing and editing off-page connectors . . . . .. ... ... ....... 130
Placing off-page connectors . . . . .. ... ... ............ 130
Place Off-Page Connector dialogbox . . . ... ... ... ... .. 132
Editing off-page connectors . . . . . ... ... ... ... ... ... 133
Placing and connecting wiresandbuses . . . . . .. ... ... .. ... .. 134
Placingwires . . . ... ... .. .. ... ... . 135
Editingwires . . .. ... ... ... ... 136
Placingbuses . . .. ... .. ... ... . ... L 137
Editingbuses . . . . .. ... ... .. ... oL oL 138
Placingbusentries . . . . ... ....... ... .. ... ... 138
Editingbusentries . . . ... ... ... ... o L L 139
Ripping a subset of signals off thebus . . . . . ... ... ... .. .. 139

Adding and editing graphics and text ............cc.oiiieail.. 141

Drawingtools . . . . .. . .. ... ... . 142
Drawinglines . . . . . . ... ... ... ... o 143
Drawing rectangles and squares . . . ... ... .............. 144
Drawing circles and ellipses . . . . ... .. ................ 145
Drawingarcs . . . ... ... . . e 146
Drawing polylinesand polygons . . . . . . ... .. ............ 147
Adding filltoanobject . .. ... .. .. .. ... .. .. .. ... 148
Mirroringanobject . . . . ... ... .. Lo L oo 148
Rotatinganobject . ... ... ... ............... ..., 149
Moving anobject . . . .. ... ... L L 149
Cuttinganobject . . ... ... ... ... L o o 149
Copyinganobject . ... ......... .. ... .. ... .. ... ... 150
Pastinganobject . . ... ... ... ... ... . 0 L 150
Deleting aselected object . . . ... ... ... ... ... ... ... 150
Placingabitmap . ....... ... ... ... ... . ... ... ... 151



Contents

Chapter 9

Chapter 10

Part Three
Chapter 11

Placingtext . . . .. ... ... ... .. ... 152
The text boundingbox . . . . .. ... ... ... .. . ... 154
Deletingtext . . . .. ... ... ... ... ... ... ... .. ... 154
Modifying text . . . . ... ... ... L Lo 154
Findingtext . ... ... . ... ... .. ... .. .. .. .. .. ... 155
Replacingtext . . ... ... ... ... ... ... ... .. ...... 156
Importingtext . ... ... . ... ... ... . ... .0 .. 156
Exportingtext . ... ... ... ... ... ... ... .. ... ... 157
Character formatting . . . . .. ... ... ... ... ... ... 157
Aboutscreenfonts. . . .. ... ... L L oL L 158

Usingmacros .....oovieeiineeinnnnnnnecnneesenceecenesas. 159

Recordingamacro . . . . .. .. ... .. ... ... .. 161
Playingamacro . .. .. ... . ... ... ... 162
Configuringamacro. . . . ... .. ... ... ... .. 163

Configure Macrodialogbox . . . ... ... ............ 164
Namingamacro . . . . . ... . ... .. i 167
Assigning a shortcutkeytoamacro. . . ... .. ... ... ... ... 169
Samplemacros . . . . .. ... e 170

Changing your view of a schematicpage ..............cco0ven.. . 171

ZOOMING . . . . . it 172
Zooming to a specifiedscale . . . ... ... ... ... . L0 173
Other viewingoptions . . . . .. .. ... ... ... ... ... ... 173

Movingtoanewlocation . . . . ... ... .. ... .. .0 00, 175
MovingtoanX, Ylocation . . . . .. ...... .. ... ... ... . 175

Go To dialog box, Locationtab . . ... .. ... ......... 176
Jumping to a specific grid reference . . . . . .. ... ... ... ... 177

Go To dialog box, Grid Referencetab. . . . . .. ... ... ... 177
Jumping to amarked location . . . ... ... ... .. .. ... 178

Go To dialog box, Bookmarktab . . ... ............. 179
Displaying the grid and grid references . . . . . . .. ... ... ... .. 180
Finding partsinaproject . . . . ... .. .. ... ... .. ... ... .. 181

Libraries and parts

About libraries and parts . .......cciiiiiiiiiiiiiiiiiieeiena.. 185

Libraries. . . . . . . o e e, 186
Parts . . . . . . e 187
Part instances and occurrences . . . . . . . . . ..o oo 188



Confents

Chapter 12

Part Four

r 19
Chapter 13

Chapter 14

viii

Thedesigncache . . .. ... ... .. ... . ... .. ... ... ... .. 189
Primitive and nonprimitiveparts. . . . . ... ... ... ... ... ... 192

Creating and editingparts .........ccovviieeeieiiinneeee.. 193

Parts and packages: homogeneous or heterogeneous . . ... ... ... 194
Creatinganewpart .. .......... .. ... ... ......... 195
Definingapart . .. ... .. ... ... ... . 195
New Part Properties dialogbox . . . ... ... ... ....... 198
Attaching a schematic foldertoapart . . . .. ... .......... 200
Adding graphics, text, and IEEE symbolstoapart . ... ... ... 201
Placingpinsonapart . ... ... .................... 202
Place Pindialogbox . . . . .. .................... 204

Place Pin Array dialogbox . . . . ... ... . ... . ...... 209

About powerand ground pins . . . ... ... ... 211
Displaying invisible powerpins . . . . . ... ... ... ... ..., 212
Editing anexistingpart . .. ... .. ... ... ... ..o 0oL 213
Editing a partinalibrary . . ... ... ..... ... ... ..., 213
Editing a part on aschematicpage. . . . . .. ... .......... 214
Viewing partsinapackage . . ... ... . ... ... ... ... ... .. 216
Editing partsinapackage . . . . ... ... ... ... oL 217
Viewingapart'sconvert. . . . ... ..................... 218

Processing your design

About the processing tools . ........cooviiiiiiiiiiiiiiiia, 221
Toolsoverview . . . ... ... ... .. e 222
Updating instances and occurrences . . . . . . ... ... ... .. .. 224
Preparing to createametlist ..........cccoiiiiiiiiiiiiiats, 225
Annotating . . . ... ... e 225
Annotate dialogbox . . . . ... ... oo o oo 227
Updating properties . . . ... ........ ... ... ... ... 229
Update Properties dialogbox . . .. .. ... .. ......... 231
Update fileformat . . . ... ..................... 233
Checking for design rules violations . . . . . ... ... .......... 234
Design Rules Check dialog box, Design Rules Check tab . . . . . 237
Design Rules Check dialog box, ERC Matrixtab . . . . ... ... 240
Sample Design Rules Checkreport . . . .. ... ... ... ... 241
Backannotating . . . .. ... ... ... oo 244
Back Annotate dialogbox. . . . .. ... ... ... . . 0L 245
Swapfileformat . . . ... ... ... oo oL 246



(ontents

Chapter 15

Chapter 16

Chapter 17

Chapter 18

Chapter 19

Creatingametlist .......covvveeiiiiiiinnnecennencecnnnans. 249

Using the Create Netlisttool . . . . ... ... .. ... .......... 249
Netlist formatfiles . . . . . . . . . . . . . . .. 252
Netname resolution . . . . . . . . . . . .. .. 253

Creatingreports .....cccveeereeeiiiiiieencesecsncsnnnons 255

Creating abill of materials . . . .. .. ... ... .. ... ........ 255
Bill of Materials dialogbox . . . . .. ... ... ... . ... ... 257
Includefileformat . . . .. ... ... . ... ... . L. 259
Creating a cross referencereport . . . . . . ... ... ........... 260
Cross Reference Parts dialogbox . . . . ... .. ... ...... 261

Exporting and importing schematicdata ..............cc00ue..... 263

Exporting and importing designs . . . . ... ... ... .. .. ... 263
Exportingdesigns . . ... ... ... .. ... ... . L. 264
Importingdesigns . . . .. ... ... .. ... . o 0L 265

Exporting and importing properties . . . . . .. ... ... .. ... ... 266
Exporting properties . . . ... ... ... ... .. 0 L. 266
Property fileformat . . . . .. ... ... .. .. o 0oL 267
Editing aproperty file. . . . . ... ... ... . L oo 268
Importing properties . . . .. ... . ... ... ... ... 269

Using Capture with OrCAD Layout .......cocvvvnnveeninnnnnnas. 271

Preparing your Capture design for use with Layout . . ... ... ... 273
Transferring user-defined properties to Layout . . . . ... ... .. 274
Creating a netlist foruseinLayout . .. ... ............... 281
Loading a new netlistinto Layout . . . . ... ... ... ... ...... 282
Back annotating board information from Layout . . ... ... ... .. 283
Forward annotating schematic data to Layout . . . . ... ... ..... 284
Cross probing between Capture and Layout . . . . . ... ... ... .. 286
Enabling intertool communication between Capture and Layout . . 285
Cross probing from Capture to Layout . . . .. ... ... ... ... 285
Cross probing from Layout to Capture . . . . .. ... ... ..... 287
Generalrules . . .. ... ... .. ... . L 288

Using Capture with OrCAD PSpice .........ccceevvevnnneeee... 289

Overview . . .. ... ... . 289
Specifying simulation model libraries . . . . . . ... ... ... ... .. 290
Creating a design for PSpice A/D simulation . . ... .......... 291
Editing simulation models from Capture . . . . . ... ... ... .... 292



Contents

Adding and defining stimulus . . . ... ... ... .. 000 293
Placing stimulus sources . . . .. .................... 293
Using the Stimulus Editor . . . . ... .. ... ............. 293

Setting up and running analyses . . . .. ... ... ... ... ... .. 294

Viewingresults . . . ... .. .. ... .. ... ... .. 295
Viewing results as yousimulate . . . ... ............... 295
Usingmarkers . .. ... ... .. ... ... .. .. ... 295
Configuring the display of simulationresults . . ... ........ 296

Creating designs for PSpice simulation and board layout . . . . . . . .. 297
Handling unmodeled pins . . .. ... ................. 298

GloSSArY « o ovvvenrreenreneecscnesccccscsnnsscccnsnnnaees 299

1T 13 A 1 I |



Figure 1

Figure 2

Figure 3

Figure 4

Figure 5

Figure 6

Figure 7

Figure 8

Figure 9

Figure 10
Figure 11
Figure 12
Figure 13
Figure 14
Figure 15
Figure 16
Figure 17
Figure 18
Figure 19
Figure 20
Figure 21
Figure 22
Figure 23
Figure 24
Figure 25
Figure 26
Figure 27
Figure 28
Figure 29
Figure 30
Figure 31
Figure 32
Figure 33
Figure 34

Capture’ssessionframe . . . . . ... ... ... .. .. ... ... .. .. 4
New project managerwindow . . . . .. ... ... .. ... ....... 6
Filetab . ... .. ... ... . ... . 9
Hierarchytab . . . . . . . ... .. ... . .. . 9
Schematic pageeditor . . . . . .. ... ... L 11
Parteditor . ... ... ... .. ... . ... ... 12
Programmer’seditor . . ... ... ... ... ... ... .. ... 13
Sessionlog . . ... ... ... 14
Capture’stoolbar . . .. ... .. ... .. ... 16
Schematic page editor tool palette . . . . . ... ............... 19
Parteditor toolpalette . . . . . . ... ... ... . L oL 22
Thestatusbar . ... ... ... ... .. ... . ... . ... ... ... 24
Browse spreadsheeteditor . . . ... ... ... ............... 30
Propertyeditor . . . . .. ... . ... ... ... . 33
Open project, design and schematicpage . . . . .. ... ... ....... 45
Openlibrary . ... ... ... .. . 46
OpenVHDLfile . . .. ... ... ... ... .. . . 46
Colors/Print tab of the Preferences dialogbox . . . . . . ... .. ... .. 54
Grid Display tab of the Preferences dialogbox . . . . .. ... ... .. .. 56
Pan and Zoom tab of the Preferences dialogbox . . . . .. ... ... ... 57
Select tab of the Preferences dialogbox . . . . . ... ... ......... 59
Miscellaneous tab of the Preferences dialogbox . . . . ... ... ... .. 61
Text Editor tab of the Preferences dialogbox . . . .. ... ......... 64
Fonts tab of the Design Template dialogbox . . . . . .. ... ....... 67
Title Block tab of the Design Template dialogbox . . . . . ... ... ... 68
Titleblock . . . . . ... ... . L 69
Page Size tab of the Design Template dialogbox . .. ... ... ... .. 70
Grid Reference tab of the Design Template dialogbox . . . . ... .. .. 72
Hierarchy tab of the Design Template dialogbox . . .. ... ... .. .. 74
SDT Compatibility tab of the Design Template dialogbox . . . . ... .. 75
Miscellaneous tab of the Design Properties dialogbox . . ... ... ... 78
Miscellaneous tab of the Schematic Page Properties dialog box . . . . . . 81
An abstract representation of a simple hierarchy. . . . ... ... ... .. 95

A simple, hierarchical design, as seen in the project manager . . ... .. 96



Figures

Figure 35
Figure 36
Figure 37
Figure 38
Figure 39
Figure 40
Figure 41
Figure 42
Figure 43
Figure 44
Figure 45
Figure 46
Figure 47
Figure 48
Figure 49
Figure 50
Figure 51
Figure 52
Figure 53
Figure 54
Figure 55
Figure 56
Figure 57
Figure 58
Figure 59
Figure 60
Figure 61
Figure 62
Figure 63
Figure 64
Figure 65
Figure 66
Figure 67
Figure 68
Figure 69
Figure 70
Figure 71
Figure 72
Figure 73
Figure 74
Figure 75
Figure 76
Figure 77
Figure 78

xii

An abstract representation of a complex hierarchy . . . .. ... ... .. 97
A complex hierarchical design, as seen in the project manager . . . . . . 97
Schematics before hierarchy . . . . ... ... ... ... ... ....... 101
Schematics with hierarchy . . . . ... ....... ... .. .. ..... 101
Schematics carryinganet . . ... ... ... ... ... 102
Connectivity across pages inaschematic . . . . ... ... ........ 102
Part editorin packageview . . . . ... ... ... .. Lo 105
Parteditorinpartview . .. .. .. ... ............ . ... .. 106
Place Partdialogbox . . . .. ... ... .. ... .. ... o L. 109
Property editor with filter set to Capture . . . .. ... ... ....... 112
Power and ground symbols in CAPSYM.OLB . . ... .......... 114
Place Power dialogbox . . . ... ........ ... ........... 116
Hierarchicalblock . .. ... ... ... ... ... ... ......... 120
Place Hierarchical Block dialogbox . . . . ... ... ........... 122
Hierarchical ports in CAPSYM.OLB . . . .. ................ 125
Place Hierarchical Port dialogbox . . . .. ... .............. 126
Place Hierarchical Pindialogbox . . . . . ... ... ... ......... 129
Off-page connectors in CAPSYM.OLB . . . . . ............... 130
Place Off-Page Connector dialogbox . . . ... ... ... ........ 132
Schematic page editor tool palette. . . . . . .. ............... 142
Part editor tool palette . . . . .. ... ... ... ... .. ... 142
Configure Macro dialogbox . . . ... ................... 164
Location tab of the Go To dialogbox . . . . . . ............... 176
Grid Reference tab of the Go Todialogbox . . . ... ... ... ..... 177
Bookmark tab of the Go To dialogbox . . . . . ... ............ 179
Replace Cache dialogbox . . ... ........ ... .. ........ 190
New Part Propertiesdialogbox . . . . . ... ................ 198
Place Pindialogbox . ... ... ... ... ... ............ 204
Place Pin Array dialogbox . . . ... .................... 209
Part editor in Package View . . . . ... ... ... ... ... ... 216
Beforeannotation . . . . . .. ... ... o 226
Afterannotation . . .. ... . ... ... oo 226
Annotate dialogbox . . ... ... ... o o oo 227
Update Properties dialogbox . . . .. .. ... ............... 231
Design Rules Check tab of the Design Rules Check dialogbox . . . . . . 237
ERC tab of the Design Rules Check dialogbox . . . . .. ... ...... 240
Back Annotate dialogbox . . . . ... .. ... oo Lo 245
Create Netlist dialogbox . . .. ... ... .. ... ... .. ..... 250
Bill of Materials dialogbox . . . . ... ..... ... ........... 257
Cross Reference Parts dialogbox . . . . ... ................ 261
Export Design dialogbox . . . ... ... .................. 264
Import Design dialogbox . . . ... ...... ... ... ... ... 265
Export Properties dialogbox . . . . ... .................. 267
Import Properties dialogbox . . . . ... .................. 270



Tables

Table 1
Table 2
Table 3
Table 4
Table 5
Table 6
Table 7
Table 8
Table 9
Table 9
Table 10
Table 11
Table 12
Table 13
Table 14

Tools on the Capturetoolbar . . . . .. ... ... ... ........... 16
Tools on the schematic page editor tool palette . . . ... ... ...... 20
Tools on the part editor tool palette . . . . ... ............... 22
Capture’s macro subroutines . . . . ... ... Lo 0000 167
Valid shortcutkeys . .. ... ... ... ... .. ... ... .. .. .. 170
Pinshapes . ... ... ... ... ... ... ... 205
Pintypes . ... .. ... ... .. .. 206
Capturetoolsoverview . . . . .. ... ... ... ... . ... 223
Updating instances or occurrences . . . . .. ... .. .. ... ..... 224
Netlist format filetypes . .. ... ... ... ... ... ......... 252
Layout part properties . . . . ... .. ... ... . . L. 275
Layout net properties . . .. . ... ... ... ... ... . ... ... 278
Layout pinproperties . . . .. ... ... ... .. ... ... ... .... 280
Cross probing from Capture to Layout . . . . ... ... ... ...... 286

Cross probing from Layoutto Capture . . . .. .. ... ......... 287



Tables

xiv



Before you hegin

OrCAD ® offers a total solution for your core design tasks:
schematic- and VHDL-based design entry; FPGA and
CPLD design synthesis; digital, analog, and mixed-signal
simulation; and printed circuit board layout. What's
more, OrCAD’s products are a suite of applications built
around an engineer’s design flow—not just a collection of
independently developed point tools. OrCAD Capture is
just one element in OrCAD'’s total solution design flow.

Many of today’s electronic circuits combine analog and
digital components. If you are among the many designers
working with both analog and digital circuits, you need a
simulator that can handle mixed-signal circuits.

Using OrCAD Capture, you can create schematics for
analog or mixed signal designs, printed circuit board
layout designs, and programmable logic designs.
Capture’s schematic page editor helps you efficiently
create your design. After your design is created, use
Capture’s tools to quickly annotate them and prepare
them for the next stage of development.
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xvi

Capture interactively communicates with OrCAD PSpice
and OrCAD Layout, so you can easily debug your
projects.

In addition to the 30,000+ libraries included with Capture,
you can create your own parts and libraries for use with
your designs. You can even store schematics with libraries
for reuse.



How fo use this guide

How to use this guide

This guide is designed so you can quickly find the
information you need to use Capture. To help you learn
and use Capture efficiently, this manual is organized by
tasks, beginning with setting up your workspace for
designs and projects (part one), followed by creating
designs and libraries (parts two and three), and ending
with processing your designs (part four).

Symbols and conventions

OrCAD printed documentation uses a few special
symbols and conventions.

Notation Examples Description

ctri)+(R) Press (Ctrl)+(R) Means to hold down the key
while pressing (R).

(at), (F), (9 From the File menu, choose Open ((Alt), (F), (G)) Means that you have two options.

You can use the mouse to choose
the Open command from the File
menu, or you can press each of the

keys in parentheses in order: first
Alt), then (F), then (0).

Monospace font  Inthe Part Name text box, type PARAM. Text that you type is shown in

monospace font. In the example,
you type the characters (P), (A), (R),
(A}, and (M).

.MODEL MLOAD NMOQOS Examples of syntax, netlist output,

+ ( LEVE L=1 VTO=O .7 C\.]:O . 02p F ) and source code are dlsplayed in
monospace font. The example
shows an example of the syntax for
the PSpice MODEL statement.

UPPERCASE In Capture, open CLIPPERA.DSN. Path and filenames are shown in
uppercase. In the example, you

open the design file named
CLIPPERA.DSN.

Italics In Capture, save design_name. DSN. Information that you are to provide
is shown in italics. In the example,
you save the design with a name of
your choice, but it must have an
extension of .DSN.

xvii
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Related documentation

In addition to this guide, you can find technical product
information in the online help, the online interactive
tutorial, online books, OrCAD’s technical web site, as well
as other books. The table below describes the types of
technical documentation provided with Capture.

This documentation component . . .

Provides this . ..

This guide—
OrCAD Capture User’s Guide

Online help

Online interactive tutorial

Basic information to get started in Capture. The OrCAD
Capture User’s Guide is an overview of the features available
in Capture.

Comprehensive information about Capture. If you can’t
find something in the Capture User’s Guide, look in the
online help.

You can access help from the Help menu in Capture, by
choosing the Help button in a dialog box, or by pressing
(F1). Topics include:

¢ Explanations and instructions for common tasks.

¢ Descriptions of menu commands, dialog boxes, tools on
the toolbar and tool palettes, and the status bar.

o Netlist format samples, error messages, and glossary
terms.

e Reference information.
¢ Product support information.

You can get context-sensitive help for a error message by
placing your cursor in the error message line in the session

log and pressing (F1J.

A series of self-paced interactive lessons. You can practice
what you’ve learned by going through the tutorial’s
specially designed exercises that interact directly with
Capture. You can start the tutorial by choosing Learning
Capture from the Help menu.

Online Converting MicroSim Schematics Designs to A quick start guide to using the Schematics-to-Capture

OrCAD Capture Designs Quick Start

Online OrCAD Capture User’s Guide
Online Capture Quick Reference Card
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translator. Includes how to convert MicroSim schematics,
symbol libraries, and package libraries to Capture.

An online, searchable version of this guide.

Concise descriptions of the commands, shortcuts, and tools
available in Capture.



How to use this guide

ODN—OrCAD Design Network An internet-based technical support solution. ODN
www.orcad.com/odn provides a variety of options for receiving and accessing

design and technical information. ODN provides:

¢ A Knowledge Base with thousands of answers to
questions on topics ranging from schematic design
entry and VHDL-based programmable logic design to
printed circuit board layout methodologies.

* A Knowledge Exchange forum for you to exchange
information, ideas, and dialog with OrCAD users and
technical experts from around the world. A list of new
postings appears each time you visit the Knowledge
Exchange, for a quick update of what’s new since your
last visit.

¢ Tech Tips that deliver up-to-the-minute product
information in your email box. Stay informed about the
latest advances, tips, and announcements on your
OrCAD product.

¢ Online technical support via the Tech Support
Connection. Use this service to submit technical support
incidents online. Create submissions, upload files, track
your incidents and add comments directly into
OrCAD’s support database.
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Part One

Capture bhasics

Chapter 1, Getting started, describes how to start Capture.

Chapter 2, The Capture work environment, describes the
things you'll need to know to find your way around in
Capture. It shows the windows you'll see in Capture: the
project manager, the browse window, the schematic page
editor, the part editor, and the session log. It also
introduces you to the toolbar and tool palettes, and
general Capture concepts such as selecting and editing
objects, and undoing and repeating actions.

Chapter 3, Starting a project, describes the different types of
designs that Capture supports: flat, simple hierarchical,
and complex hierarchical. It introduces the electrical
objects used to create these types of designs, and provides
an example of how to create a simple hierarchy.

Chapter 4, Setting up your project, shows how to open a
design and navigate the schematics and schematic pages
in a design, or a portion of a design, such as an individual
schematic page.






Getting started

This chapter describes how to start OrCAD Capture.

Starting Capture

The OrCAD Release 9 installation process puts Capture in
the \PROGRAM FILES\ORCAD \ CAPTURE folder, and
adds “OrCAD Release 9” to the Programs menu (available
from the Start button).

To start Capture

1 From the Start menu, choose Programs. The Programs
menu displays.

2 From the OrCAD Release 9 menu item, choose
Capture.
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Getfing started

The Capture session frame

Once you start Capture, you see the Capture session frame.
You do all your schematic design and processing within
this window.

OiCAD Capture

. Session Log

Figure 1 Capture’s session frame

The minimized Session Log icon in the lower left portion
of the Capture session frame is the session log. The session
log provides information about everything you have done
in the current Capture session. Detailed information about
this window—and the other windows in Capture—is
given in Chapter 2, The Capture work environment.

In Capture, each design that you open is in a separate
project manager window. If you need to work
simultaneously with several designs, you can open them
all, and each will have its own project manager window.

Depending on which type of window you have active (an
active window is one whose title bar is highlighted),
certain buttons on the toolbar and certain items on the
menus may be unavailable, since you perform tasks and
use tools based upon the type of window that is active.
Also, the menus and menu choices vary, depending on
which type of window is active. The available menus and
menu choices will also vary depending upon the type of
project you are working with.



The Capture work
environment

This chapter describes the things you need to know to find
your way around in Capture. It shows the windows you’ll
see in Capture: the project manager, the schematic page
editor, the part editor, the text editor, and the session log.
It also introduces you to the toolbar, tool palettes, and
general Capture concepts such as selecting and editing
objects, editing properties, and undoing and repeating
actions.
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E:] Design Cache
b m Lib[ary
Qutputs

Figure 2 New project manager window

For information about hierarchical designs,
see Chapter 6, Design structure.

The project manager

You use the project manager to collect and organize all the
resources you need for your project. These resources
include schematic folders, schematic pages, part libraries,
parts, VHDL files, and output reports such as bills of
materials and netlists. Figure 2 shows a new project
manager window.

A project doesn’t actually contain all the resources. It
merely “points to” the various files that the project uses.
For this reason, be sure you don’t move or delete any files
referenced by a project. If you do, the project won’t be able
to find them.

The project file is saved with an .OP]J file extension. It is an
ASCII file, and can be viewed in any text editor.

Project manager folders

The project manager provides a graphical display of a
project’s resources by grouping them into appropriate
folders, as described below.

e Shown underneath the Design Resources folder is the
design folder with the design’s schematic folders and
schematic pages, and a Design Cache folder that
shows all the parts used on the schematic pages. Any
schematic folders or schematic pages that you create
are automatically added to the design folder (in
Figure 2, the design folder is named DESIGN3.DSN).
You can also add other files or information using the
Project command on the Edit menu. For example, you
can add an existing VHDL file to the design folder and
later attach the models within that VHDL file to
hierarchical blocks on a schematic page.



The project manager

e The Library folder (in the Design Resources folder)
shows the schematic part library files you've added to
the project using the Project command on the Edit
menu.

e The Outputs folder shows the output of Capture’s
processing tools. Generally, these files include bill of
materials reports and technology-specific netlists.
Capture adds the appropriate files to this folder as
each is created.

Each project may have only one design, but may have
multiple libraries. The design may consist of any number
of schematics or VHDL models, but it must have a single
root module. The root module is defined as the top level of
the design. That is, all other modules in the design are
referenced within the root module.

Within the project manager, you can expand or collapse
the structure you see by double-clicking on a folder, or by
clicking on the plus sign or minus sign to the left of a
folder. A plus sign indicates that the folder has contents
that are not currently visible; a minus sign indicates that
the folder is open and its contents are visible, listed below
the folder. It appears as a schematic folder with a slash on
it in a design file, or as a page in a VHDL file.

Each project you open has its own project manager
window. You can move or copy folders or files between
projects by dragging them from one project manager
window to another (as well as to and from Windows
Explorer). To copy rather than move items, press and hold
the key while you drag them. If you close a project
manager window, you close the project.

In the project manager’s File tab, double-clicking on a
schematic folder expands it and displays icons for each
schematic page within the schematic folder. Then, if you
double-click on a schematic page icon, the schematic page
opens in a schematic page editor. Or, if the page is already
open, its window becomes active.

Tip The root module for a design has a
backslash in its folder icon, as shown in
Figure 2 on page 6.

Note If a schematic page is open, you
cannot drag ifs icon to a different location.
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Note The project manager is also used to
manage libraries and the parts they
contain. This is covered in detail in
Chapter 11, About libraries and parts.

A design can consist of a single schematic page within a
single schematic folder, or a number of schematic pages
within a number of schematic folders. A schematic folder
“contains” schematic pages in a relationship similar to the
relationship between a directory and the files it contains.
Files are contained in a directory; schematic pages are
contained in a schematic folder.

A schematic page provides a graphical description of the
electrical connectivity of a design. It is made up of parts,
wires, and other electrical symbols. A schematic page may
also contain borders, title blocks, text, and graphics.

Capture acts on any schematic folders or schematic pages
you have selected within an active project manager
window. For example, the Find and Browse commands on
the project manager’s Edit menu, the Print command on
the project manager’s File menu, and the various tools on
the Tools menu, only apply to the selected schematic
folder or page.



The project manager

Project manager tabs — File and Hierarchy

The project manager provides two ways to display a
project’s resources.

If you choose the File tab (shown in Figure 3), the project
manager displays all the project’s folders, schematic
folders, and schematic pages. These are displayed in a
tree-like fashion. You can expand or collapse the tree by
clicking the plus sign in front of the icon. When that
branch of the tree is expanded, the plus sign change to a
minus sign.

If you choose the Hierarchy tab (shown in Figure 4), the
project manager displays the hierarchical relationship
among the project’s schematic folders and schematic

pages.

Single view

Versions of Capture prior to Release 9 used logical mode
and physical mode to separate instance and occurrence
information. Now, both instances and occurrences are
contained in a single view. The project manager shows all
occurrences in the Hierarchy tab.

In versions of Capture prior to Release 9, it was necessary
to switch modes before creating a netlist for use with
OrCAD Layout. Now, the netlist tool provides an option
to use either the instance properties or the occurrence
properties for creating a netlist.

1 FEE0LUrg

\fulladd.dsn

FULLADD
&-63 ExeB
@ EexescH
. [-C0 Design Cache
-C3 Library
0 Outputs

Figure 3 file tab

For information about hierarchical designs,
see Chapter 6, Design structure.
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Figure 4 Hierarchy tab
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For information about simple and complex
hierarchical designs, see Chapter 6, Design
sfructure.

For information on each pop-up menu
command, refer to Capture’s online help.

10

Part instances and part occurrences

A part instance is a specific instantiation of a part. Since the
part instance may be referenced in one or more schematic
pages, any change you make to a part instance affects each
schematic page that refers to that part instance. For flat
and simple hierarchical designs, this is straightforward:
each part instance has a unique reference designator and
corresponding set of associated properties that apply each
time the part instance is referenced.

In a complex hierarchy, a part instance that is referenced
more than once in the design will only have one reference
designator and set of properties assigned to it, regardless
of the number of times it is referenced. This presents a
problem when you need to create a netlist for use with
Layout or some other board layout tool. However,
Capture automatically uniquely annotates each
occurrence of a part instance. Hence, part occurrence refers
to a particular instantiation of a part instance in the netlist.

Project manager pop-up menus

There are a number of pop-up menus available in the
project manager window. Pop-up menus are available by
clicking the right mouse button. Using the commands on
these pop-up menus, you can open a file or schematic
page, or edit and view the properties of the currently
selected item.



The schematic page editor

The schematic page editor

The schematic page editor is used to display and edit
schematic pages. You can place parts, wires, buses, and
draw graphics. The schematic page editor has a tool
palette that you can use to draw and place everything you
need to create a schematic page. You can print from within
the schematic page editor, or from the project manager
window.

halfadd_A

< SUM

3 -
2 ) CARRY_OUT

741822
1401P30D

Figure 5 Schematic page editor
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For more information, see The part editor
tool palette on page 22.

See Chapter 11, About libraries and parts
for complete definitions of parts and
packages. See Chapter 12, Creating and
editing parts for a complete description of
the part editor.

12

The part editor

The part editor is used to create and edit parts.

| 2 FULLADD DSN

Figure 6 Part editor
From the View menu of the part editor you can choose
either Part or Package. In Part view you can:

e Create and edit parts and symbols, then store them in
new or existing libraries.

e Create and edit power and ground symbols, off-page
connector symbols, and title blocks.

e Use the tool palette’s electrical tools to place pins on
parts, and its drawing tools to draw parts and
symbols.

Package view shows the entire package. A package is a
physical part that contains more than one logical part. You
can edit the properties of the entire package, such as part
reference, prefix, part alias, and so on. You cannot edit
individual parts in this view, but you can select individual
parts to edit by double-clicking on them.

The part editor is very similar to the symbol editor. The
main difference between the two is the symbol editor’s
lack of Pin and Pin Array tool palette buttons.



The Programmer’s editor

The Programmer’s editor

Use the Programmer’s editor to create or view VHDL files
or other text files within Capture. VHDL keywords and
comments are displayed in the colors you specify in the
Text Editor tab in the Preferences dialog box (from the
Options menu, choose Preferences).

| &3 bitbed_vhd

LIBRARY IEEE;

USE IEEE .std_logic_1164 all;
ENTITY FDE IS PORT

D : IN std_logic;

E : IN std_logic;

CLK @ IN std_logic;

C : IN std_logic;

Figure 7 Programmer’s editor

To create a new VHDL file in the Programmer’s editor

1 From the File menu, choose New, then choose VHDL
File. A blank VHDL file appears in the text editor.

To open a VHDL file in the Programmer’s editor

1 From the File menu, choose Open, then choose VHHDL  Note Designs and parts of designs can be
File. The Open VHDL File dialog box appears. VHDL based instead of schematic based.

92 Select a file, then click OK. OrCAD Express provides a complete design
solution for targeting PLDs. For more

Or information on editing VHDL files in the

1 In the project manager, select a VHDL file. text editor, see Chapter 4, Creating VHDL

models and paramertized parts in th
2 Click the right mouse button, and choose Edit from the 0rCAD Expr:ss Usei’sié:id‘::r *1n e

pop-up menu.

13
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The session log

The session log lists the events that have occurred during
the current Capture session, including messages resulting
from using Capture’s tools. To display context-sensitive
help for an error message, put the cursor in the error
message line in the session log and press (F1)J.

The ruler along the top appears in either inches or
millimeters, depending on which measurement system
(U.S. or Metric) is selected in the Windows Control Panel.
You can add tab settings to the ruler by clicking in the
ruler bar, dragging the tabs to different positions, or
remove them by dragging them down into the session log
window. Your tab settings are saved and used each time
you start Capture.

Session Log

+*

| * Bl Of Materials

*

* LT * O e e L

Perfarming BOM.
BOM Done.

Figure 8 Session log

Tip You can clear the session log by You can search for information in the session log using the
choosing the Clear Session Log command, Find command on the Edit menu. You can also save the
or by pressing (Ctrl)+ (Del). contents of the session log to a file, which is useful when

working with OrCAD’s technical support staff to solve
technical problems. The default filename is SESSION.TXT.

14



The session log

To display the session log

1 Click on the session log’s maximize button, or choose
Session Log from the Window menu.

To minimize the session log

1 Click the minimize button on the title bar.

To copy session log text to the Cliphoard

1 Select the session log window to make it active.

2 Select the text and choose Copy from the Edit menu.

To print the session log
1 Select the session log window to make it active.

2 From the File menu, choose the Print command.

To use Find in the session log

1 Select the session log window to make it active.

2 From the Edit menu, choose the Find command. The
Find dialog box appears.

Enter the word or words that you want to find.

4 (lick Find Next.

To save the session log to a text file
1 Select the session log window to make it active.

2 From the File menu, choose the Save As command.
The Save As dialog box appears.

3 Enter a file name in the File name text box. By default,
the session log is saved to SESSION.TXT in the current

directory. If necessary, specify a new location for the
file.

4 Click Save. The session log text is saved to the file.

15
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The toolbar

Note The foolbar is always docked on the Capture’s toolbar is dockable (that is, you can select an area
top edge of the session frame the firstfime ~ between buttons and drag the toolbar to a new location)
you open a project in a new session frame and resizable, and displays tooltips for each tool. By

of Capture. The position of the tool palette choosing a tool button, you can quickly perform a task. If
a tool button is dimmed, you can’t perform that task in the
current situation.

is not saved.

Figure 9 Capture’s toolbar

Some of the tools operate only on what you have selected,
while others give you a choice of either operating on what
is selected or expanding the scope to the entire project.

Table 1 summarizes the tools on the toolbar. The tasks that
these tools perform are described throughout this manual.

Table 1  Tools on the Capture toolbar

Tool  Name

Description

New

Create a new document based on the active document. Similar to the
New command on the File menu. For more information, see Creating
new projects, designs, libraries, and VHDL files on page 42.

Open

Open an existing project or library. Similar to the Open command on
the File menu. For more information, see Opening existing projects,
designs, libraries, and VHDL files on page 45.

Save

Save the active document, schematic, or part. Equivalent to the Save
command on the File menu. For more information, see Saving projects,
designs, and libraries on page 48.

Print

Print the selected pages in the schematic folder, or the active schematic
page or part. Equivalent to the Print command on the File menu. For
more information, see Chapter 5, Printing and plotting.

Cut

Remove the selected object and place it on the Clipboard. Equivalent to
the Cut command on the Edit menu.

Copy

Copy the selected object to the Clipboard. Equivalent to the Copy
command on the Edit menu.

16



The toolbar

Table 1 Tools on the Capture toolbar (continued)

Paste Paste the contents of the Clipboard at the cursor. Equivalent to the
Paste command on the Edit menu.

Undo Undo the last command performed, if possible. Equivalent to the Undo
command on the Edit menu.

Redo Redo the last command performed, if possible. Equivalent to the Redo
command on the Edit menu.

Zoom In Zoom in to see a closer, enlarged view. Equivalent to choosing Zoom
and In from the View menu. For more information, see To zoom in on
page 172.

Zoom Out Zoom out to see more of your document. Equivalent to choosing Zoom

and Out from the View menu. For more information, see To zoom out
on page 173.

Zoom Area

Specify an area of the schematic page or part to enlarge to fill the entire
window. Equivalent to choosing Zoom and Area from the View menu.
For more information, see To view a selected area on page 173.

Zoom All View the entire document. Equivalent to choosing Zoom and All from
the View menu. For more information, see To view the entire page or part
on page 174.

Annotate Assign part references to parts on the selected schematic pages.
Equivalent to the Annotate command on the Tools menu. For more
information, see Annotating on page 225.

Back Annotate Back annotate the selected schematic pages. Equivalent to the Back
Annotate command on the Tools menu. For more information, see Back
annotating on page 244.

Design Rules Check for design rules violations on the selected schematic pages.

Check Equivalent to the Design Rules Check command on the Tools menu.

For more information, see Checking for design rules violations on
page 234.

Create Netlist

Create a netlist for the selected schematic pages. Equivalent to the
Create Netlist command on the Tools menu. For more information, see
Using the Create Netlist tool on page 249.

Cross Reference

Create a cross reference report for the selected schematic pages.
Equivalent to the Cross Reference command on the Tools menu. For
more information, see Creating a cross reference report on page 260.

17
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Table 1  Tools on the Capture toolbar (continued)

Bill of Materials  Create a bill of materials report for the selected schematic pages.
Equivalent to the Bill of Materials command on the Tools menu. For
more information, see Creating a bill of materials on page 255.

Snap-to-Grid Toggle schematic page and part editing to either on or off grid.

Project Manager  Display the project manager window for the active document,
providing an overview of project contents. Equivalent to choosing a
project manager window by number from the Window menu.

Help Topics Open online help. Equivalent to the Help Topics command on the
Help menu.

Displaying or hiding the toolbar

You can hide the toolbar, then display it again when you
need it.

To display or hide the toolbar

1 From the schematic page editor’s View menu, choose

Toolbar.
or
From the part editor’s View menu, choose Toolbar.

18



The tool palettes

The tool palettes

Capture has two tool palettes: one for the schematic page  Note The fool palette is always docked on

editor and one for the part editor. Both tool palettes are the right edge of the session frame the first
dockable (that is, you can click on an area between buttons time you open a schematic page or part in
and drag a tool palette to a new location) and resizable, a new session of Capture. The position of
and display tooltips that identify each tool. While the the tool palette is not saved.

drawing tools on the two tool palettes are identical, each
tool palette has different electrical tools. After you choose
a tool (and, in the case of some tools, after you respond to
the tool’s dialog box), you press the right mouse button to
display a context-sensitive pop-up menu.

The schematic page editor tool palette

The first group of tools on the tool palette are electrical
tools, used to place electrical-connectivity objects. The

second group of tools are drawing tools, used to create
graphical objects without electrical connectivity.

Figure 10 Schematic page editor tool palette

The tools on the schematic page editor tool palette are For information on using the electrical

described in Table 2. tools, see Chapter 7, Placing, editing, and
connecting parts and electrical symbols. For
information on how to use the drawing
tools, see Chapter 8, Adding and editing
graphics and text.

19
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Table 2 Tools on the schematic page editor tool palette

Tool Name Description
Select Select objects. This is the normal mode.
Part Select parts from a library for placement.

Equivalent to the Part command on the Place
menu. For more information, see Placing parts on
page 107.

Wire Draw wires. Press | > Shift| to draw

non-orthogonal (not a multiple of 90°) wires.
Equivalent to the Wire command on the Place
menu. For more information, see Placing wires on
page 135.

Net Alias Place aliases on wires and buses. Equivalent to the
Net Alias command on the Place menu. For more
information, see Placing buses on page 137.

Bus Draw buses. Press | <> Shift] to draw

non-orthogonal segments. Equivalent to the Bus
command on the Place menu. For more
information, see Placing buses on page 137.

Junction Place junctions. Equivalent to the Junction
command on the Place menu.

Bus Entry Draw bus entries. Equivalent to the Bus Entry
command on the Place menu. For more
information, see Placing bus entries on page 138.

Power Place power symbols. Equivalent to the Power
command on the Place menu. For more
information, see Placing power and ground symbols
on page 114.

Ground Place ground symbols. Equivalent to the Ground
command on the Place menu. For more
information, see Placing power and ground symbols

on page 114.
Hierarchical ~ Place hierarchical blocks. Equivalent to the
Block Hierarchical Block command on the Place menu.
For more information, see Placing hierarchical
blocks on page 120.

20
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Table 2 Tools on the schematic page editor tool palette (continued)

Hierarchical ~ Place hierarchical ports on schematic pages.

Port Equivalent to the Hierarchical Port command on
the Place menu. For more information, see Placing
hierarchical ports on page 125.

Hierarchical =~ Place hierarchical pins in hierarchical blocks.

Pin Equivalent to the Hierarchical Pin command on
the Place menu. For more information, see Placin g
hierarchical pins on page 127.

Off-Page Place off-page connectors. Equivalent to the

Connector Off-Page Connector command on the Place menu.
For more information, see Placing off-page
connectors on page 130.

No Connect Place no-connect symbols on pins. Equivalent to
the No Connect command on the Place menu. See
Placing and editing no-connect symbols on page 118.

Line Draw lines. Equivalent to the Line command on
the Place menu. For more information, see
Drawing lines on page 143.

Polyline Draw polylines. Press to draw
non-orthogonal polylines. Equivalent to the

Polyline command on the Place menu. For more
information, see Drawing polylines and polygons on
page 147.

Rectangle Draw rectangles. constrains to a square.
Equivalent to the Rectangle command on the
Place menu. For more information, see Drawing
rectangles and squares on page 144.

Ellipse Draw ellipses. | <> Shift] constrains shape to a
circle. Equivalent to the Ellipse command on the

Place menu. For more information, see Drawing
circles and ellipses on page 145.

Arc Draw arcs. Equivalent to the Arc command on the
Place menu. For more information, see Drawing
arcs on page 146.

Text Place text. Equivalent to the Text command on the
Place menu. For more information, see Placing text
on page 152.
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The part editor tool palette

The first group of tools on the part editor tool palette are
electrical tools, used to place pins and IEEE symbols. The
second group of tools are drawing tools, used to create
graphical objects without electrical connectivity.

Figure 11 Part editor tool palette

For information on how to use the electrical
tools, see Chapter 12, Creating and editing
parts. For information on how fo use the
drawing tools, see Chapter 8, Adding and
editing graphics and fext.

The tools unique to the part editor tool palette are
described in Table 3. The drawing tools are described in
the previous section, The schematic page editor tool palette on
page 19.

Table 3  Tools on the part editor tool palette

Tool Name Description
IEEE Place IEEE symbols on a part. Equivalent to the
Symbol IEEE Symbol command on the Place menu. For

more information, see Adding graphics, text, and
IEEE symbols to a part on page 201.

Pin Place pins on a part. Equivalent to the Pin
command on the Place menu. For more
information, see Placing pins on a part on page 202.

Pin Array Place multiple pins on a part. Equivalent to the
Pin Array command on the Place menu. For more
information, see Placing pins on a part on page 202.
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Displaying or hiding a fool palette

Like the toolbar, you can hide a tool palette, then display
it again when you need it.

To display or hide a tool palette

1 From the schematic page editor’s View menu, choose
Tool Palette.

or
From the part editor’s View menu, choose Tool

Palette.
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The status bar

The status bar is located at the bottom of the Capture
session frame, and reports on current actions, number of
items selected, zoom scale, and pointer location.

Note When a session log or a project
manager window is active, the center field
of the status bar doesn't display.

24

Figure 12 The status bar

Left field

The left field displays descriptions of selected tools or
menu items, prompts, or the current status.

Center field

The center field displays the number of items selected in
the schematic page editor or part editor.

Right field

The right field displays the current scale and pointer
location (such as: Scale=50% X=10.0 Y=5.0). The location
in the schematic page editor is measured in either inches
or millimeters, depending on the Units settings in the
Page Size tab in the Schematic Page Properties dialog box.
The location in the part editor is measured in grid units.



The status bar

Displaying or hiding the status bar

You can hide the status bar, then display it again when
you need it.

To display or hide the status bar

1 From the schematic page editor’s View menu, choose
Status Bar.
or

From the part editor’s View menu, choose Status Bar.
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Note You can edit the properties of a
group of objects using the property editor.
See The property editor on page 33.

Use the following steps to change the
selection color:

1 from the Options menu, choose
Preferences, then choose the Colors
tab.

2  (lick the left mouse button over the
Selection color.

3 Select a new color from the color
palette window, dlick OK to dismiss the
color palette, then click OK to dismiss
the dialog box.

26

Selecting and deselecting objects

Once you select an object, you can perform operations on
it, including moving, copying, cutting, mirroring,
rotating, resizing, or editing. You can also select multiple
objects and edit them, or group them into a single object.
Grouping objects maintains the relationship among them
while you move them to another location.

This section describes different ways to select individual
objects and groups of objects in both the schematic page
editor and the part editor.

To select an object

1 Position the pointer on the object and click the left
mouse button. The object displays in the selection color.

To select multiple objects

1  For each object to select, position the pointer on the
object and press while you click the left mouse
button. Every object in the selection set displays in the
selection color.

Tip  Toselect a part, click within the part itself. To select a graphical
object, lick on an outside edge of the object (it is easier to do this
if you zoom in).

To deselect objects

1 Click on an area where there are no objects. Selected
objects become deselected. Note that a part occupies a
rectangular area encompassing all its graphics. This
means that a part may occupy a larger area than is
initially apparent.



Selecting and deselecing objects

To select all objects in an area
1 From the tool palette, choose the selection tool.

2 Click on an area where there are no objects or parts to
deselect any items that may be selected.

3 Move the pointer to one corner of the area to select.
Press and hold the left mouse button while you drag
the mouse to the opposite corner, then release the left
mouse button. Every object in the selection set appears
in the selection color.

To select all objects on a schematic page or part

1 From the Edit menu, choose Select All. All objects
appear in the selection color.

To select an object from a set of objects stacked atop one another

1 Position the pointer over the stack of objects.

2 Press while you click the left mouse button. This
cycles through the objects in the stack.

To remove one object from a selection set

1 Place the pointer over the object, press , and click
the left mouse button.

You can control whether the selection set
includes all objects intersected by your
selection rectangle or only those objects
entirely inside the selection rectangle by
the following steps:

1 From the Options menu, choose
Preferences, then choose the Select
tab.

2 Select one of the Area Select options,
then click OK.

Note A selection set behaves as if it is one
object, so you can move, copy, cut, delete,
mirror, or rotate the entire set. Be aware,
however, that the Select All command also
selects the title block on the schematic
page. If you copy or move the selection set,
you could create a duplicate title block, or
inadvertently move the title block off the
schematic page.
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Note Objects remain grouped until you
ungroup them or close the schematic page
or part that contains them.

Caution The Group command will not be
available if your selection includes a net
alias, because a net alias is a property.
After block selecting the objects you want to
group, deselect the included net aliases by

holding the (Ctr1) key and clicking on each
object.

28

Grouping objects

Use the Group command on the Edit menu to group
multiple objects into one selectable object. This is a
convenient way to maintain the relationship among
several objects while moving them to another location.
You can nest groups, meaning a group can contain other
groups as well as objects. The Group command is only
available when multiple objects are selected.

To group multiple selected objects

1 Select the objects you want to group, as described in
the previous section.

2  From the Edit menu, choose Group. You can move the
objects as a group.

3 When you are through manipulating the objects as a
group, you can ungroup them. From the Edit menu,
choose Ungroup.



Editing properties

Editing properties

In a Capture schematic design, each object has properties
that define their characteristics. These objects include:

e Hierarchical ports

e Off-page connectors

e DRC markers

e Bookmarks

e Parts (including hierarchical blocks)

e Nets (including constituent nets within buses)
e Pins

e Title block

A property consists of a property name (for example, Part
Value or Part Reference) and an associated value (for
example, TIP31C or Q2). For example, part properties
define the name, value, reference designator, and other
information for each part in your design.

In Capture you can edit property values, create or delete
properties, or cause the properties to be displayed on the
schematic page. To edit properties, you use one of two
editors:

e The browse spreadsheet editor, as described on
page 30.

e The property editor, as described on page 33.

Since Capture allows for complex hierarchical design
structures (as discussed in Chapter 6, Design structure),
each of the objects listed above can exist as instances or
occurrences.

In complex hierarchical designs, a schematic page can be
referenced (or reused) at several points in the design. An
instance refers to the object that is placed on the defining
schematic. An occurrence represents the use or reuse of
that instance within a design. When you edit properties
for an object, you can edit the instance, or you can edit a
particular occurrence of that instance.
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The Browse spreadsheet editor

E— You display the Browse spreadsheet editor from the
oro project manager’s Edit menu. The particular Browse

14DIP30

14DIP300

e spreadsheet that you display depends on the object you

1DIPI00
14DIP300

orim select from the Browse pull-right menu. The options

14DIP300

o, e include:

14DIP300

e Hierarchical ports

Off-page connectors
e DRC markers

Figure 13 Browse spreadsheet edifor

e Bookmarks
e Part (including hierarchical block) occurrences

e Net (including constituent nets within a bus)
occurrences

e Pin occurrences
e Title block occurrences

The Browse spreadsheet editor browses the entire design
for the objects you select, then displays their properties.
Each property appears as a column heading in the
spreadsheet. Each row is an object located by the editor.

It is important to note that, in the Browse spreadsheet
editor you can only edit properties for occurrences. To edit
instance properties, you must use the property editor
discussed in The property editor on page 33.
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To create a new property in the Browse spreadsheet editor

In the first column of the Browse spreadsheet, select
the object or occurrence for which you want to create
the new property.

From the Edit menu, choose Properties. Capture
displays the object in a new Browse spreadsheet
window.

Click New. Capture displays the New Property dialog
box.

Enter a name and value for the new property, then
click OK. Capture adds the property to the object or
occurrence and displays the new property in the
original Browse spreadsheet.

To copy a value from one property to another property in the
Browse spreadsheet editor

1

In the first column of the Browse spreadsheet, select
the object or occurrence that has the property with the
value you want to copy.

From the Edit menu, choose Properties. Capture
displays the object in a new Browse spreadsheet
window.

Select the cell that contains the value you want to
copy.
Click Copy.

Select the cell that you want to contain the copied
value.

Click Paste. Capture pastes the value into the selected
cell.
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Note Some properties cannot be removed
as they are essential for creating a netlist.
You can only remove user-defined
properties.

Note If you remove a property from an
occurrence for which there is a defined
instance property, the occurrence property
is not removed, but rather, the instance
property value “shines through” fo the
occurrence. In order fo remove an instance
property you must use the property editor.

For more information about instance and
occurrence properties see The property
editor on page 33.
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To remove a user-defined property in the Browse spreadsheet
editor

1 In the first column of the Browse spreadsheet, select
the object or occurrence that has the property you
want to remove.

2 Select the column heading for the property you want
to remove.

3 Click Remove. Capture removes that property from
the object.



Editing properties

The property editor

You display the property editor either by selecting items
on a schematic page, then choosing Properties on the Edit
or popup menu, or by simply double-clicking on an item
in the schematic page editor.

The property editor allows you to edit properties for
instances or occurrences of the following objects:

e Parts (including hierarchical blocks)

e Nets (including constituent nets within buses)
e PDins

e Title blocks

The property editor is constrained such that it can only
edit instances or occurrences on the active schematic page.
To browse and edit properties for an entire design, see The
Browse spreadsheet editor on page 30.

Occurrence ] )
hierarchical path:reference  Property names Filter drop-down list

<none=

<none=

<none=

<none=

(ALFADD : HALFADD : U3 11505679615 Tl e asmoeanY  aones

Instance name ltem selection tabs Property value
schematic name:page:reference

Figure 14 Property editor
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Note When you first start the property
editor all instance properties are displayed.
Occurrence properties are displayed only if
they have their own values assigned to
them (independent of the instance property
valves).
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Each column in the property editor is a property. Each
row is an instance or occurrence. Occurrence rows appear
in yellow below their associated instance row. They only
appear if you expand the instance by clicking the plus sign
(+) to the left of the instance name. The cells in the
property editor show the property values for each
instance or occurrence. If a cell contains a cross-hatch
pattern, the corresponding property does not have a value
(for instances), or does not have an occurrence-specific
property, causing the instance property value to “shine
through.”

The properties that appear in the property editor depend
on the items selected in the schematic page. Also, these

properties depend on the tab selection at the bottom of the
property editor. For example, if the Parts tab is active, the
properties for selected parts appear in the property editor.

You can also constrain the set of displayed properties by
using the filters available in the drop-down list in the
upper right of the property editor. There are a number of
filters available. These filters are sets of properties that are
typically useful for particular project types. For example,
the Actel Designer Part/Net Properties filter includes
properties that are useful for constraining a PLD project
for integration with Actel’s Designer software. The <All>
filter causes the property editor to display all properties
that currently exist for the selected item.



Editing properties

When editing properties in the property editor, it is
important to remember a few key points:

Property values that are applied to instances will
“shine through” to all occurrences of those instances,
unless an occurrence has a value (independent of the
instance value) for a particular property.

Occurrence property values override instance
property values.

When you delete an instance property, that property
will no longer “shine through” to its occurrences.

Deleting a property value from an occurrence causes
the instance property value to “shine through” to that
occurrence.

To create a new property in the property editor

In the schematic page editor, select the object(s) for
which you want to create the property.

On the Edit menu, choose Properties. Capture
displays the property editor.

Click the New button. Capture displays the New
Property dialog box.

Enter a name for the new property and click OK.
Capture adds the new property to the property editor
and to all instances and occurrences currently
displayed therein.

Enter values for the property as described in To edit a
property value in the property editor.

To edit a property value in the property editor Note Some property values (those that

1

have particular significance to the design

In the property editor, select the cell that contains the database) cannot be edited

value you want to change.

Type in the new value and press (Enter«=). Note that
changing an instance property value causes that value
to “shine through” to all occurrences of the instance
that do not have a value independent of the instance.
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Note Some property values (those that
have particular significance to the design
database) cannot be deleted.

For information on the Display Properties
dialog box, see the Capture online help.

Note Although you can only sef the
display for instances, the property value
that appears on the schematic page is that
of the particular occurrence.
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To edit the a property value for all instances and occurrences
currently displayed in the property editor

1

In the property editor select the property name
column that has the value you want to change.

From the popup menu, choose Edit. Capture displays
a dialog box for the selected property.

Type the new value for the property and click OK. The
new value is applied to that property for each instance
and occurrence that is currently displayed in the
property editor.

To delete a property in the property editor

1
2

Select the column of the property you want to delete.

Click the Delete Property button. The property is
removed. (The property column remains in the
display. To see that the property is deleted, leave the
property editor and then return to it.)

To display a property on the schematic page

1

In the property editor, select the instance property
cells you want to display, then click the Display
button. Capture displays the Display Properties
dialog box.

Complete the dialog box as desired, then click OK.
Capture displays the property on the schematic page
for all instances currently displayed in the property
editor.



Moving and resizing graphic objects

Moving and resizing graphic
objects

For some objects—such as wires, buses, lines, ellipses,
rectangles, and so on—you can edit the object’s size and
shape by clicking on it and dragging its resize handles.

Before you can move or resize a graphic object, you must
first select it. A selected object has resize handles that you
use to change the size of the graphical object.

To resize and move objects

1
2

Select the object to resize or move.

To resize the object, press the left mouse button on a
resize handle, and drag the handle until the object is
the size you would like it. Release the mouse button.
or

To move the object, press the left mouse button
anywhere on the object—except on a resize handle—
and drag the object until it is where you want it.
Release the mouse button.

To deselect the object, click in an area where there are

L

no parts or objects.

Note For descriptions of other ways to
manipulate objects, see Chapter 8, Adding

and editing graphics and fext.
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Tip You can use the Repeat command to
align objects or to quickly create repetitive
structures such as buses.
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Undoing, redoing, and repeating
an action

You use the Undo command to undo your action. To
repeat an edit action, use the Repeat command. For
example, you might move a selected object five grid units,
then realize you also need to move a different object the
same distance. Select the second object, then from the Edit
menu, choose the Repeat command. You can use the
Undo, Redo, and Repeat commands with the following
actions:

e Placing objects

o Deleting objects (except for the Repeat command)
e Copying objects

e Moving objects

e Resizing objects

¢ Rotating objects

e Mirroring objects

To undo an action

1 From the Edit menu, choose Undo.

To reverse an undone action

1 From the Edit menu, choose Redo.

To repeat a command

1 Perform the command once.

2 From the Edit menu, choose Repeat.



Undoing, redoing, and repeating an action

To repeat a copy operation

1
2

Select an object on a schematic page.

Press and drag the object to a new location. This

creates a copy of the object. Leave the object selected.

From the Edit menu, choose Repeat. The pointer
repeats the relative move in step 2 and an additional
object is placed.
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Using the Accessories menu

You can use extensions to the OrCAD-supplied
functionality of Capture if you purchase software
developed by associates of OrCAD. These associates
create .DLL files that address specific Capture
functionality, such as customized netlist creation. The
associates configure their .DLL files so that they are listed
as menu choices on the Accessories menu, available in
either the project manager window or the schematic page
editor once you install the third-party extension.



Starting a project

A project file (.OPJ) stores pointers to a single design file
(.DSN), and can also contain libraries, VHDL files, and
output reports associated with the design file. A design
file contains one or more schematic folders, in which there
are one or more schematic pages. A design file also
contains a design cache, which is like an embedded
library—it contains a copy of all the parts and symbols
used on the schematic pages. When a design is saved with
the project file, information from the various Tools dialog
boxes is also saved in the project file.

Note Parts reside in a library the same
way schematic pages reside in schematic
folders. Symbols and title blocks also reside
in libraries. A project can use any number
of libraries, and a library can be included in
any number of projects. However, a project
may have only one design (.DSN).
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Note The project types available fo you
will depend upon which 0rCAD programs
you have installed. As a minimum, you will
have the option to create a PC Board or
Schematic project type.
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Creating new projects, designs,
libraries, and VHDL files

You can create a new project, and then create new designs,
libraries, and VHDL files.

To create a new project

1 From the File menu, choose New, then choose Project.
The New Project dialog box appears.

2 Type a name for your new project in the Name text
box.

Use the Browse button to select a new directory.

Select a project type in the Create a New Project Using
group box, and click OK. Capture provides the
following project types:

Analog or mixed signal circuit—select this type of
project if you intend to use your design with
OrCAD PSpice. Follow the guidance of the Analog
Mixed-Mode Project wizard to add the
appropriate files to your project.

PC board—select this type of project if you intend
to use your design with OrCAD Layout. Follow
the guidance of the PCB Project Wizard to add the
appropriate files to your project.

Programmable logic—select this type of project if
you intend to use your design with OrCAD
Express. Follow the guidance of the
Programmable Logic Project Wizard to add the
appropriate files to your project.

Schematic—select this type of project if none of the
other project types apply. Using this option,
Capture creates a basic project containing only the
design file.



Creating new projects, designs, libraries, and VHDL files

To create a new design
1  From the File menu, choose New, then choose Design.

2 The design opens in a new PCB project manager and a
new schematic page displays.

To create a new schematic page

1 On the File tab of the project manager, select the
schematic folder that requires a new schematic page.

2 Click the right mouse button and choose New Page
from the pop-up menu. A new schematic page
appears within the schematic folder you selected in
step 1.

To create a new library

1 From the File menu, choose New, then choose Library.

2 Thelibrary opens in the project manager and a Library
Cache folder is added to the project manager, or the
library opens in the existing open project manager and
a library cache is added.

To create a new VHDL file

RPN DR IR W 4 B & I SR ISR S o B I
WO wdys to create a new VHDL file ir \.apfure:

1 From the File menu, choose New, then choose VHDL
File.

2 A VHDL file opens in Capture’s VHDL programmer’s
editor.

Or

1  With the project manager active, choose New VHDL
File from the Design menu. The file opens in the
VHDL programmer’s editor and a dialog box appears,
asking if you want to add the file to the project.

2 Choose the Yes button to add the file to the project that
is currently open. The Save As dialog box appears.

Note A project cannot have more than
one design (.DSN) file. If you try to add a
second .DSN file to your project, the
Overwrite dialog box appears, asking if
you want fo replace the existing design.

For information on how fo create parts for
inclusion in a library, see Chapter 12,
(reating and editing parts.

Note If you choose the No button,
Capture does not add the VHDL file to your
project and you must save it yourself at a
later point in time.
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3 Select a directory for the file and supply a filename. By
default, the VHDL file’s name is VHDL#n.VHD (where
n is an integer indicating the number of .VHD files
created in the current session).

4 Choose the Save button. Capture saves the file and
places it in the Design Resources folder of your
project.
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Opening existing projects,
designs, libraries, and VHDL files

You can open an existing project, design, library or VHDL Tip The four files that were last opened

file. Existing schematic pages can only be opened from are listed at the bottom of the File menu. To
within designs and libraries. open one of these files, select it from the
File menv.

To open an existing project

1 From the File menu, choose Open, then choose Project.
The Open Project dialog box displays.

2 Select a project (.OPJ) or type the name in the File
name text box, then choose the Open button. The
project opens in the project manager.

To open an existing design

1 From the File menu, choose Open, then choose Design. ~ Figure 15 Open project, design and
The Open Design dialog box displays. schematic page

2 Select a design (.DSN) or type the name in the File
name text box, then choose the Open button. The
design opens in the project manager.

To open an existing schematic page

1 In the project manager, select the File tab and
double-click the icon of a schematic folder; this
expands the folder and reveals the schematic pages it
contains.

2 Double-click on the icon of the schematic page you
want to open. The schematic page opens in a
schematic page editor window.
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To open an existing library

1 From the File menu, choose Open, then choose
Library. The Open Library dialog box displays.

2 Select a library (.OLB) or type the name in the File
name text box, then choose the Open button. The
library opens in the project manager.

Figure 16 Open library
To open an existing VHDL file

1 From the File menu, choose Open, then choose VHDL
File. The Open VHDL File dialog box displays.

2 Select a VHDL file (VHD) or type a name in the File
name text box, then choose the Open button. The
VHDL file opens in Capture’s text editor.

Figure 17 Open VHDL file
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Working with files in a project

Using the project manager, you can add or delete project
files. You can add any file to your project, including
libraries and VHDL files. Files not in ASCII format, or a
Capture generated format, may not appear as expected
when opened in Capture.

To add a file to your project

1 In the project manager, select the folder to which you
want to add a file.

2 From the Edit menu, choose Project. The Add File to
Project Folder dialog box displays.

3 Select the file you want to add and choose the Open
button. The file is added to the project.

Or

1 Drag the file from the Windows Explorer into the
folder in the project manager.

To delete a file from a project

1 In the project manager, select the file you want to
delete.

2 Press the key. The file is removed from the
project.

Note You can also add files to your
project interactively. When you create a
design using the New command on the File
menu, it is placed in the project manager’s
Design Resources folder.

Caution You will not be given a chance fo
cancel this process affer you press the

key. If you delete a file by mistake,
you will have to add it back to the project.
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Note To avoid overwriting a design file
with a misnamed project file, type in the
filename without a file extension. Capture
automatically saves the file with the correct
file extension.

Tip To protect your work in the event of a
system crash or power outage you can
enable Auto Recovery, and set the interval
at which your design, library, or VHDL file
is saved. For information about the Auto
Recovery option, see Setting miscellaneous
options on page 61.

Note If you choose Save when a
schematic page window is active, only that
page’s design is saved, not the entire
project. However, when you attempt to
close the project, a dialog box asks if you
want fo save any project files that have
been edited but not yet saved.
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Saving projects, designs, and
libraries

When the project manager window is active, you can save
a new or existing project, design, or library. The Save
command saves all open documents referenced by the
project, as well as the project itself.

The Save As command saves files depending on what you
have selected in the project manager.

e If one or more designs or libraries are selected, you are
prompted to save each file in turn.

e If no top-level folders (Design Resources or Outputs)
are selected, and items other than designs or libraries
are selected, the Save As command is unavailable.

e If no designs or libraries are selected in the project
manager, you are prompted to save the project.

To save a new design or library

1  With the design or library selected in the project
manager, from the File menu, choose Save. The Save
As dialog box displays.

2 Enter a name for the design or library in the File name
text box, specify a location, then choose the Save
button.

The design or library is saved, and the project manager
remains open. When you close the project, Capture
prompts you to save the project file.

To save an existing project

1 With the Design Resources or Output folder selected,
choose Save from the File menu.

The project is saved, and remains open in the Capture
session frame.



(losing a project

Closing a project

When the project manager window is active, you can close
a project without quitting Capture, or you can close and
save your project as you quit.

To close a project

1 From the project manager’s File menu, choose Close
Project.

When you close a project, a dialog box displays, asking if
you want to save your changes.

To quit Capture

1 From the project manager’s File menu, choose Exit.

When you choose the Exit command, a dialog box
displays, asking if you want to save your changes.

e Choose Yes to save the specific document within
the project.

¢ Choose Yes All to save all documents in the
project.

e Choose No to close the document without saving
it.

e Choose No All to close all open documents
without saving them.

e Choose Cancel to abort closing the project.
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Setting up your project

Capture provides different levels of configuration. Using
commands on the Options menu, you can:

e Customize the working environment specific to your
system (using Preferences).

¢ Create default settings for new designs (using Design
Template). These settings stay with the design as
design properties even if it is moved to another system
with different preferences.

e Override settings in individual designs (using Design
Properties) or individual schematic pages (using
Schematic Page Properties).

Regardless of which Capture window is active, the
Options menu has a Preferences command and a Design
Template command. In addition, the Options menu
contains commands specific to the current active window.
For example, the project manager’s Options menu
contains the Design Properties command, while the
schematic page editor’s Options menu contains the
Schematic Page Properties command.
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The settings in the Preferences dialog box determine how
Capture works on your system, and persist from one
Capture session to the next because they are stored in the
Capture initialization (.INT) file on your system. If you
pass projects to others, they won't inherit your
Preferences settings. This means you can set colors, grid
display options, pan and zoom options, and so on to your
liking and be assured that your settings will remain, even
if you work on a project created on another system.

The Design Template dialog box determines the default
characteristics of all the projects created on your system.
Because a new project inherits characteristics from the
current Design Template settings, it’s a good idea to check
the settings before you create a new project.

Once you begin working on a project, you can customize
its particular characteristics by choosing Design
Properties from the Options menu when you are in the
project manager, or Schematic Page Properties when you
are in the schematic page editor.



Defining your preferences

Defining your preferences

The options that you define in the tabs of the Preferences
dialog box affect how Capture works with your projects.
Choose Preferences from the Options menu to access the
Preferences dialog box.

Colors/Print. Set up colors for objects such as off-page
connectors, hierarchical blocks and ports, text, title
blocks, and so on, and specify which objects will be
printed or plotted. You can also change the
background color and the color of the grid.

Grid Display. Select dots or lines for your grid, and
whether to display or print your grid. You can select
whether to have your pointer snap to grid as you place
objects. You can set these options independently for
the schematic page editor and the part editor.

Pan and Zoom. Define how you want autoscrolling to
work, and what the zoom factor should be. You can set
these options independently for the schematic page
editor and the part editor.

Select. Define whether you want to select objects
enclosed by a selection rectangle or objects inside and
intersecting a selection rectangle, the maximum
number of objects to display at high resolution while
dragging, and whether to show the tool palette. You
can set these options independently for the schematlc
page editor and the part editor.

Miscellaneous. Define the default fill, line style and
width, and color for graphic objects, define the font
used in the project manager and session log, render
TrueType fonts with strokes (for printing and
plotting), and set whether to auto recover your project
and how often. In addition, you can enable intertool
communication, which is the method that Capture
uses to communicate with other OrCAD software,
such as OrCAD Layout.

Text Editor. Define which (if any) VHDL keywords
are highlighted, and the font and tab settings used
within the text editor.
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Defining colors/print options

You control the color in which different schematic page
objects display by using the Colors/Print tab in the
Preferences dialog box.

Figure 18 Colors/Print tab of the Preferences dialog box

To define if an object is printed or plotted

1 From the Options menu, choose Preferences, then
choose the Colors/Print tab.

2 Select the check box by the color for the object to be
printed or plotted. Clear the check box for the object to
not be printed or plotted. Objects are always displayed
on your screen, regardless of the setting of their check
boxes.



Defining your preferences

To define an object’s color

1 From the Options menu, choose Preferences, then
choose the Colors/Print tab.

2 Click the left mouse button on the color of an item. The

color palette window opens. Note The color that you select for Title

3 Select a new color. Click OK to dismiss the color Block is also the color used for borders and
palette. grid references.
4 Click OK.

Graphics objects (lines, polylines, and arcs) use the colors
specified by Miscellaneous tab. If the color options in the
Miscellaneous tab are set to Default color, then Capture

uses the color specified for graphics by the Colors/Print
tab.
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Caution If you disable the Pointer
snap-to-grid option while you are drawing,
be sure to enable it before you place
electrical objects. Otherwise, your part pins
may be placed off-grid, making it difficult
to connect them properly.

Tip You can also show or hide the grid
using the Grid command on the View menu
in the schematic page editor or the part
editor.

Tip You can toggle the snap-to-grid using
the snap-to-grid toolbar button.
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Controlling the grid

You can control whether Capture displays a grid
independently in the schematic page editor and the part
editor, and whether the grid uses dots or lines. You can
also specify whether the pointer snaps to grid in each
editor.

Preferences

Figure 19 Grid Display tab of the Preferences dialog box

To control the grid

1 From the Options menu, choose Preferences, then
choose the Grid Display tab.

2 For the schematic page editor and the part editor,
specify:

e  Whether to display the grid.
e  Whether the grid uses dots or lines.

¢  Whether the pointer snaps to grid as you place
objects.

3 Click OK.
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Setting pan and zoom

When you have an object attached to the pointer and you
move the pointer near the edge of the window while
holding the left mouse button down, the display changes
to a different region of the document. This change is called
panning. The display automatically pans only if you hold
the left mouse button down whether or not an object is
attached to the pointer; otherwise, you must use the
window’s scroll buttons to view a different region of the
document. You configure the percent by which the
display changes using the Auto Scroll Percent setting.

When you zoom in or out, the view changes by the zoom
factor. You can define pan and zoom settings for the
schematic page editor and the part editor independently.

Figure 20 Pan and Zoom tab of the Preferences dialog box
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To configure zoom factor and auto scroll percent

1 From the Options menu, choose Preferences, then
choose the Pan and Zoom tab.

2 For the schematic page editor and the part editor, set
these options:

e Zoom Factor. Enter an integer to indicate the
magnification or reduction of the objects shown in
the window when you zoom in or zoom out. This
number is a multiplier for each time you zoom in

or out.
Tip You can also auto scroll without an e Auto Scroll Percent. Enter the percent of the
obl'ed aﬂathed fo fhe poinfer by pressing window’s horizontal or vertical dimension by
the left mouse button as the pointer which the display will scroll when the pointer
approaches the edge of the window. approaches the edge of the window with an object
attached.
3 Click OK.
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Defining selection options

You can specify whether objects are selected when the
selection border intersects them or if the objects are
selected only when they are completely enclosed in the
selection area. You can also change the maximum number
of objects displayed at high resolution while dragging,
and set tool palette visibility in both the schematic page
editor, and the part and symbol editor.

Figure 21 Select tab of the Preferences dialog box

To define selection options

1 From the Options menu, choose Preferences, then
choose the Select tab.

2 For the schematic page editor and the part editor, set
these options:

e Area Select. Specify whether to select objects that
are inside and intersecting the selection border or
only objects that are fully enclosed by the selection
border.
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Note Capture may perform slower if you e Maximum number of objects to display at high

set the Maximum number of objects fo resolution while dragging. If you drag more

display at high resolution while dragging to objects than you specify here, you will see

a large number. rectangular placeholders for the objects as you
drag them.

e Show Palette. Select this check box to make the
tool palette visible; deselect it to make the tool
palette invisible.

3 Click OK.
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Setting miscellaneous options

You can specify the default fill, line style and width, and
color for graphics objects, define the font used in the
project manager and session log, render TrueType fonts
with strokes (for printing and plotting), and set whether to
enable auto recovery for your project and how often. In
addition, you can enable intertool communication, which
is the method that Capture uses to communicate with
other OrCAD software, such as OrCAD Express, OrCAD
PSpice, and OrCAD Layout.

Figure 22 Miscellaneous tab of the Preferences dialog box

To set miscellaneous options

1 From the Options menu, choose Preferences, then
choose the Miscellaneous tab.

2 For the schematic page editor and the part editor, set
these options:

e Fill Style. Select the fill pattern to be used when
drawing rectangles, ellipses, and closed shapes
drawn with the polyline tool.

You can change the fill style, line style and
width, and color on graphic objects on an
individual basis once they are drawn on a
schematic page. Select the object, then
from the Edit menu, choose Properties. For
specific instructions, see Chapter 8, Adding
and editing graphics and text.

For information about intertool
communication between Capture and
Layout, see Chapter 18, Using Capture with
0rCAD Layout.

For information about intertool
communication between Capture and
PSpice, see Chapter 19, Using Capture with
0rCAD PSpice.

For information about intertool
communication between Capture and
Simulate in OrCAD Express, see Chapter 4,
Functional simulation in the Express User’s
Guide.
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Note The Default color is the color
defined in the Graphics box in the
Colors/Print tab in the Preferences dialog
box.

Grapbhics objects use the colors specified by
Miscellaneous tab. If the color options in the
Miscellaneous tab are set to Default color,
then Capture uses the color specified by the
Colors/Print tab.

Tip The Render TrueType fonts with
strokes option produces fext that is printed
or plotted quickly, but is not as aesthetically
pleasing as TrueType text. For this reason,
you may want to enable the option when
you print or plot drafts of your schematic
pages, then disable the option when you
print or plot the final versions of your
schematic pages.
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Line Style and Width. Select the line style and
width used for lines, polylines, rectangles, ellipses,
and arcs.

3 For the schematic page editor, set this option:

Color. Select the color used for graphic objects
(rectangles, ellipses, and closed polylines).

4 Set the following options:

Project Manager and Session Log. Select a font for
display text in the project manager and session log.
If you select this option, a standard Windows

dialog box for font selection appears. Select a font,
style, and size from the dialog box, then click OK.

Text Rendering. The text rendering options affect
how text on a schematic page appears on your
screen, and how it is printed or plotted. The
Render TrueType fonts with strokes option
displays text as a series of lines, connected to
resemble the outlines of the corresponding
TrueType letters or numbers they represent.
Enabling the Fill text option causes the text
outlines to be filled in.
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e Auto Recovery. Select whether to enable auto
recovery for your project and, if so, the interval
between saves. You can specify any interval
between five minutes and 120 minutes. When the
time interval is up, any design, library, or VHDL
file in your project that hasn’t been saved, or has
been modified since the last save, is saved as a
temporary file (with an .ASP extension) in the
WINDOWS/TEMP /AUTOSAVE directory.
When you close your project normally, the
/ AUTOSAVE directory and temporary files are
deleted. In cases of power outages or system
crashes, however, the temporary files are saved.
When you restart Capture, it loads the auto
recovered files, showing “Restored” in their title
bars. You must use the Save As command and
provide a filename to have an auto recovered file
overwrite the original file.

e Auto Reference. Select whether to enable
automatic annotating of reference designators
when parts are placed.

¢ Intertool Communication. Select whether to
enable intertool communication (also known as
ITC), so that you can test and display design
information using other OrCAD software (such as
Layout, PSpice, and Express) in conjunction with
Capture. Capture processes its tools faster when
intertool communication is not selected.

5 Click OK.
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Note The Highlight Keywords, Comments,
and Quoted Strings option must be enabled
for Capture fo use the syntax highlighting
opfions.
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f Preferences

Setting text editor options

Capture’s text editor options include automatic
highlighting of VHDL keywords, comments, or quoted
strings. You can also set the font, the tab spacing, and
enable or disable the highlighting feature.

Figure 23 Text Editor tab of the Preferences dialog box

To set text editor options

1 From the Options menu, choose Preferences, then
choose the Text Editor tab.

N

Set these options:

Syntax Highlighting. Select the color to use to
highlight VHDL keywords, comments, and
quoted strings. You can choose a different color for
each.

¢ Current Font Setting. Click Set to change the font
setting for the text editor to values other than those
displayed.

e Tab Spacing. Set the tab spacing for the text editor.
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3 Check the Highlight Keywords, Comments, and
Quoted Strings option to have those VHDL items
highlighted in the text editor. The colors used to
highlight these items are the ones set in the Syntax
Highlighting group box.

4 If you want to reset the text editor options to the
Capture default values, click the Reset button.

5 Click OK.
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Setting up your project template

The options that you define in the Design Template dialog
box are the default settings for all new projects, and for
schematic pages you add to an existing project. You can
override some of these options for individual projects or
schematic pages. Some of the things you can define in the
Design Template dialog box are:

66

Fonts. You can define the fonts for schematic page
objects that contain text, such as part references and
values.

Title Block. You can specify the text to appear in title
block fields, as well as the path and filename of the
library containing the title block. This affects new
projects, as well as new schematic pages in existing
projects.

Page Size. You can specify whether inches or
millimeters are used as the unit of measure, the width
and height of a schematic page, and the spacing
between pins.

Grid Reference. For horizontal and vertical border
grid references, you can set the number of border grid
references to display in either direction, whether the
grid references are alphabetic or numeric, whether
they increment or decrement across the schematic
page, and how wide grid reference cells are. You can
also make the border, grid references, and title block
visible or invisible. This affects new projects, as well as
new schematic pages in existing projects.

Hierarchy. For hierarchical blocks and part instances
that have their Primitive property set to Default, you
can specify if you want Capture to treat each as
primitive (cannot descend into attached schematic
folders) or nonprimitive (can descend into attached
schematic folders).

SDT Compatibility. You can specify which Capture
properties map to which OrCAD Schematic Design
Tools (SDT) part fields when saving a project in SDT
format.
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Setting up fonts for new projects

You can define the fonts assigned to the text associated
with different schematic page objects in new designs. The
fonts specified here do not affect existing designs.

f Design Template

Figure 24 Fonts tab of the Design Template dialog box
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1 From the Options menu, choose Design Template,
then choose the Fonts tab.

2 Click the left mouse button on the font of an item. A
standard Windows font dialog box appears.

3 Select a font, font style, and size. Click OK to dismiss
the font dialog box.

4 Click OK.

To change the fonts for an existing project,
use the Fonts tab in the Design Properfies
dialog box. You can access this dialog box
by choosing Design Properties from the
project manager’s Optfions menu.

The default fonts were selected for optimal
compatibility with SDT. Changing these
fonts may result in less optimal fext sizes
for translated projects.
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Defining title block information

There are two types of title blocks: default and optional.

* You specify the information that goes into the default
title block in the Title Block tab of the Design Template
dialog box. Capture places a default title block in the
lower right corner of each schematic page (if a library
and title block name are specified), and places the
information you enter in the text fields in the Title
Block tab into the title block. This information is also
used in reports created by the commands on the Tools
menu. This affects new projects, as well as new
schematic pages in existing projects. You can set the
default title block to be visible or invisible on an
existing schematic page by changing the setting in the
Grid References tab in the Schematic Page Properties
dialog box.

® You can place any number of optional title blocks
anywhere on the schematic page using the Title Block
command on the Place menu. Optional title blocks
display information that you define as property
values for the title block symbol.

E Design Template

TitleBlockO

Figure 25 Title Block tab of the Design Template dialog box
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Capture provides default title block symbols in the
CAPSYM.OLB library. One such title block is shown
below. The text shown in curly braces acts as property text
placeholders. You can specify the value by
double-clicking on the text and supplying a value. You
can control the visibility by selecting or deselecting the
Visible check box in the Display Properties dialog box.

[Soesiont PaGE BRI

OrgName}
OrgAddri}
ize Document Number Rev
A {Doc} {ReviCode}
Date: _Monday, Aoril 01, 1996 heet 0 of 0

Figure 26 Title block

To choose a title block and define the text it contains

1 From the Options menu, choose Design Template,
then choose the Title Block tab.

2 Inthe Text group box, enter the information you want
to appear in the title block.

3 In the Symbol group box, enter the path and filename
of the library containing the title block.

a The Library Name text box can be left blank if you
are using title block from the CAPSYM.OLB
library and CAPSYM.OLB has not been moved to
a different directory from where it was installed.

b If you are using a custom title block, then put the
full path and file name for the library in the
Library Name text box.

4 Enter the exact name of the title block into the Title
Block Name text box. Symbol names are case sensitive
and space sensitive.

5 Click OK.

You can access the Display Properties
dialog box by following these steps:

1 Double-dlick on the property.
or

1 Double-click the object containing the
property.

2 Select the property in the property
editor, and click Display.

You can create custom fitle blocks and store
them in a library using the New Symbol
command from the project manager’s
Design menu. If you specify the name of
the custom library and title block in the
Symbol group box of the Design Template’s
Title Block tab, the custom fitle block
appears in the lower right corner of each
new schematic page. See Capture’s online
help for specific instructions.

For Capture to automatically place the
information you entered in the text fields
into your custom title block, you must give
your custom title block the appropriate
properties. See the topic Creating a custom
fitle block in Capture’s online help for more
information.
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You can select a different unit of measure
or page size (A, B, C, D, E, and Custom if the
unit of measure is Inches; or A4, A3, A2,
A1, A0, and Custom if the unit of measure
is Millimeters) for individual schematic
pages in existing projects. Choose
Schematic Page Properties from the
schematic page editor’s Options menu, and
use the Page Size tab.

Caution Changing from Inches to
Millimeters resets the page sizes o their
defaults; therefore, if you make any
changes to the standard page size
dimensions, then change the units, the
page size changes are nof translated
between the two types of units.
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Setting the schematic page size for new projects

For new projects, you can specify the default unit of
measure, the default width and height of schematic pages,
and the spacing between pins. The value you enter in the
Pin-to-Pin Spacing text box defines how close together
pins are placed in the part editor. It also defines the grid
spacing (the space between grid dots or grid lines)

esign Template

Figure 27 Page Size tab of the Design Template dialog box

To set up the schematic page size

1 From the Options menu, choose Design Template,
then choose the Page Size tab.

2 Inthe Units area, select the default unit of measure for
new projects. This setting only affects the schematic
page editor, not the part editor.
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3 Select the default schematic page size for new projects.
For each schematic page size (A, B, C, D, E, and
Custom if the unit of measure is Inches; or A4, A3, A2,
A1, AO, and Custom if the unit of measure is
Millimeters) you can specify the width and height. The
values that you enter in the Width and Height text
boxes become the dimensions for each page size. You
cannot change these dimensions for individual
schematic pages, although you can select a different
page size, or choose to define a custom size.

4 In the Pin-to-Pin Spacing text box, specify the default ~ Note Partsize will vary when copying and
spacing between pins. The value you enter in this text pasting parts between pages with different
box defines how close together pins are when you pin-to-pin spacings.
place a part on a schematic page. It also defines the
grid spacing (the space between grid dots or grid
lines). You cannot change this value for existing
projects or individual schematic pages.

5 Click OK.

71



Chapter 4 Setting up your project

You can change these settings for existing
schematic pages. Choose Schematic Page
Properties from the schematic page editor’s
Options menu, then choose the Grid
Reference tab in the Schematic Page
Properties dialog box.

Note The size of the Grid Reference font
is tied to the width.
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Defining the grid reference

You set the border’s grid references to display either
horizontally or vertically, alphabetically or numerically,
incrementally or decrementally across the schematic page,
and the width of their cells. You can also make the border,
grid references, and title block visible or invisible on the
screen and on schematic pages you print. The settings
affect new projects and new schematic pages in existing
projects.

Figure 28 Grid Reference tab of the Design Template dialog box

To define the grid reference

1 From the Options menu, choose Design Template,
then choose the Grid Reference tab.

2 Specify the number of border grid references, whether
they are alphabetic or numeric, whether the grid
references increment (Ascending) or decrement
(Descending) across the schematic page, and how
wide the grid reference cells are.
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3 For the border, title block, and grid reference, select
Displayed to have the item display on the screen or
Printed to have the item appear on schematic pages
you print. Select ANSI grid references to display the
grid references in accordance with ANSI standards
(see the glossary entry ANSI).

4 Click OK.

73



Chapter 4 Setting up your project

Note You can change the hierarchy
option for existing projects using the
Hierarchy tab in the Design Properties
dialog box. Choose Design Properties from
the project manager’s Options men.

For more information, see Primitive and
nonprimitive parts on page 192.
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Defining the default hierarchy option for new
projects

For hierarchical blocks and part instances that have their
Primitive property set to Default, you can specify if you
want Capture to treat each as primitive (cannot descend
into attached schematic folders) or nonprimitive (can
descend into attached schematic folders). The Primitive
and Nonprimitive options in the Hierarchy tab of the
Design Template dialog box only affect new projects.

Note that this setting affects how the options on the Tools
menu process projects.

esign Template

Figure 29 Hierarchy tab of the Design Template dialog box

To define the default hierarchy option

1 From the Options menu, choose Design Template,
then choose the Hierarchy tab.

2 For hierarchical blocks and parts, select Primitive or
Nonprimitive. All hierarchical blocks and part
instances that have their Primitive property set to
Default will use the setting selected here.

3 Click OK.
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Setting up compatibility with OrCAD’s Schematic
Design Tools

You can specify which properties Capture stores in the

eight SDT part fields when saving a project in SDT format.

In the dialog box shown below, the part fields listed on the
left are SDT’s part fields. The text boxes on the right are
used to specify which of Capture’s properties map to the
part fields in SDT. The options in the SDT Compatibility
tab of the Design Template dialog box only affect new
projects.

PCE Foolpin

Figure 30 SDT Compatibility tab of the Design Template dialog
box

To set up compatibility with OrCAD’s Schematic Design Tools

1 From the Options menu, choose Design Template,
then choose the SDT Compatibility tab.

2 For each Capture property you want mapped to an
SDT part field, specify the part field to contain the
property value.

3 Click OK.

0rCAD’s Schematic Design Tools

(SDT 386+) was 0rCAD’s DOS-based
schematic capture program.

Note You can also use the part fields for
mapping netlists that use part field
information. For information on creating
these types of netlists and the combined
property strings they require, see the
Capture online help.

Tip To change the part field to property
mapping for existing projects, use the SDT
Compatibility tab in the Design Properties
dialog box (from the project manager’s
Options menu, choose Design Properties).
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You can override other Design Template
options (page size and grid reference)
using the Schematic Page Properties dialog
box. For further information, see Changing
properties of existing schematic pages on
page 80.

To get fo the Design Properties option, you
must select either the design name, a
schematic folder, or a schematic page in the
project manager.
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Chunging properties of existing

projects

When you create a new project, it uses the options defined
in the Design Template dialog box. You can set the options
on existing projects using the Design Properties dialog
box (from the project manager’s Options menu). The
options are:

¢ Fonts. You can define the fonts for schematic page
objects that contain text, such as part references and
part values.

e Hierarchy. You can specify hierarchical blocks and
part instances whose Primitive property is set to
Default be treated as primitive (cannot descend into
attached schematic folders) or nonprimitive (can
descend into attached schematic folders).

e SDT Compatibility. You can specify which Capture
properties map to which SDT part fields when saving
the design in SDT format.

e Miscellaneous. You can view the project name, root
schematic folder name, creation time, and
modification time. Also, if you need to see the power
pins on a schematic page for documentation or
debugging purposes, you can display them on the
screen.
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Assigning fonts

Fonts are assigned to new projects using the Fonts tab in
the Design Template dialog box. You can change fonts for
existing projects using the Fonts tab in the Design
Properties dialog box (choose Design Properties from the
project manager’s Options menu). When you change the
settings for the fonts in Design Properties, all affected text
which is set to the default font will be changed. If you have
assigned a unique font to any piece of text in the design,
these will not be affected by changing the default font. See
Setting up fonts for new projects on page 67 for more
information.

Defining hierarchy

The behavior for hierarchical blocks and part instances
whose Primitive property is set to Default (whether to act
as primitive or nonprimitive) is defined for new projects
using the Hierarchy tab in the Design Template dialog
box. You can change this behavior for individual projects
using the Hierarchy tab in the Design Properties dialog
box (choose Design Properties from the project manager’s
Options menu). See Defining the default hierarchy option for
new projects on page 74 for more information.

Using Capture with SDT

The mapping of Schematic Design Tools to Capture
properties for new projects is defined using the SDT
Compatibility tab in the Design Template dialog box. You
can change this mapping for individual projects using the
SDT Compeatibility tab in the Design Properties dialog box
(choose Design Properties from the project manager’s
Options menu). See Setting up compatibility with OrCAD’s
Schematic Design Tools on page 75 for more information.
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Viewing design information

Capture displays the following information about the
active schematic page in the Miscellaneous tab of the
Schematic Page Properties dialog box:

¢ The path and file name of the design
e The name of the root schematic in the design
e The creation time of your schematic page

e The last time your schematic page was modified

Figure 31 Miscellaneous tab of the Design Properties dialog box

You can also set Capture to display power pins for the
purpose of documentation. For more information, see
Viewing invisible power pins without isolating them on
page 79.

78



Changing properties of existing projects

Viewing invisible power pins without isolating them

Normally, power pins are invisible, and thus global.
Selecting the Display Invisible Power Pins (for
documentation purposes only) option in the
Miscellaneous tab will display the pins on the screen, and
they are still considered global. However, you can only
view the power pins—you cannot connect to them.

To view invisible power pins without isolating them

1 From the project manager’s Options menu, choose
Design Properties, then choose the Miscellaneous tab.

2  Select the Display Invisible Power Pins option.
3 Click OK.

Note To connect wires and other electrical
objects to power pins, you must make them
visible on the part or instance. Select the
part and then, from the Edit menu, choose
Properties. Select the Power Pins Visible
option and click OK. If you connect a wire or
other electrical object to a power pin made
visible by this method, that pin is isolated
from the global net.
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You can override other Design Template
options (fonts, hierarchy, and SDT
compatibility) using the Design Properties
dialog box. For further information, see
Changing properties of existing projects on
page 76.
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Changing properties of existing
schematic pages

When you add a new schematic page, the options defined
in the Design Template dialog box are used. You can
override these options on existing schematic pages by
using the options in the Schematic Page Properties dialog
box. You access this dialog box by choosing Schematic
Page Properties from the schematic page editor’s Options
menu. The options in the Schematic Page Properties
dialog box are:

e Page Size. You can specify the unit of measure and the
page size.

e Grid Reference. You can set the number of horizontal
or vertical border grid references to display, whether
the grid references are alphabetic or numeric, whether
they increment or decrement across the schematic
page, and how wide the grid reference cells are. You
can also make the border, grid references, and title
block visible or invisible.

e Miscellaneous. You can view information about the
schematic page, such as creation time, modification
time, and page number.

Changing page size

For existing schematic pages, you can change the unit of
measure from Inches to Millimeters or select a different
page size. Since the width and height for each page size
(except Custom) and the pin-to-pin spacing are set in the
Design Template Page Size tab, you cannot change these
particular items in the Schematic Page Properties Page
Size tab. You can access the Schematic Page Properties
dialog box by choosing Schematic Page Properties from
the schematic page editor’s Options menu. See Setting the
schematic page size for new projects on page 70, for more
information.
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Setting up new grid references

Horizontal and vertical border grid references for new
schematic pages are set up in the Grid Reference tab of the
Design Template dialog box. You can change these
settings for existing schematic pages using the Grid
Reference tab in the Schematic Page Properties dialog box
(choose Schematic Page Properties from the schematic
page editor’s Options menu). See Defining the grid reference
on page 72 for more information.

Viewing miscellaneous schematic page properties

The Miscellaneous tab in the Schematic Page Properties
dialog box displays the creation time and the last
modification time of the schematic page, as well as the
page number.

| S chematic Page Properties

Figure 32 Miscellaneous tab of the Schematic Page Properties
dialog box
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To view miscellaneous schematic page properties

1 From the schematic page editor’s Options menu,
choose Schematic Page Properties, then choose the
Miscellaneous tab.

2 Whenyou are done viewing the information, click OK.
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Printing and plotting

To send output to a printer, a plotter, or an encapsulated Note C(apture can send output to any

PostScript® file, use the standard Windows Print Setup, print driver that Windows supports. For

Print Preview, and Print dialog boxes. additional information on print drivers, see

Printing commands can be chosen from the File menu in ”",’ documentation included with Microsoft
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editor. You can print schematic pages, parts, or packages.

To configure a printer or plotter

1 From the File menu, choose the Print Setup command. Note To install and remove printers and
Select an appropriate printer or plotter, or change the  plotfers, and to set additional printing
printer settings if necessary, and then click OK. options, see the documentation included

with Microsoft Windows regarding the
Windows Control Panel.
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Printing or plotting schematic
pages

You can print or plot a schematic page, or several
schematic pages, from the project manager.

To print or plot a schematic page or pages

Activate the schematic page editor window for the
page you want to print.

or

In the project manager, select the schematic page or
pages.

or

If you want to print all the pages in the design, select
the design name in the project manager.

From the File menu, choose Print. The Print dialog box
appears.

Select the scale, print offsets, print quality, number of
copies, and whether to print to file.

Click OK to send the image to the output device.



Printing or plotting parts or packages

Printing or plotting parts or
packages

With the part editor active and open to a specific part or
package, you can create a print or a plot of that part or
package. You can also print a library part from the project
manager.

To print or plot a part or package

1 Select the part or package you want to print in the
schematic page editor.
or
Select the library part in the project manager.

2 Click the right mouse button in the project manager,
and choose Edit Part from the pop-up menu. The part
appears in the part editor.

3 From the parteditor’s View menu, choose Part to print
a part or choose Package to print a package.

4 From the File menu, choose Print. The Print dialog box
appears.

5 Select the scale, the print quality, and the number of
copies.

6 Click OK to send the image to the output device.

85



Chapter 5  Printing and plotfing

86

Printing the session log and text
editor windows

With the text editor window or session log active, you can
print the contents of the window.

To print a text editor window

1
2

4

Make the text editor the active window.

From the File menu, choose Print. The Print Range
Selection dialog box appears.

Select whether to print highlighted text or the entire
file.

Click OK to send the text to the output device.

To print the session log

1
2

Make the session log the active window.

From the File menu, choose Print. The Print dialog box
appears.

Click OK to send the text to the output device.



Previewing printer or plotter output

Previewing printer or plotter
output

Using the Print Preview command, you can preview your
schematic page, part, or package output to check its
appearance before you commit it to paper.

To preview a schematic page

From the File menu, choose Print Preview. The Print
Preview dialog box appears.

Specify appropriate values in the dialog box, and then
click OK. The Print Preview display window opens
with a display of your schematic page, part, or
package.

Use the Previous page and Next page buttons to view
other pages you intend to print.

To zoom in, move the magnifier pointer to a specific
area and click the left mouse button.

Choose the Close button to close the Print Preview
window.

Choose the Print button to send the page or pages to
the output device, using the defaults set in the Print
Setup dialog box.
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Scaling printer or plotter output

You can manually scale, or have Capture automatically
scale, printer output and plots to fit a given paper size.

To scale a print or a plot

1

From the File menu, choose Print. The Print dialog box
appears.

Select one of the three options in the Scale box.

o The Scale to paper size option scales each
schematic page to fit a single sheet of paper (as
configured in the printer driver).

e The Scale to page size option scales each schematic
page to the sheet size you select in the Page size
area. The sheet size is configured in the Page Size
tab in the Design Template dialog box.

¢ The Scaling option scales your schematic page to a
factor between 0.100 and 10.000.

If you select the Scale to page size option in step 2, the
Page size area becomes available. Select a sheet size.
This results in multiple sheets of paper if you select a
sheet size larger than your printer paper.

Click OK to print the image.



Special considerations for plotting

Special considerations for
plotting

Vector (pen) plotters do not support bitmaps directly. If
you are sending Capture output to such a plotter, it will
not plot your bitmaps. Most inkjet and thermal plotters
will plot bitmaps.

Plotter pen colors

The plotter driver maps your color choice to the closest
available pen color as established in your plotter driver
configuration. See your plotter’s driver setup and
documentation for more details.

Many plotters do not have drivers that ship with
Windows. If you do not see the plotter you are looking for
in the list of available drivers, contact your plotter
manufacturer and ask for a Windows driver. If your
plotter emulates HPGL, use the HPGL driver as an
alternative solution.

Tip Vector-based plotters tend to produce
higher quality output than raster-based
prinfers.

Note The plotter setup dialog boxes are
only accessible from the Windows Control
Panel. See the documentation included with
Microsoft Windows regarding the Windows
Control Panel.
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Part Two

Creating designs

Chapter 6, Design structure, describes how to customize the
working environment specific to your system, how to
create default settings for new designs, and how to
override default settings in individual designs.

Chapter 7, Placing, editing, and connecting parts and electrical
symbols, describes how to place and edit parts and
symbols. It also describes how to connect the elements of
your design using hierarchical blocks, hierarchical ports,
off-page connectors, wires, and buses.

Chapter 8, Adding and editing graphics and text, describes the
drawing tools you can use to add text and a variety of
graphic shapes to your design.

Chapter 9, Using macros, describes how to create and run
macros.

Chapter 10, Changing your view of a schematic page, describes
how to view specific areas of a schematic page using the
Zoom command. It also describes jumping to different
locations within a schematic using the Location,
Reference, and Bookmark commands.






Design structure

Many schematic designs can fit on one schematic page.
Some designs, however, are too large for even the biggest
page, and even if a complex design could fit on one page,
there are good reasons for dividing it:

To fit at full scale on your printer’s page.

To partition a design so that several people can work
on it at once.

To develop the design using a top-down approach.
That is, you may want to begin with a block diagram
in which each block represents a major function and
then construct more detailed diagrams for each block.

To organize your design by functional parts.

To meet department specifications.

Capture offers two ways of handling multiple-page
designs: a flat design structure and a hierarchical design
structure.
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Schematic Page A Schematic Page B Schematic Page C

& » & »
» R | «

_, Test; opl

- CO
: Mtest.dsn
SCHEMATIC1
‘ PAGE1
PAGE2
EE]C] Design Cache
O Library
[ Outputs

94

Flat designs

Flat designs are practical for small designs with few
schematic pages. A flat design is a structure in which the
output nets of one schematic page connect laterally to the
input nets of another schematic page in the same
schematic folder through objects called off-page connectors.
A flat design has no hierarchy (no hierarchical blocks,
hierarchical ports, hierarchical pins, or parts with attached
schematic folders). The structure of a flat design is shown
to the left.

All schematic pages in a flat design are contained within a
single schematic folder, and are on a single level, as shown
at left. In the figure, SCHEMATIC1 is a schematic folder.

It contains schematic pages named PAGE1 and PAGE2.

Since you must manage all of the interconnections
between the pages of a flat design using names assigned
to off-page connectors, it is best to keep a flat design
relatively small.



Hierarchical designs

Hierarchical designs

You can create symbols on schematic pages that represent
other schematic folders. These symbols are called
hierarchical blocks. The layered arrangement created by
placing schematic folders inside schematic pages is called
a hierarchy.

Any schematic page can contain hierarchical blocks (or
parts with attached schematic folders) that refer to other
schematic folders; a design’s structure can be many levels
deep. The schematic folder at the top of a hierarchy, which
directly or indirectly refers to all other schematic folders
in the project, is called the root module.

In the project manager, the root module has a backslash in
its folder icon. The root module, as well as any other
schematic folder, can contain as many schematic pages as
you need.

Simple hierarchical designs

Schematic A

\
0
4 K

Schematic B Schematic C

) JrELN
r's e N

Schematic D Schematic E Schematic F

Figure 33 An abstract representation of a simple hierarchy.

Tip Ifyou intend to take your design into
a digital simulator like OrCAD Express and
OrCAD PSpice, it is best to place only one
schematic page in each lower level
schematic folder. This may reduce problems
you encounter while troubleshooting your
designs.
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A one-to-one correspondence between hierarchical blocks
(or parts with attached schematic folders) and the
schematic folders they reference is called a simple hierarchy
(Figure 34).

In a simple hierarchy, each hierarchical block or part with
an attached schematic folder represents a unique
UG, [?4[.508] SChematiC fOlder.

H1 (SCHEMATICA)
[3] U4 [74L508)
U2A [74L508)

134 [74LS08)

HO [SCHEMATICB)
4, [74L508)

Figure 34 A simple hierarchical design,
as seen in the project manager
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Complex hierarchies

A many-to-one correspondence between hierarchical
blocks (or parts with attached schematic folders) and the
schematic folders they reference is called a complex
hierarchy. In Figure 35, schematic A references schematic B
three different times. These references can be via
hierarchical blocks or parts with attached schematic
folders.

Figure 36 shows a complex hierarchical design as seen on
the Hierarchy tab of the Capture project manager.

Schematic A

B

—&

Schematic B

Figure 35 An abstract representation of
a complex hierarchy

U1A (74L508)
U1B (74L508)
U1C (74L508)
U24 (74L504)
U2B (74L504)

L34 (74L532)
HALFADD_B (Ex6B) ||
. U1D (74L508) |
U2C (74L504)
2D (74L504)
U3B (74L532)
44 (74LS08)
. U4B (74LS08)
-[Bl U3C(74L532)

Figure 36 A complex hierarchical
design, as seen in the project manager
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For information about placing hierarchical
blocks, hierarchical ports, hierarchical pins,
and off-page connectors, see Chapter 7,
Placing, editing, and connecting parts and
electrical symbols.

| 5 FULLADD.DSN - FULLADD.SCH B[] 3 |

halfadd_A

SUM &
CARRY

CARRY_IN [

Note Before you create or resize a
hierarchical block, make sure the Snap to
grid option is turned on (by choosing
Preferences from the Options menu). If the
hierarchical block is off grid, then
hierarchical pins inside it are also off
grid— even if you change the Snap to grid
setting before you place them — and it
may be difficult to connect to these off-grid
hierarchical pins.
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Connecting schematic folders and
schematic pages

In Capture, you connect schematic folders and schematic
pages by extending nets between them using hierarchical
blocks (or parts with attached schematic folders),
hierarchical ports, hierarchical pins, and off-page
connectors. Hierarchical blocks (or parts with attached
schematic folders), hierarchical ports, and hierarchical
pins carry signals between schematic folders and
schematic pages in a hierarchy, while off-page connectors
carry signals between schematic pages within a single
schematic folder of a flat design.

Hierarchical blocks

Hierarchical blocks (or parts with attached schematic
folders) refer to child schematics in a design, providing
vertical (dlownward-pointing) connection only.
Hierarchical pins in a hierarchical block, and hierarchical
ports outside a hierarchical block, act as points of
attachment for electrical connections between the
hierarchical block and other electrical objects in an
attached schematic folder. The picture at left shows
hierarchical pins (X, Y, SUM, and CARRY) within a
hierarchical block, and a hierarchical port (CARRY_IN)
outside a hierarchical block.

A part with an attached schematic folder functions like a
hierarchical block, and pins on a part with an attached
schematic folder function like hierarchical pins within a
hierarchical block. You can use either method to define a
hierarchy. The only difference between the methods is
that a part with an attached schematic folder can be
reused.



Connecting schematic folders and schematic pages

You can attach a schematic folder that is external to a
project to a hierarchical block, but be aware that you won’t
be able to use any of Capture’s tools to make changes to
the external design unless you explicitly open that
external design.

Caution If you incorporate an external schematic folder into a hierarchical
block, include the schematic folder when you give the project to
another engineer or to a board fabrication house. Attached
schematic folders external to a project do not automatically
accompany schematic folders that you copy or move to another
project. For this reason, you should copy all attached schematic
folders into your project if you want your project to be “portable.”

Hierarchical ports

Hierarchical ports provide vertical (upward-connecting)
and lateral connections within a design hierarchy. A
hierarchical port connects vertically to a like-named
hierarchical pin inside a hierarchical block, and connects
laterally to like-named nets in the same schematic page,
and hierarchical ports within the same schematic folder.

Hierarchical pins

Hierarchical pins provide vertical (downward-pointing)
connections only. You connect them by name to
hierarchical ports on schematic pages in an attached
schematic folder. Think of hierarchical pins as bringing a
net “up” from an attached schematic folder into the
hierarchical block, but not out onto the schematic page. In
the figure shown, X, Y, SUM and CARRY represent
hierarchical pins.

[ % DESIGNT - PAGE1 )
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1 =] PORTLEFT-L
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Off-page connectors

Off-page connectors provide connection between
schematic pages within the same schematic folder. An
off-page connector is connected by name to other off-page
connectors within the same schematic folder. Like-named
off-page connectors in different schematic folders are not
connected.



An example: creating a simple hierarchy

An example: creating a simple
hierarchy

As described earlier in this chapter, you connect schematic
folders and schematic pages by extending nets between
them using off-page connectors, hierarchical ports, and
hierarchical pins in hierarchical blocks. Off-page
connectors carry nets between schematic pages within a
single schematic folder. Hierarchical blocks, hierarchical
ports, and hierarchical pins carry nets between schematic
folders, which need not be in the same design.

The rest of this section contains an example of how to use
off-page connectors, hierarchical ports, hierarchical pins,
and hierarchical blocks to create a simple hierarchy.

Figure 37 shows two schematic folders (Sch. A and
Sch. B), each with two schematic pages. The schematic
folder marked with a backslash (\) is called the root
module.

To establish a hierarchy with schematic folder A positioned
“above” schematic folder B:

Figure 38 illustrates the schematics with hierarchy
established.

1 Place a hierarchical block on schematic page 1.

2 In the Place Hierarchical Block dialog box, set the
following options to attach schematic folder B:

e Type in a reference.

e Select Schematic View for the Implementation
Type.
e Type in Sch.B as the Implementation Name.

Note For information about placing
hierarchical blocks, hierarchical ports,
hierarchical pins, and off-page connectors,
see Chapter 7, Placing, editing, and
connecting parts and electrical symbols.

=3
=747

Sch. Pg. 1 Sch. Pg. 2
SCh.B/ / / /
Sch. Pg. 3 Sch. Pg. 4

Figure 37 Schematics before hierarchy

]

Sch. Pg. 3 Sch. Pg. 4

Figure 38 Schematics with hierarchy
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B

Sch. Pg. 3

Sch. Pg. 4

Figure 39 Schematics carrying a net

Sch. Pg. 2

ST

Figure 40 Connectivity across pages in a

schematic

102

Sch. Pg. 3

Sch. Pg. 4

To carry a net between schematic folder A and schematic folder B:

Figure 39 illustrates the schematics carrying a net between
them.

1 Select the hierarchical block on schematic page 1 and
place a hierarchical pin named “X” inside it.

The hierarchical pin is a point of attachment for
electrical connections between the hierarchical block
and other objects on schematic page 1.

2 Place a hierarchical port named “X” on schematic
page 3.
The hierarchical port is a point of attachment for
electrical connections between schematic page 3 and
other schematic pages within schematic folder B. It is
connected by name to the hierarchical pin inside the
hierarchical block on schematic page 1.

Hierarchical ports generally carry a net “up” through a
hierarchy. In a root module, they usually represent
external signals, such as a hierarchical block in another
project.

The two hierarchical ports added to schematic folder A
are electrically connected to each other by the name “Y,”
so any electrical objects (such as power or ground
symbols) on schematic pages 1 and 2 named “Y” are part
of the net named “Y.” You could make both of these
hierarchical ports off-page connectors without affecting
the electrical connections. Figure 40 illustrates this
electrical connectivity across pages in a schematic.

To connect the schematic pages in schematic folder B,
place a hierarchical port named “X” on schematic page 4.
Any like-named electrical objects on schematic pages 3
and 4 are now part of a single net named “X.”

To connect the “X” nets in schematic folder B and the “Y”
nets in schematic folder A, you cannot simply rename one
set of objects to match the other set of objects. Remember,
the hierarchical pin “X” inside the hierarchical block on
schematic page 1 does not bring net “X” out onto
schematic page 1. You must physically connect
hierarchical pin “X” to net “Y” in order to join the two
nets.



Placing, editing, and
connecting parts and electrical
symbols

Capture includes libraries containing parts, power
symbols, and ground symbols. You can place instances of
these objects on a schematic page. Once you place a part,
you can edit its appearance, properties, or location. Once
you have placed a power or ground symbol, you can
rotate it or edit its name.

This chapter contains information about placing and
editing objects from Capture libraries. It also explains how
to connect these objects using wires and buses.

| 9 CMOSCPU.DSN - POWER.SCH
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Capture libraries also include symbols used to establish
connectivity between schematic pages. You use off-page
connectors to connect signals between schematic pages
within a schematic folder. You use hierarchical blocks,
hierarchical ports, and hierarchical pins to connect signals
from one schematic folder to another, or from an attached
schematic folder. See An example: creating a simple hierarchy
on page 101 for more information on working with
connectivity across schematic pages.

Wires and buses are used to conduct signals between
parts and electrical objects. Nets are made up of one or
more wires; a bus represents multiple signals or nets.



Placing and edifing parts

Placing and editing parts

Capture includes libraries with a total of over 30,000 parts
that you can use on your schematic pages. You can also
create your own parts.

~ Alibrary part has a package view, which corresponds to
the actual physical object that can be placed, for example,
on a printed circuit board. The package view identifies the
physical pin numbers and the number of logical objects
(for example, parts or devices) that are contained within
the package.

I ® FuLLADD DSN - 741532 0

Figure 41 Part editor in package view

The different parts that make up a package can be
identical in their graphic appearance and electrical
COI’iﬁeCthy \lLuruuscru:uua) or thc_y can be dissimilar in

their graphic appearance or electrical connectivity
(heterogeneous).

In addition to the package view, a library part has a part
view, which is a graphical representation used to define a
single, logical, electrical object whose electrical
connectivity is represented by pins.

Note For information about creating your
own parts, see Chapter 12, Creating and

editing parts.
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Tip Apart doesn’t necessarily need pins. If
a part doesn't have pins, it is listed in a bill
of materials report, but doesn’t appear in a
netlist. This is useful if you want fo show
hardware —such as screws, nuts, or
washers—in a bill of materials report.

Note A part without pins will not snap fo
grid when placed on a schematic page.
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Figure 42 Part editor in part view

Each part has a set of properties that contains
information—such as part value and reference
designator—used by layout or simulation tools. In
addition, you can create your own unique part properties
that hold information relevant to your application.

Parts have pins that define the part’s electrical
connectivity. Pins carry information in properties that
define the characteristics of each pin. This information
includes the pin’s name, number, shape (clock, dot,
dot-clock, line, short, or zero length), type (3-state,
bidirectional, input, open collector, open emitter, output,
passive, or power), width (scalar or bus), and visibility.
The pin type is used by the Design Rules Check command
on the Tools menu to check conformance to basic electrical
rules.

A primitive part is a basic part without any underlying
hierarchy. A nonprimitive part is a part that has an
underlying hierarchy, such as an attached schematic
folder, PSpice model, or VHDL code. Placing a
nonprimitive part adds all its underlying hierarchy to
your project without moving the actual schematic folders,
making it easy to add levels of hierarchy to your project.
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Placing parts

You select parts from libraries and place them on
schematic pages using the Part command on the Place

menu, or using the part tool on the schematic page editor

tool palette.

To place a part

1 From the schematic page editor’s Place menu, choose

Part.
or

Choose the part tool on the schematic page editor’s

tool palette.
The Place Part dialog box appears.

2 Select a part from the list that appears.
or

In the Part text box, type the name of the part. If you

aren’t sure of the name of the part, enter wildcard

characters to constrain the list of parts, then click OK.
Valid wildcard characters are an asterisk (*) to match
multiple characters and a question mark (?) to match a

single character.

After you type the name of the part to be placed, click
OK. All parts in the libraries (listed in the Libraries list
box) that match the part name appear in the box below
the Part text box. When you select a part from this box,

its graphic image displays in the preview box.

3 When you have located the part you want to place,
click OK.

An image of the selected part is attached to your
pointer. You can click the right mouse button to

display a pop-up menu with commands that you can

use to change the properties of the part before you
place it. You can mirror the part horizontally or

vertically, rotate the part, or edit the part’s properties.

Tip You can add more libraries fo the
Libraries list box by clicking Add Library.
Capture displays a standard Windows
dialog box that you can use fo locate a
library to add to the list.

Tip You can remove a library from the
Libraries list box by selecting it and clicking
Remove Library.

Tip You can switch between the Normal
view of a part and the Convert view of a
part by choosing the appropriate option in
the Graphic section. For more information
on convert views, see The Graphic option of
the Place Part dialog box on page 110.

Tip Ifyour partis a package that contains
multiple parts, you can use the Part
drop-down list in the Packaging area o
select which part in the package fo view,
after you've selected a part from the list
that displays.
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Note All schematic page objects have
right mouse button pop-up menus. These
menus are confext sensitive, displaying
commands appropriate for the selected
object. For information about pop-up menu
commands, see the Capture online help.
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4

Move the pointer to the location on your schematic
page where you want to place the part, then click the
left mouse button.

This places an instance of the part on your schematic
page. (You can place multiple instances of the part by
clicking the left mouse button at each location where
you want an instance of the part.)

When you are done placing instances of the selected
part, choose End Mode from the right mouse button
pop-up menu, or press (Esc).
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Place Part dialog box

| Place Part

Design Cache

Figure 43 Place Part dialog box

Part Specifies the name of the part. If you aren’t sure of
the exact name of the part, you can enter wildcard
characters to constrain the list of parts, then click OK.
Valid wildcard characters are an asterisk (*) to match
multiple characters and a question mark (?) to match a
single character. The names of all parts in the selected
libraries that match the wildcard appear in the Part list
box.

Part list Lists the names of all parts in the selected
libraries that match the name entered in the Part text box.
If more than one library is selected, the part name is
followed by a slash (/) and a library name. When you
select a part in this list, its name displays in the Part text
box, and its graphic displays in the preview box.
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Note If you select an SDT 386+ or SDT
Release IV library from the dialog box that
appears when you choose Add Library,
Capture automatically translates the file
after you specify the name of the new
Capture library.

110

Libraries Lists the library names currently available.
All parts in the selected libraries that match the Part text
box display in the Part list. To select more than one library,
press while you click the mouse.

Graphic You can choose the view of the part: Normal or
Convert. Some parts have a Convert view that is used for
things such as a DeMorgan equivalent of a part.

Packaging Parts per package indicates the number of
parts in the package you are editing. Part indicates which
part of a multiple-part package you are placing.

Preview box Displays the graphic of the selected part.

Add Library Displays a standard Open dialog box that
you can use to locate a library and add it to the Libraries

Remove Library Removes the selected libraries from
the Libraries list.

Part Search Opens the Part Search dialog box, so you
can search for a part in all the libraries listed in a particular
directory.
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Searching for parts

Capture is able to search for a particular partinside all the
libraries it finds in the specified directory.

To find a part

1 In the schematic page editor, choose Part from the
Place menu.

2 Click the Part Search button. The Part Search dialog
box appears.

Enter the part name you want to locate.

Click Browse to locate the directory where your
libraries are located.

5 Click Begin Search. Capture returns the names of all
the libraries in the specified directory, that contain
your part.

Editing parts

You can move a part on a schematic page by selecting it Note for more information about editing
P wacoino i o 5 new location Yoii can 11qe tha Ratate parts see Chanter 12 (ragting and editing
alil U145611l5 1L LU ad 1ICVV 10ULdAdUVUILL. 10U Cdll UdC LIC NLUL4Alc PUTIS, JUU NTTUPIVE 1 &, NTUUTITTY UlTu vuiiiiny

or the Mirror command from the Edit menu. You canuse ~ parts.
the part editor to change the part’s physical appearance,

and you can edit the part’s properties. When you edit a

part on a schematic page, your edited part differs from the

part in the library and exists only in your design; you can

place another copy of the part you edited by using the

Copy command from the Edit menu, and by dragging the

part from the design cache.
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To edit the physical appearance of a part, select it, and
either choose Part from the Edit menu or choose Edit Part
from the right mouse button pop-up menu. This opens the
part in a part editor window. After you finish editing the
part and choose Save, you're given a choice of updating
the single instance, or updating all instances in the design.
If you update only the single instance, Capture creates a
new part in the design cache. If you update all instances,
Capture replaces the library part in the design cache with
your edited part. These new parts are placed in the design
cache with “-n” appended to the name, where 7 is an
integer.

To edit the properties of a part, select the part on the
schematic page, and either choose Properties from the
Edit menu, or choose Edit Properties from the right mouse
button pop-up menu. You can also double-click the part.
This displays the property editor, shown in Figure 44.

% Parts Sproadsheet R I =l

DTFLLLADD OL
ORCADDESIGMESDTFULLADD

Figure 44 Property editor with filter set to Capture

Capture displays properties according to the selected
filter. All the properties are shown when the filter is set to
All. General schematic page properties are shown when
the filter is set to Capture. The following are common
properties:

Value Specifies the part value name. By default, the part
value is set to the name of the part if you don’t specify a
part value in the library.
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Reference Specifies the part reference.

Primitive Default indicates that the part uses the
setting in the Hierarchy tab of the Design Properties
dialog box. Yes indicates that the part is primitive. No
indicates that the part is nonprimitive.

Designator Indicates which part of a multiple-part
package you are editing.

PCB Footprint The PCB physical package name to be
included for this part in the netlist.

Power Pins Visible Specifies the visibility of the part’s
power pins.

Implementation Type Specifies if the part has an
attached schematic folder or other implementation, and
the type of implementation, if one exists. Implementation
types include schematic folders, VHDL entities, netlists,
and PSpice models.

Caution An attached schematic folder or other file external to the project or
library is not stored with the project or library. If you copy or move
the project or library to a new location, you must also move or copy
the attached object to keep them together. In addition, you may
need to edit the path o the attached schematic folder or file if you
move the project to a new location with a different directory
structure.

Note To change the Part Reference
property, you will need to edit the
Reference property, the Designation
property, or both. The Part Reference
property is a read-only property that
Capture calculates from the Reference and
Designator values.

Note For information on power pin
visibility and how it affects a global net, see
the Capture online help.
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Placing and editing power and
ground symbols

You can place power and ground symbols, and you can
edit their names before or after placing them. You can also
edit the text associated with the symbols. The name of a
power symbol becomes the name of the global net that is
created.

Placing power and ground symbols

Power and ground symbols are placed on a schematic
page using the Power command or Ground command on
the Place menu, or using the power tool or ground tool on
the tool palette. Power and ground symbols are selected
from libraries the same way parts are selected from
libraries. CAPSYM.OLB contains all the power and
ground symbols shipped with Capture.

To place a power symbol

1 From the schematic page editor’s Place menu, choose
Power.
or
Choose the power tool on the schematic page editor’s
tool palette.

The Place Power dialog box appears.

2 Inthe Symbol text box, type the name of the symbol to
place. If you aren’t sure of the exact name of the
symbol, you can enter wildcard characters to constrain
the list of symbols, then press (Enter«). Valid wildcard
characters are an asterisk (*) to match multiple
characters and a question mark (?) to match a single
character. All power symbols in the libraries selected
in the Libraries list box that match the name of the
power symbol are listed in the box below the Power
Symbol text box. When you select a symbol from this
box, its graphic image appears.
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3

After you locate the power symbol you want to place,

click OK. An image of the power symbol is attached to
your pointer.

You can press the right mouse button to display a
pop-up menu with commands to change the attributes
of the power symbol before you place it. You can
mirror the power symbol horizontally or vertically, or
rotate it.

Move the pointer to the location on your schematic
page where you want the power symbol and click the
left mouse button. This places the power symbol on
your schematic page.

You can place multiple instances of the power symbol
by clicking the left mouse button each place you want
an instance of the symbol.

When you are done placing power symbols, choose
End Mode from the right mouse button pop-up menu,

or press (Esc).

To place a ground symbol

1

Follow the instructions in the previous section, To
place a power symbol on page 114, but substitute the
Ground command or the ground tool in the
appropriate places.

Note All objects that you can place on a
schematic page have right mouse button
pop-up menus. These menus are context
sensitive, meaning they display commands
that are appropriate for the selected object.
For information about the commands on a
pop-up menu, see Capture’s online help.

Note You can create custom power,
ground, and other symbols for hierarchical
ports, off-page connectors, fitle blocks, and
power objects by choosing the New Symbol
command from the Design menu in the
project manager window. For information
on how to use this command, see Capture’s
online help.
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Place Power and Place Ground dialog boxes

The Place Power and Place Ground dialog boxes are
identical, except that each displays the last power or
ground symbol you placed on this page. This figure shows
the Place Power dialog box.

GND EARTH
GND FIELD SIGNAL
GND POWER

GND SIGNAL
FF

VL ARROW
Figure 46 Place Power dialog box

Symbol Specifies the name of the power or ground
symbol in the library. If you aren’t sure of the exact name
of the symbol, you can enter wildcard characters to
constrain the list of symbols, then click OK. Valid
wildcard characters are an asterisk (*) to match multiple
characters and a question mark (?) to match a single
character. The names of all symbols in the selected
libraries that match the wildcard appear in the Symbol list
box.

Symbol list Lists the names of all symbols in the
selected libraries that match the name entered in the
Symbol text box. If more than one library is selected, the
symbol name is followed by a slash (/) and alibrary name.
When you select a symbol in this list, its name displays in
the Symbol text box, and its graphic displays in the
preview box.
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Libraries Lists the library names currently available.
Select the libraries from which to select power or ground
symbols. All symbols in the selected libraries that match
the Symbol text box display in the Symbol list. To select
more than one library, press while you click the
mouse.

Preview box Displays the graphic of the selected
symbol.

Add Library Displays a standard Open dialog box that
you can use to locate a library and add it to the Libraries
list.

Remove Library Removes the selected libraries from
the Libraries list.

Name Assigns a name—such as +5, GND, +5VDC, -12
VDC, VSS, or VEE—to the symbol. By default, the name of
the symbol is assigned.

Editing power and ground symbols

You can change the name of a power or ground symbol by
selecting the symbol on the schematic page, and either
choosing Properties from the Edit menu, or choosing Edit
Properties from the right mouse button pop-up menu.
You can also double-click the symbol. This displays a
dialog box in which you can edit the symbol’s name, then

click OK.
You can also edit the display properties of the name of the ~ Note You cannot assign user properties fo
power or ground symbol. Select only the text of the power or ground symbols.

symbol, then either choose Properties from the Edit menu,
or choose Edit Properties from the right mouse button
pop-up menu. You can also double-click the text. This
displays a Display Properties dialog box. Once you have
finished editing the properties, click OK.
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Placing and editing no-connect
symbols

A no-connect symbol (shown as an “X” attached to a pin)
causes unused pins to be ignored by reports (such as
Design Rules Check and netlists) that show unconnected
pins. If a pin is connected, the no-connect symbol doesn’t
affect the pin. They are pin properties.

Placing no-connect symbols

No-connect symbols are placed on pins on a schematic
page using the No Connect command on the Place menu,
or using the no-connect tool on the schematic page
editor’s tool palette.

To place a no-connect symbol

1 From the schematic page editor’s Place menu, choose
No Connect.
or
Choose the no-connect tool on the schematic page
editor’s tool palette.

2 Position the mouse over the pin end and click the left
mouse button. The end of the pin changes from a
square (unconnected) to an X (not connected). This
changes the pin property called “Is No Connect” from
False to True and displays an X on the pin end.
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Editing no-connect symbols

No-connect symbols cannot be deleted using the
key. To remove a no-connect symbol, place another
no-connect symbol on top of the existing no-connect
symbol. You can temporarily override a no-connect
symbol by attaching a wire to the pin, but if you delete the
wire, you'll again be able to see the no-connect symbol.
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Figure 47 Hierarchical block

For information on connecting hierarchical
designs using hierarchical blocks,
hierarchical ports, and hierarchical pins,
see Connecting schematic folders and
schematic pages on page 98.
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Placing and editing hierarchical

blocks

Hierarchical blocks (or parts with attached schematic
folders) refer to child schematic folders in a project,
providing vertical (downward-connective) connection
only. Hierarchical pins in a hierarchical block, and
hierarchical ports outside a hierarchical block, act as
points of attachment for any electrical connections
between the hierarchical block and other electrical objects
in an attached schematic folder.

A part with an attached schematic folder functions like a
hierarchical block, and pins on a part with an attached
schematic folder function like hierarchical pins within a
hierarchical block. You can use either method to define a
hierarchy. The only difference between the two methods
is that a part with an attached schematic folder can be
more easily reused.

Placing hierarchical blocks

You create hierarchical designs using hierarchical blocks
to represent child schematic folders. When you create a
hierarchical block, you specify the name of the child
schematic folder that the hierarchical block represents.
Once you've created the hierarchical block, you place
hierarchical pins inside it to connect it to hierarchical ports
on the child schematic folder’s schematic pages.

To place a hierarchical block

1 From the schematic page editor’s Place menu, choose
Hierarchical Block.
or
Choose the hierarchical block tool on the schematic
page editor’s tool palette.

The Place Hierarchical Block dialog box appears.
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N

Note

In the Reference text box, type the name of the
hierarchical block.

Accept the Primitive setting of Default, or choose Yes
or No. (See Place Hierarchical Block dialog box on page
122 for more information.)

If necessary, click User Properties, add or change
property names and their associated values in the
dialog box that appears, then click OK.

Specify the type of implementation. (See Place
Hierarchical Block dialog box on the next page for a
description of implementation types.)

Specify the name of the attached schematic folder,
VHDL entity, netlist, or project.

Specify the path and filename of the attached
schematic folder, VHDL entity, PSpice entity, netlist,
or project.

Click OK to close the Place Hierarchical Block dialog
box.

Draw the hierarchical block. Press the left mouse
button, drag the mouse to draw a rectangle, and
release the mouse button when the rectangle is the
desired size. Click an open space on the page to
deselect the block.

Once you've placed a hierarchical block, you must place
hierarchical pins inside it, then name the pins so that they connect
to like-named hierarchical ports in the schematic pages in the child
schematic folder. See Placing hierarchical pins on page 127.

Note If the child schematic folder you
specify as the hierarchical block’s attached
schematic folder already exists, Capture
automatically adds hierarchical pins to the
hierarchical block that match the
corresponding ports on the schematic pages
in the child schematic folder. If the child
schematic folder doesn’t yet exist and you
place the hierarchical block and choose
Descend Hierarchy from the right mouse
button pop-up menu, Capture creates a new
schematic folder and creates a new
schematic page containing hierarchical
ports that match the hierarchical pins in the
hierarchical block.
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Place Hierarchical Block dialog box

| Place Hierarchical Block

Figure 48 Place Hierarchical Block dialog box

Reference The name of the hierarchical block. If you
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increments this number when the hierarchical block is
copied.

Primitive Default indicates that the part uses the
setting in the Hierarchy tab of the Design Template dialog
box. Yes indicates that the part is primitive, and contains
no underlying hierarchy. No indicates that the part is
nonprimitive, and contains underlying hierarchy.

User Properties Displays a dialog box that you can
use to edit the part’s property names and their respective
property values.
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impiementation Type Specifies the type of
implementation from one of the following:

Schematic View—Indicates that the attached
implementation is a schematic folder. Capture will
automatically generate the appropriate hierarchical
pins for the block based on the schematic ports.

VHDL—Indicates that the attached implementation is
a VHDL entity. Capture will automatically generate
the appropriate hierarchical pins for the block based
on the port declarations in the VHDL entity.

EDIF—Indicates that the attached implementation is
an EDIF netlist. If your design includes EDIF
implementations for hierarchical blocks, you must
specify the hierarchical pins for the block; Capture will
not generate them from the EDIF netlist.

Project—Indicates that the attached implementation
is a programmable logic project. You must specify the
hierarchical pins for the block; Capture will not
generate them.

PSpice Model—Indicates that the attached
implementation is a PSpice model file. You must
specify the hierarchical pins for the block; Capture will
not generate them.

PSpice Stimulus—Indicates that the attached
implementation is a PSpice stimulus file. You must
place the hierarchical pins on the block. Capture will
not generate them.

Implementation Name Specifies the name of the
attached schematic folder, VHDL entity, netlist, or project
for the hierarchical block. Schematic folder names are case
sensitive.

Path and filename Specifies the path and filename of
the attached schematic folder, VHDL entity, netlist, or
project for the hierarchical block.

If you specify a project that you haven't yet
saved fo disk, Capture creates the project in
the directory specified by your TEMP
environment variable.

Attaching an implementation does not
automatically add that file, project, or
schematic folder to the project. You must
specifically add the implementation to the
project with the Project command (on the
Edit menu).

Caution An attached schematic folder or
other file external to the project or library
is not stored with the project or library. If

you copy or move your project or library to
a new location, you must also move or copy
the attached file, to keep them together. In
addition, you may need to edit the path to
the attached schematic folder or file if you
move your project to a new location with a
different directory structure.
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Editing hierarchical blocks

You can edit a hierarchical block after it is placed. Select
the hierarchical block and do one of the following;:

e Double-click it.
e Choose Properties from the Edit menu.
e Choose Edit Properties from the pop-up menu.

Each of these methods displays the property editor, in
which you can change the block’s reference, choose
among the options in the Primitive group box, or modify
the attached schematic folder’s name or path. You can also
add and modify user properties in the property editor.

You can also edit the display properties of the text
associated with the hierarchical block. Select the text of the
hierarchical block and do one of the following:

e Double-click it.
e Choose Properties from the Edit menu.
e Choose Edit Properties from the pop-up menu.

Each of these methods displays the Display Properties
dialog box, in which you can edit the visibility, color, font,
or rotation of the text of the hierarchical block.

You can click a hierarchical block and move it to another
location, or you can drag its selection handles to resize it.
You can also use the Mirror or Rotate commands to
change the appearance of the block.
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Placing and editing hierarchical
ports and hierarchical pins

For information on how hierarchical designs are
connected using hierarchical blocks, hierarchical ports,
and hierarchical pins, see Connecting schematic folders
and schematic pages in Chapter 6, Design structure.

Placing hierarchical poris

You place hierarchical ports on schematic pages in child
schematic folders, then name the ports so that they
connect to like-named hierarchical pins inside hierarchical
blocks on schematic pages in parent schematic folders.

Hierarchical ports also connect to like-named hierarchical
ports, and to off-page connectors with the same name, on
schematic pages within the same schematic folder.

Hierarchical ports are stored in the CAPSYM.OLB library.

To place a hierarchical port

1 From the schematic page editor’s Place menu, choose
Hierarchical Port.

The Place Hierarchical Port dialog box appears.

2 Select CAPSYM.OLB or your own custom library
containing hierarchical ports from those listed in the
Libraries field, or use the Add Library and Remove
Library buttons to change what is listed in the
Libraries field and select one or more libraries.

3 Inthelist below the Symbol text box, select the type of
the hierarchical port. The selection’s name appears in
the Symbol text box and its graphic displays in the
preview box.

4 Type in the name for the hierarchical port. The name
is added to the attached net, and is used to determine
which like-named hierarchical pins and hierarchical

Note You can create custom power,
ground, and other symbols for hierarchical
ports, hierarchical pins, off-page
connectors, title blocks, and power objects
by using the New Symbol command on the
Design menu in the project manager
window. For information on how to use this
command, see Capture’s online help.
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Figure 49 Hierarchical ports in
(APSYM.OLB

Tip You can place a hierarchical port
anywhere on a schematic page. A
hierarchical port connects to like-named
hierarchical ports and off-page connectors
on schematic pages in the same schematic
folder, and connects to like-named
hierarchical pins inside hierarchical blocks
in parent schematic folders.

125



Chapter 7 Placing, editing, and connecting parts and electrical symbols

ports the port connects to. Hierarchical ports attached
to buses must have a bus type name, preferably the
same name as the bus. For more information, see Bus
naming conventions in Capture’s online help.

5 When you have specified the characteristics of the
hierarchical port, click OK. The Place Hierarchical Port
dialog box closes.

6 You can now place the hierarchical port anywhere on
the schematic page. If you want to move the port, you
can select it and drag it to another location after you
place it.

Place Hierarchical Port dialog box

 Place Hierarchical Port
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Figure 50 Place Hierarchical Port dialog box

Symbol Specifies the hierarchical port symbol to use. If
you aren’t sure of the exact name of the symbol, you can
enter wildcard characters to constrain the list of symbols,
then click OK. Valid wildcard characters are an asterisk (*)
to match multiple characters and a question mark (?) to
match a single character. The names of all symbols in the
selected libraries that match the wildcard appear in the
Symbol list box.
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Symbol list Lists the names of all symbols in the
selected libraries that match the text entered in the Symbol
text box. If more than one library is selected, the symbol
name is followed by a slash (/) and a library name. When
you select a part in this list, its name displays in the
Symbol text box, and its graphic displays in the preview
box.

Libraries Lists the library names currently available.
Select the libraries from which to select symbols. All
symbols in the selected libraries that match the Symbol
text box display in the Symbol list. To select more than one
library, press while you click the mouse.

Preview box Displays the graphic of the selected
symbol.

Name Specifies the symbol’s name. This name is used
to determine which like-named hierarchical ports the port
will connect to.

o . .
Add Library Displays a standard Open dialog box that
you can use to locate a library and add it to the Libraries

list.

Remove Library Removes the selected libraries from
the Libraries list.

Placing hierarchical pins

You place hierarchical pins inside hierarchical blocks on
schematic pages in parent schematic folders. You name
the hierarchical pins to correspond to hierarchical port
names on schematic pages in child schematic folders.

Note If you do not select the Pointer

snap-to-grid option in the Grid Display tab
of the Preferences dialog box, hierarchical
pins you place in a hierarchical block may
not snap to grid. Delete the pin and place it
again with the snap-to-grid option selected.
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Tip You can only place a hierarchical pin
within the boundaries of a hierarchical
block. A hierarchical pin connects to any
like-named hierarchical port on the
schematic pages in the schematic folder you
attached to the hierarchical block.

Note Bus width hierarchical pins must be
given bus type names. See Bus naming
conventions in Capture’s online help for
more information.
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To place a hierarchical pin

1
2

Select a hierarchical block.

From the schematic page editor’s Place menu, choose
Hierarchical Pin. The Place Hierarchical Pin dialog
box appears.

In the Name text box, type in a name for the
hierarchical pin. This name, which is also the net
name, is used to determine which like-named
hierarchical ports the pin connects to.

From the drop-down list box under Type, select a pin
type for the hierarchical pin.

In the Width group box, select either Scalar or Bus.

Choose the User Properties to display a dialog box
where you can add or change property names and
their associated values. When you’ve finished editing
the hierarchical pin’s properties, click OK.

Click OK to close the Place Hierarchical Pin dialog
box.

Position the hierarchical pin on an edge of the
hierarchical block and click the left mouse button to
place the pin.
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Place Hierarchical Pin dialog box

Place Hierarchical Pin |

Figure 51 Place Hierarchical Pin dialog box

Name Specifies the hierarchical pin’s name.
Type Specifies the type of pin.
Width Specifies whether the pin is Scalar or Bus.

User Properties Displays a dialog box that you can
use to edit the pin’s property names and their respective
property values.

Editing hierarchical ports and hierarchical pins

You can edit a hierarchical port or hierarchical pin afterit ~ Tip If you move the fext of a hierarchical
is placed by selecting it and choosing Properties from the  port, it will snap to the grid. To return it fo
Edit menu, choosing Edit Properties from the right mouse  ifs correct position with respect to the
button pop-up menu, or double-clicking on it. This hierarchical port, use the Mirror command
displays a dialog box that lets you change the information  on the Fdit menu, or turn snap-to-grid off,
for Name and Type. Once you have finished editing the and move the text back into place.
information in the dialog box, click OK.

You can edit the display properties of the text associated
with a hierarchical port by selecting the text of the port,
and choosing Properties from the Edit menu, choosing
Edit Properties from the right mouse button pop-up
menu, or double-clicking on it. Using the Display
Properties dialog box, you can change the text itself, or
change the text's color, font, or rotation. After you have
finished editing the text's properties, click OK.
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Note For more information about
connecting designs using off-page
connectors, see Connecting schematic
folders and schematic pages on page 98.
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Figure 52 Off-page connectors in
CAPSYM.OLB

Tip You can add more libraries to the
Libraries list box by clicking Add Library.
Capture displays a standard Open dialog
box that you can use to locate a library to
add to the list.

You can remove a library from the Libraries
list box by selecting it and clicking Remove
Library.

You can assign a name by typing it in the
Name text box. The name is used to
connect to other off-page connectors in the
same schematic folder. You can also assign
a name after the symbol is placed.

Al of the options on the Place Off-Page
Connector dialog box are described later in
this section.
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Placing and editing off-page
connectors

Off-page connectors are used to connect signals to
like-named off-page connectors and hierarchical ports on
other schematic pages within the same schematic folder.
Off-page connectors are stored in the CAPSYM.OLB
library.

Placing off-page connectors

To place an off-page connector, you use the Off-Page
Connector command on the Place menu or the off-page
connector tool on the tool palette.

To place an off-page connector

1 From the schematic page editor’s Place menu, choose
Off-Page Connector.
or
Choose the off-page connector tool on the schematic

page editor’s tool palette.
The Place Off-Page Connector dialog box appears.

2 Inthe Symbol text box, type the name of the symbol to
place. If you aren’t sure of the exact name of the
symbol, you can enter wildcard characters to constrain
the list of symbols, then click OK. Valid wildcard
characters are an asterisk (*) to match multiple
characters and a question mark (?) to match a single
character.

After you type the name of the symbol to place, click
OK. All symbols in the libraries listed in the Libraries
list box that match the symbol name are listed in the
box below the Symbol text box. When you select a
symbol from this box, its graphic image displays.
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When you have located the symbol you want to place,
click OK.

An image of the symbol is attached to your pointer.
You can press the right mouse button to display a
pop-up menu with commands that you can use to
change the appearance of the symbol before you place
it. You can mirror the symbol horizontally or
vertically, rotate the symbol, or edit its properties.

Move the pointer to the location on your schematic
page where you want the symbol and click the left
mouse button. This places the symbol on your
schematic page. '

You can place multiple instances of the symbol by
clicking the left mouse button each place you want an
instance of the symbol.

When you are done placing symbols, choose End
Mode from the right mouse button pop-up menu, or

press (Esc).

Note All objects that you can place on a
schematic page have right mouse button
pop-up menus. These menus are context
sensitive, meaning the displayed
commands are appropriate for the selected
object. For information about the
commands on a pop-up menu, see
Capture’s online help.
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Place Off-Page Connector dialog box

H< OFFPAGELEFT-L

Figure 53 Place Off-Page Connector dialog box

Symbol Specifies the off-page connector symbol to use.
If you aren’t sure of the exact name of the symbol, you can
enter wildcard characters to constrain the list of symbols,
then click OK. Valid wildcard characters are an asterisk (*)
to match multiple characters and a question mark (?) to
match a single character. The names of all symbols in the
selected libraries that match the wildcard appear in the
Symbol list box.

Symbol list Lists the names of all symbols in the
selected libraries that match the text entered in the Symbol
text box. If more than one library is selected, the symbol
name is followed by a slash (/) and a library name. When
you select an off-page connector in this list, its name
displays in the Symbol text box, and its graphic displays
in the preview box.

Libraries Lists the library names currently available.
Select the libraries from which to select symbols. All
symbols in the selected libraries that match the Symbol
textbox display in the Symbol list. To select more than one
library, press while you click the mouse.



Placing and edifing off-page connectors

Preview box Displays the graphic of the selected
symbol.

Name The name of the symbol. Other off-page
connectors and hierarchical ports in the same schematic
folder that have this name are connected to this off-page
connector.

Add Library Displays a standard Open dialog box that
you can use to locate a library and add it to the Libraries
list.

Remove Library Removes the selected libraries from
the Libraries list.

Editing off-page connectors

You can edit an off-page connector after it is placed by
selecting it and either choosing Properties from the Edit
menu, or choosing Edit Properties from the right mouse
button pop-up menu. You can also double-click the
off-page connector. This displays the Edit Off-Page
Connector dialog box, which lets you change the Name.
Once you have finished editing the information in the Edit
Off-Page Connector dialog box, click OK.

You can also edit the display properties of the text
associated with the off-page connector. Select only the text
of the off-page connector, then either choose Properties
from the Edit menu, or choose Edit Properties from the
right mouse button pop-up menu. You can also
double-click the off-page connector. This displays the Edit
Off-Page Connector dialog box. Once you have finished
editing the properties, click OK.

You can click an off-page connector and move it to
another location. You can also use both the Mirror and
Rotate commands from the Edit menu to change the
appearance of the off-page connector.

Tip If you move the text of a hierarchical
port, it will snap to the grid. To return it to
its correct position with respect to the
off-page connector, select the symbol, use
the Mirror command on the Edit menu, or
turn snap-to-grid off, and move the text
back into place

Note You can create custom power,
ground, and other symbols for hierarchical
ports, off-page connectors, title blocks, and
power objects by using the New Symbol
command from the Design menu in the
project manager window. For information
on how to use this command, see the
Capture online help.
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Note For more information about placing
and connecting wires and buses, see
Capture’s online help.
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Placing and connecting wires and
buses

Two wires or two buses can be connected physically by
the following methods:

e If you cross a wire segment of another wire and add a
junction where the wires meet, a junction displays,
and the wires connect.

e If you begin or end a wire segment on a segment of
another wire, a junction is added automatically, and
the wires are connected.

e If you begin or end a bus segment on a segment of
another bus, a junction is added automatically, and
the buses are connected.

A wire and a bus can be connected in name only by the
following methods:

e If you begin or end a wire segment on a segment of a
bus, a junction is added, and they will be connected.

e If you begin or end a bus segment on a segment of a
wire, a junction is added, and they will be connected.

Wires and buses, along with other parts and symbols in
the project that are logically connected via net names,
form a net. When you place a wire, it is assigned a
system-generated netname, which you can replace with
an alias or a different netname. Once a bus acquires a valid
name or alias, then that name or alias defines the signals
carried by the bus and connects those signals to the
corresponding nets. For example, the alias A[0:3] defines
a four-signal bus and connects the four signals it carries
with nets A0, A1, A2, and A3.

Like wires, buses can acquire names and aliases by two
means:

¢ Direct application of a net alias with valid bus name

¢ Electrical connection to a hierarchical port, off-page.
connector, or global bus pin with a valid bus name.
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Placing wires

When you connect a wire to a pin, Capture provides
visual confirmation of the connection by removing the
unconnected pin box on the pin. If two continuous wires
cross at 90°, they are not electrically connected unless you
create a junction by double-clicking the left mouse button
on one wire as you draw the other across it.

You can determine whether wires or buses that cross each
other are connected by the presence or absence of a
junction. Unless a junction is present, wires or buses that
cross each other are not connected. Likewise, if you drag a
net up to another net so that they touch, the two nets are
not connected unless you add a junction at the location
where the nets meet.

You can add a junction using the Place junction button on
the schematic page editor’s toolbar, or by choosing
Junction from the Place menu in the schematic page
editor. You can place junctions anywhere on a wire or bus,
but they only take effect when another object is connected
at the junction’s location. You can remove a junction by
selecting it and using the key, or by placing another
junction on top of the existing one.

To place a wire

1 From the schematic page editor’s Place menu, choose
Wire.
or
Choose the wire tool on the schematic page editor’s
tool palette.

Click the left mouse button to start the wire.

3 Move the mouse to draw the wire. Click the left mouse
button if you want to place a vertex and change
directions.

4 Double-click to end the wire. The wire displays in the
selection color.
or
Click on another wire. Clicking on another wire
connects the two wires.

Tip To find out the name of the net to
which a pin is connected, double-click the
pin, then click User Properties in the Pin
Properties dialog box. The Net Name
property is the name of the net.

Note If you place parts so that two pins
meet end to end, the pins are connected.
When you move the parts away from each
other, a wire is automatically placed.

Note Junctions can only be placed on
wires and buses. A junction cannot be
placed in an open area, or on an object such
as a pin or a port.

Note The wire is constrained to multiples
of 90° unless you hold down the

key while you draw the wire.
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Tip To edit a net alias, double-click the
alias. This displays the Edit Net Alias dialog
box, in which you can change the Alias,
Color, Rofation, or Font. Once you have
finished editing the properties, click OK.
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5 When you are done placing wires, choose End Mode
from the right mouse button pop-up menu, or press

[Esc).

Editing wires

Capture makes it easy for you to modify the appearance
and properties of a wire. You can implement most
changes with two clicks of the mouse or a key
combination.

To assign a net alias to a wire

1 Select the wire and choose Properties from the Edit
menu, choose Edit Properties from the pop-up menu,
or
Double-click the wire.

2 The property editor appears, allowing you to enter a
net alias; this alias serves as the netname in a netlist.

3 Once you have finished entering a net alias, click OK.

Note When you click a wire, all its graphical handles are highlighted. To
] nnnthar wira tn tha calartinn hald down flmfum ’lnu nnll r’u‘ll
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the additional wire. To select the entire nef, select the w:re, then
choose Select Entire Net from the right mouse bution pop-up menu.
Zoom out to view the entire selected net.

To edit the display properties of text associated with a wire

1 Select only the text of the wire, then either choose
Properties from the Edit menu, or choose Edit
Properties from the right mouse button pop-up menu.
You can also double-click the text.

This displays a Display Properties dialog box.

3 Once you have finished editing the properties, click
OK.



Placing and connecting wires and buses

To move a wire, select it and drag it to a new location; the
wire stretches to maintain its connectivity. To break the
wire’s connectivity, press while you move it. To move
a vertex, select a wire segment next to the vertex and drag
the vertex to the new location.

Placing buses

A bus is a group of scalar signals (wires), and is never
connected to a net. Once the bus acquires a valid name or
alias, then that name or alias defines the signals carried by
the bus and connects those signals to the corresponding
nets. For example, the alias A[0:3] defines a four-signal
bus that connects the four bus signals to the individual
wires named A0, Al, A2, and A3. Net aliases on wires do
not use brackets.

To place a bus

1 From the schematic page editor’s Place menu, choose
Bus.
or
Choose the bus tool on the schematic page editor’s tool
palette.
Click the left mouse button to start the bus.

3 Move the mouse to draw the bus. Click the left mouse
button if you want to place a vertex and change
directions, or to connect to another bus as you pass
over it. The bus is constrained to multiples of 90°
unless you hold down the key while you draw
the bus.

4 Double-click to end the bus.

5 Highlight the bus, then choose Net Alias from the
Place menu. Enter an alias for the bus in the Place Net
Alias dialog box that appears, then click OK.

6 When you are done placing buses, choose the selection
tool or press to dismiss the bus tool.

Note For more information about editing
wires and nefs, see the Capture online help.

Note Bus names and aliases have the
form X[m..n]. X represents the “base
name.” The portion m..n represents the
range of signals carried by the bus. Note
that m may be less than or greater than n.
In other words, both A[0..3] and A[3..0]
are valid bus aliases. You can use two
periods (..), a colon (:), or a dash (-) to
separate m and n. Do not use two digits for
single-dligit signals (for example, use
A[0..3], but don’t use A[00..33]). See Bus
naming conventions in the Capture online
help for more information.
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Editing buses

Select the bus and either choose Properties from the Edit
menu, or choose Edit Properties from the right mouse
button pop-up menu. You can also double-click the bus.
Capture displays the property, in which you can add or
change the bus’s properties. These changes can be applied
to the schematic page by clicking Apply, or returning to
the schematic page editor.

You can also edit the display properties of the text
associated with the bus. Select only the text of the bus,
then either choose Properties from the Edit menu, or
choose Edit Properties from the right mouse button
pop-up menu. You can also double-click the text. This
displays the Edit Net Alias dialog box, which allows you
to change the Alias, Color, Rotation, or Font. Once you
have finished editing the properties, click OK.

Placing bus entries

Bus entries are used to bring a net into a bus. They are
optional. The only distinction between a bus entry and a
wire segment is that two wires that touch are connected,
whereas two bus entries that touch are not connected.

To place a bus entry

1 From the schematic page editor’s Place menu, choose
Bus Entry. The bus entry is attached to the pointer.

2 From the Edit menu, choose Rotate to rotate the bus
entry 90° counterclockwise if the bus entry is not at the
angle you need.

3 Use the mouse to position one end of the bus entry on
the bus, then click the left mouse button to place the
bus entry.

Repeat step 3 until all of the bus entries are placed.

Choose the selection tool or press to dismiss the
bus entry tool.



Placing and connecting wires and buses

To connect multiple nets fo a bus

1
2

Place a wire to connect the first bus entry to a net.

Place an alias on the wire using the lowest value in the
bus range. For example, if you're using a bus alias of
A[0:3], the lowest value in the bus range is AO.

Select the wire, then press while you drag a copy
a specific distance so that it connects the next net to the
bus. The alias value is increased by one.

From the Edit menu, choose Repeat. The wire and the
incremented alias text are placed at the specified
distance from the previous set.

Repeat step 4 for every bus entry in the bus, or repeat
steps 3 and 4 as needed.

When you are done connecting bus entries, press (Esc).

Editing bus entries

To move abus entry, select it and drag it to a new location.
To rotate a bus entry, select it and choose Rotate from the
Edit menu.

Ripping a subset of signals off the bus

You can rip a bus that is a subset of another bus similar to
the way you connect a net to a bus. For example, if you
want to rip ADDR[8..15] off of ADDR][0..15], place a bus
entry so that it connects the two buses. Make sure that the
name of the bus being ripped off uses a net alias that is a
subset of the second bus.

You can route the ripped bus to any page in the design.
Use hierarchical ports, hierarchical pins, and off-page
connectors to connect the ripped bus to other schematic
pages the same way you would with any other bus.

Tip To place an alias, choose Net Alias
from the Place menu. Enter the net alias
text (following the naming conventions for
buses and nets), then click OK. A rectangle
representing the alias text attaches to the
pointer. Click the left mouse button on the
bus or net to place the alias. The alias text
displays in the selection color. When you
are done placing aliases, press (Esc).

139



Chapter 7 Placing, editing, and connecting parts and electrical symbols

140



Adding and editing graphics

and text

You can create a wide variety of graphic shapes to add to
your schematic pages. You can work with the snap-to-grid
option turned on or turned off. For close work, you may
want to zoom in on your graphic using the Go To
command on the View menu.

Before you begin drawing, you may want to specify
default line and fill styles, because all lines and shapes you
draw will use the current line style, and closed shapes that
you draw will use the current fill style. You can use a
variety of line or fill styles for any part. You can specify
these styles in the Miscellaneous tab in the Preferences
dialog box.

Note If the pointer snap-to-grid option is
cleared, then placemed graphics and text
snap to a finer grid that is one-tenth the
size of pin-to-pin spacing.
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Drawing tools

Capture has two tool palettes: one for the schematic page
editor window, and one for the part editor window. Both
tool palettes are movable and resizable, and display
tooltips that identify each tool. The tool palettes are each
divided into two groups of tools. The electrical tools are in
the first group and the drawing tools are in the second

group.

Figure 54 Schematic page editor tool palette

Figure 55 Part editor tool palette

General rules for all drawing tools:

e Ifyou choose a drawing tool and press (Esc] before you
begin drawing an object, the drawing tool changes to
the selection tool.

e If you choose a drawing tool, start drawing an object,
and then press (Esc), the unfinished object is removed,
and the drawing tool changes to the selection tool.
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Drawing lines

You use the line tool to draw a single line. The line you
draw adopts the current line style. If you want to draw a
line with multiple contiguous segments, use the polyline
tool.

To draw a line segment

1 From the Place menu, choose Line.
or
Choose the line tool on the tool palette.

Move the pointer to the line’s beginning.

Press and hold the left mouse button while moving the
mouse to draw the line.

4 Release the left mouse button to end the line. The line
displays in the selection color.

5 Choose the selection tool or press (Esc) to dismiss the
line tool.

To resize a line

Use the selection tool to select a line. Edit handles appear
at either end of the line. With the pointer on one of the two
edit handles, press the left mouse button and drag the line.
You can change the angle of the line in the process of

resizing it.

Note To place diagonal lines, hold down

the key while drawing a line
with snap-to-grid selected.
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Drawing rectangles and squares

You use the rectangle tool to create orthogonal shapes. To
create a square, hold down the key before you
begin drawing. Any rectangles or squares you create will
have the current fill style and line style.

To draw a rectangle or a square

From the Place menu, choose Rectangle.
or
Choose the rectangle tool on the tool palette.

Move the pointer to one corner of the intended
rectangle.

Press and hold the left mouse button while you drag
the mouse. The rectangle changes shape as you move
the mouse. Release the left mouse button when you
have the correct shape. To draw a square, hold down
the key while you perform this step. The
rectangle displays in the selection color.

Choose the selection tool or press to dismiss the
rectangle tool.

To resize a rectangle or square

Use the selection tool to select a rectangle or square. Edit
handles appear on the four corners. With the pointer on
one of the handles, press the mouse and drag the handle.



Drawing circles and ellipses

Drawing circles and ellipses

You use the ellipse tool to draw a closed ellipse; if you
want to draw an arc, use the arc tool. To draw a circle, hold
down the key while you drag the mouse. Because
they are closed shapes, circles and ellipses will have the
current fill style. They will also have the current line style.

To draw an ellipse or a circle

1 From the Place menu, choose Ellipse.
or
Choose the ellipse tool on the tool palette.

Move the pointer to an edge of the intended ellipse.

3 Press and hold the left mouse button while you drag
the mouse. The ellipse changes shape as you move the
mouse. If you want to draw a circle, hold down the
key while you perform this step. Release the
left mouse button when you have the correct shape.
The ellipse appears in the selection color.

4 Choose the selection tool or press to dismiss the
ellipse tool.

To resize an ellipse or cirde

Use the selection tool to select an ellipse or a circle. Edit
handles appear on all four corners of the rectangle that
encloses it. With the pointer on one of the handles, press
the mouse and drag the handle.
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Drawing arcs

You create an arc of any angle using the arc tool. Because
it is a line, an arc adopts the current line style. If you want
to create a full circle, use the ellipse tool.

Drawing an arc is done in three stages:

1
2

3

Specify the center of the arc with the first mouse click.

Specify the radius of the arc with the second mouse
click.

Specify the arc segment endpoint with the third
mouse click.

Capture draws the arc counterclockwise from the
endpoint, and displays in the selection color.

To draw an arc

w

From the Place menu, choose Arc.
or
Choose the arc tool on the tool palette.

Move the pointer to establish the center of the arc, and
press and hold the left mouse button.

radius of the arc, then click the left mouse button to
establish the location of one end of the arc.

Drag the mouse out from the center to establish t

Use the mouse to establish the other end of the arc and
click the left mouse button. The arc is drawn
counterclockwise from the endpoint, and displays in
the selection color.

Choose the selection tool or press to dismiss the
arc tool.

To resize an arc

1

Use the selection tool to select an arc. Edit handles
appear at the ends of the arc.

With the pointer on one of the handles, press the
mouse and drag. The center remains the same. The
other arc endpoint uses the new radius.



Drawing polylines and polygons

Drawing polylines and polygons

To draw a line with multiple contiguous segments, use the
polyline tool. The line you draw adopts the current line
style. Polygons can be created with the polyline tool, and
they adopt the current fill style. To create a
non-orthogonal polyline, hold down the key
while you draw.

To draw a polyline

1 From the Place menu, choose Polyline.
or
Choose the polyline tool on the tool palette.

2 Click the left mouse button to begin drawing, click to
change directions, and double-click to end the final
segment. To draw non-orthogonal polylines, press
(<> Shift). After you double-click, the polyline displays
in the selection color.

3 Choose the selection tool or press to dismiss the
polyline tool.

To draw a polygon

1 Follow the instructions above, ending the line with a
single mouse-button click at the beginning point. The
polygon adopts the current line and fill style.

To resize a polyline or polygon

Use the selection tool to select a polyline or polygon. Edit
handles appear at the ends of all the lines in the
polyline/polygon. With the pointer on a handle, press the
left mouse button and drag the handle.
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Adding fill to an object

You can have closed shapes automatically filled in after
you finish drawing them by defining a default fill. From
the Options menu, choose Preferences, then choose the
Miscellaneous tab. Click the Fill Style drop-down box to
display the options. Note that you can specify separate
options for the schematic page editor and the part editor.
Select one of the options and click OK.

To add fill to an object
1 Select the object
From the Edit menu, choose Properties.

3 Select a fill style from the Fill Style drop-down box,
then click OK.

Mirroring an object

You can mirror objects horizontally, vertically, or both
horizontally and vertically. Some objects, such as text and
bitmaps, cannot be mirrored. If the Mirror command
appears dimmed on the Edit menu, the object cannot be

mirrored.

To mirror an object

1 Select the object.

2 From the Edit menu, choose Mirror, then choose
Mirror Horizontally, Mirror Vertically or Both. The
object flips in the chosen direction.



Rotating an object

Rotating an object

You can rotate objects by 90° increments. Some objects,
such as bitmaps, cannot be rotated. If the Rotate command
appears dimmed on the Edit menu, the object cannot be
rotated.

To rotate an object

1 Select the object.

2 From the Edit menu, choose Rotate. The selection
rotates 90° counterclockwise.

Moving an object

1 Move the mouse anywhere over the object, except
over resize handles.

2 Press the left mouse button, without releasing it, and
drag the object until it is where you want it.

3 Release the mouse button.

Cutting an object

Select the object. From the Edit menu, choose Cut. The
object is removed from the schematic page and placed on
the Clipboard.
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Tip After you copy an object using the
second method, you can use the Repeat
command (from the Edit menu) to place
multiple copies of the object using the same
spacing. This is a quick way fo create an
array of aligned objects.

Note (apture can only paste text from
Windows applications into the Place Text
window, and not directly onto the page.
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Copying an object

There are two ways to copy an object:

Select the object. From the Edit menu, choose Copy.
The object remains on the schematic page and a copy
of it is placed on the Clipboard. It can be pasted in
Capture or in other Windows programs.

or :

Position the pointer on the object. Press the left mouse
button, hold down the key, and drag a copy of the
object to the new location.

Pasting an object

To use the Paste command, an object must already be on
the Clipboard via the Cut or Copy command. Place the
pointer where you want the object to be pasted. From the
Edit menu, choose Paste. The object is placed on the
schematic page.

Deleting a selected object

There are several ways to delete a selected object:

From the Edit menu, choose Delete.

From the right mouse button’s pop-up menu, choose
Delete.

Press [Delete).
Press [«+—Bksp].



Placing a bitmap

Placing a bitmap

You can create a bitmap in another application and place
iton a schematic page, on a library part, or in a custom title
block.

To place a bitmap

5

From the Place menu, choose Picture. A standard
Open dialog box appears.

Select the bitmap file. If the file is not listed in the File
name text box:

a Inthe Look in drop-down list, select a new drive.
b Choose the Up One Level button.

¢ In the Files of type box, select the type of file you
want to open.

Click OK. A rectangle representing the bitmap image
is attached to the pointer.

Click the left mouse button to place the bitmap at the
desired location. If you want to place multiple copies
of the bitmap, repeat this step.

Press or choose the selection tool.

To resize a bitmap

1

Select the bitmap so that it displays in the selection
color with edit handles at the four corners.

Position the pointer over an edit handle and drag the
edit handle. The bitmap’s size and shape change to
accommodate the new dimensions. Using the
key constrains resizing the bitmap to proportional
changes in the horizontal and vertical directions.

Note Because some printers and plotters
do not interpret bitmaps correctly, you
should place one bitmap and print or plot it,
to ensure that the output is what you want
before you place multiple bitmaps.
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Tip The font size and style of any text
placed in the default font setting can be
globally changed using the settings in the
Design Properties dialog box. Changes to
these design property settings will not
affect any text on a design that is not set fo
the default font.

Tip If you have text in another Windows
application, you can copy it to the Clipboard
and paste it into the text dialog box using

the (Ctri)+(C) and (Ctrl)+(V) shorfcut

keys, respectively.
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Placing text

You can place text, in the font of your choice, on a
schematic page or on a part to document your schematic

page.

To place text on a schematic page

From the Place menu, choose Text.
or
Choose the text tool on the tool palette.

Enter the text. To type numbers using the numeric
keypad on your keyboard, you must first enable the

key.

Complete the dialog box selections by specifying font,
color, and rotation.

Click OK to close the dialog box. A rectangle
representing the text is attached to the pointer.

Click the left mouse button to place the text at the
desired location. You can place multiple copies of the
text by clicking the left mouse button at each location
where you would like text.

When you are done placing text, choose End Mode
from the right mouse button pop-up menu or press

(Esc).

To move text

Select the text so that it displays in the selection color
with edit handles at the four corners.

Position the pointer over the text—not an edit
handle—and drag the text to the new location.

Release the mouse button to place the text.

Click an area where there are no parts or objects to
deselect the text.



Placing text

To move or copy text using the Clipboard

1
2

Select the text.

From the Edit menu, choose Cut. The text is placed on
the Clipboard.

or

From the Edit menu, choose Copy. A copy of the text
is placed on the Clipboard.

From the Edit menu, choose Paste. The text is attached
to the pointer.

Move the pointer to the location where you want to
place the text and click the left mouse button. The text
is placed and displays in the selection color.

Click an area where there are no parts or objects to
deselect the text.

To rotate text

1

Select the text so that it displays in the selection color
with edit handles at the four corners.

From the Edit menu, choose Rotate. The text rotates
90° counterclockwise.

Repeat step 2 as necessary.

Click an area where there are no parts or objects to
deselect the text.
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The text bounding box

Text that you place wraps according to the dimensions of
its bounding box.

To change how the text wraps

1 Select the text so that it displays in the selection color
with edit handles at the four corners.

2 Position the pointer over an edit handle and drag the
edit handle. The text inside the bounding box rewraps
within the new dimensions.

Deleting text

To delete the text and its bounding box, select the text so
that it displays in the selection color with edit handles at

the four corners. Press either the key or the
key.

To delete text when it is highlighted in the Edit Text dialog
box, press the key, the key, or begin typing

new text.

To delete individual words within the text, double-click
the text, or select the text and choose Properties from the
Edit menu. The Edit Text dialog box appears, with the text
highlighted. Press one of the four arrow keys to remove
the text highlighting. Double-click the word you want to

remove. Press the key or the key.

Modifying text

To add more text to text you have already placed,
double-click the text, or select the text and choose
Properties from the Edit menu. The Edit Text dialog box
appears, with the text highlighted. Press one of the four
arrow keys to remove the text highlighting. Type the
additional text. When you are done, click OK.



Placing text

Finding texi

You can use the Find command to search for text in an
entire project, in selected schematic pages, on one
schematic page, or in the part editor.

To find text

1

4
5
6

In the project manager, select the root schematic folder
(to search the entire project) or select specific
schematic pages.

or

Make the schematic page editor or the part editor the
active window.

From the Edit menu, choose Find. The Find dialog box
appears.

Leave the asterisk in the Find What text box to locate
all occurrences of all text.
or

Narrow the text search by entering specific text in the
Find What text box.

Verify that the Match Case option is as you want it.

Select Text from the object types in the Scope area.
Click OK.

If you search the entire project or selected schematic pages
from the project manager, the search results are listed in

the browse window. If you search with either the

-

schematic page editor window or the part editor window
as the active window, the results of the search display in
the selection color in either the schematic page editor
window or the part editor window.
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Replacing text

Schematic page editor or part editor text can be replaced
by entering the replacement text from the keyboard, or
copying the replacement text from another application.

To replace text

1 Select the text so that it displays in the selection color
with edit handles at the four corners.

2 From the Edit menu, choose Properties. The Edit Text
dialog box appears, with the text highlighted.

3 Enter the replacement text, then click OK.

Importing text

You can import text from any Windows program that
copies text to the Clipboard.

To import text from other Windows applications

1 Inthe other Windows application, copy the text to the
Clipboard using that program’s Copy command.

2 Make the schematic page editor or part editor the
active window.

3 From the Place menu, choose Text. The Place Text
dialog box appears.

4 Press(Ctrl]+V] to paste the text into the text box, then
verify that the color, font, and rotation are as you want
them and click OK. A rectangle representing the textis
attached to the pointer.

5 Click the left mouse button to place the text at the
desired location.

6 When you are done placing text, press (Esc) or choose
the selection tool.



Placing text

Exporting text

You can export Capture text to any Windows program
that uses the Clipboard. You must select the text within
the Edit Text or Place Text dialog boxes. Otherwise,
copying a text object treats the text as a graphic.

To export text to other Windows applications

1

In Capture, double-click the text you want to export.
Capture displays the Edit Text dialog box.

Select the text.
From the Edit menu, choose Cut or Copy. The text is

placed on the Clipboard.
4 Activate the other Windows application and use that
application’s Paste command to place the text.
Character formatting

You may want the text to have a distinctive appearance, or
to fit within a specific space. Capture supports TrueType®
fonts. You can preview a sample of the selected font before
you choose it. You can also select the default font that you
set up in the Fonts tab in either the Design Template
dialog box or the Design Properties dialog box (available
from the Options menu).

To change fonts and point sizes

If you are placing the text, choose Text from the Place
menu. The Place Text dialog box appears.

or

If the text has already been placed, double-click the
text. The Edit Text dialog box appears.

In the Font group box, click the Change button. The
Font dialog box appears.

Select a font, style, and size. Sample text displays in
the Sample group box.

4 (Click OK twice.
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About screen fonts

For information about setting up your screen fonts, see
Chapter 4, Setting up your project.
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In the schematic page editor, you can create a macro by
recording a series of editing actions. For example, you can
begin a macro recording, place a wire, place text that
names the wire, then stop the macro recording. Macros are
recorded at the command level (not at the keystroke level)
and each macro is stored as a separate file. You can also
create a macro in ASCII text, using valid Visual Basic
syntax.

When you record a macro, Capture assigns it a temporary
name, and treats it as a temporary macro. Temporary
macros can be run during the current Capture session, but
they are not saved for use in subsequent Capture sessions.
You can make a temporary macro permanent by saving it
using the Configure Macro dialog box (choose Configure
from the Macro menu).

For samples of valid Visual Basic syntax,
see Capture’s online help.
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In general, you can record a macro command for each
menu command available in the schematic page editor.
However, because the macro commands are limited to the
schematic page editor window, the following commands
that result in moving to a new window are unavailable:

e Ascend
e Descend
e Edit Part in Place

When recording a macro, the Undo command is not
recorded as a part of the macro. For this reason, you
cannot create an undo macro using the Undo command.



Recording a macro

Recording a macro

A location recorded within a macro is relative to the
previous action, not relative to where you began
recording the macro. For example, you can record a macro
to place a wire, move the cursor down one grid space, then
place another wire. When you run the macro at a different
location on your schematic page, the macro places a wire,
moves down one grid space, then places another wire
below the original wire.

To record a macro

1 Click the left mouse button on the schematic page to
set a location to begin recording the macro.

2 From the schematic page editor’s Macro menu, choose
Record. The macro recorder tool palette containing
three buttons displays, as shown.

3 Perform the series of edits that you want to record as a
macro, using the three macro record buttons as
necessary.

e Use the left button to stop recording the macro.

e Use the center button to pause recording. The
pause mode is in effect until you click the center
button again.

e Use the right button to cause a command to begin
recording in a “with dialog” mode. If a command
is recorded in this mode, the value you enter while
recording the macro is not saved. Instead, when
the macro is run, the command displays a dialog
box so that you can fill in a value. When recording,
the “with dialog” mode is in effect until you click
the right button again. Use this button again to
stop recording in “with dialog” mode.

4 Choose the left macro record button to stop recording
the macro.
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Playing a macro

Choose Play from the Macro menu to play back the most
recently recorded macro or any macro you choose in the
Configure Macro dialog box.

To play a macro

1 Click the left mouse button on the schematic page to
set a location to begin playing the macro.

2 From the schematic page editor’s Macro menu, choose
Play.
or
From the Configure Macro dialog box, choose Play.



Configuring a macro

Configuring a macro

After you record a macro, you give it a name, and you can
also assign it a menu entry, a shortcut key definition, and
a description. Once you give a macro a name and save it,
it automatically displays in the Macro name list box in the
Configure Macro dialog box the next time you run
Capture. The text you enter as the menu entry displays on
the Macro menu, along with the macro’s shortcut key
definition, if you specified one. The text you enter as the
description displays in the Description text box in the
Configure Macro dialog box when you highlight the
macro name.

To configure a macro

1 From the schematic page editor’s Macro menu, choose
Configure. The Configure Macro dialog box appears.

If the macro you want is not selected, select it.

3 In the Macro Name text box, enter a name for the
macro and click the Save button. The Macro Name
dialog box appears.

4 To assign a shortcut key, enter text corresponding to a
shortcut key or key combination (for example,
(Ctr]+{(7)) in the Keyboard Assignment text box.

5 To have the macro appear as an entry on the Macro
menu, enter the appropriate text (for example,
Wirenames) in the Menu Assignment text box.

6 Todescribe the macro, enter the appropriate text in the
Description text box.

7 Click OK. The Save As dialog box appears.

8 Select a file location and filename, click the Save
button, then click the Close button.

Note After editing a macro, you must
reconfigure it. Use the Add butfon in the
Configure Macro dialog box to locate the
macro on your system. Select it and click
Open.
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Configure Macro dialog box

Trptacro

Figure 56 Configure Macro dialog box

Macro Name Displays the macro name. You can either
select a macro from the macro name list box or type in a
macro’s name. The macro shown in the Macro Name field
is the macro that is run if you choose Play from the Macro
menu or click the Run button in the Configure Macro
dialog box.

Configured Macros Displays the currently configured
macros and any currently available temporary recordings.
Selecting a name from the list fills in the dialog box fields
with the appropriate values.

Close Closes the dialog box. Since the changes you
make in the dialog box are immediately saved to memory,
these edits are not permanently saved to the file unless
you use the Save command before you use the Close
command.



Configuring a macro

Record Closes the dialog box, displays the macro record
dialog box, and records your editing actions until you
click the Stop button in the macro record dialog box. A
recording is temporary (only available for the current
Capture session) unless you assign it a macro name and
save it using either Save or Save As.

Play Runs the active macro.

Add Displays a dialog box that you use to add a macro
you have created. The macro must be in ASCII text, and
use valid Visual Basic syntax. A newly added macro is
highlighted in the list of macros and becomes the active
macro.

Remove Removesa macro from the list of permanent
macros, but does not remove the macro from your hard
disk.

Save Updates an existing macro on your hard drive or
saves a temporary macro to your hard drive. Saving a
macro adds it to the list of configured macros and makes
it the active macro.

Save As Displays a Macro Name dialog box that you
use to assign the macro a name, keyboard assignment,
menu assignment, and description. Saving amacro adds it
to the list of configured macros and makes it the active
macro.

Keyboard Assignment Specifies the shortcut key
associated with the macro. You can specify a shortcut key
for a temporary macro recording or change the shortcut
key used for an existing macro by entering the text
equivalent of a keyboard sequence in the Keyboard
Assignment text box.
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Menvu Assignment Specifies the menu assignment
associated with the macro. You can specify a menu
assignment for a temporary macro recording or change
the menu assignment used for an existing macro by
entering a menu entry in the Menu Assignment text box.

Description Specifies the description associated with
the macro. You can specify a description for a temporary
macro recording or change the description used for an
existing macro by entering text in the Description text box.
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Naming a macro

You can assign a macro a name of any length. Since

periods aren’t allowed in macro filenames, don’t specify a
tile extension for your macro filename: Capture assigns an
extension of .BAS to your macro filename. If you want,
you can rename the file with a different file extension

using the Rename command in Windows Explorer.

There are some restrictions regarding the names you give
your macros. These restrictions are given below.

* You cannot use spaces in a filename.

® You cannot use the following filename extensions for

your macro names, since they are reserved for

Capture’s use: .DBK, .DLL, .DSN, .EXE, .INI, .OBK,

and .OLB.

e You cannot use any of the names in Table 4 for your

macro names, since they are reserved for use by

Capture’s macro subroutines.

Table 4 Capture’s macro subroutines

Copy
DisplayPropertyEx
EndPlace
FindHierarchicalPorts
FindParts
GoToAbsolute
GoToRelative
MirrorVertical
PlaceArc
PlaceBookMark
PlaceBusEntry
PlaceGroundWithDialog
PlaceNetAlias

Cut

Drag
FindBookMarks
FindNets
FindText
GoToBookMark
Group

Move
PlaceBlock
PlaceBookMarkWithDialog
PlaceEllipse
PlaceJunction

PlaceNetAliasWithDialog

Delete

Duplicate
FindDRCMarks
FindOffPageConnectors
GetProperty
GoToGridReference
MirrorHorizontal
Paste
PlaceBlockWithDialog
PlaceBus

PlaceGround
PlaceLine

PlaceNextPolygonPoint
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Table 4 Capture’s macro subroutines (continued)

PlaceNextPolylinePoint
PlaceOffPageWithDialog
PlacePicture
PlacePolygon
PlacePortWithDialog
PlaceRectangle
PlaceTitleBlock
RemoveDisplayProperty
Rotate

SelectObject

SetFont

SetLineStyle
ShowSpreadsheet
UnSelectObject
ViewPalette

ZoomAll

ZoomOut

PlaceNoConnect
PlacePart
PlacePin
PlacePolyline
PlacePower
PlaceText
PlaceTitleBlockWithDialog
RemoveProperty
SelectAll
SetColor
SetFontEx
SetLineWidth
Ungroup
ViewGrid
ViewStatusBar
ZoomArea

ZoomScale

PlaceOffPage
PlacePartWithDialog
PlacePinWithDialog
PlacePort
PlacePowerWithDialog
PlaceTextWithDialog
PlaceWire
ReplacePart
SelectBlock
SetFillStyle
SetHatchStyle
SetProperty
UnSelectAll
ViewGridReference
ViewToolbar
ZoomlIn

ZoomSelection
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Assigning a shortcut key to a
macro

To assign a shortcut key to a macro, enter an
alphanumeric character (such as K) in the Keyboard
Assignment text box of the Configure Macro dialog box,
then save the macro. To enter a combination of keyboard
keys and alphanumeric characters, add a plus sign (+),
either with or without spaces, between the items (for
example: ALT+2 or ALT + 2). Shortcut keys are not
case-sensitive: you can specify ALT+2 or ALT+2.

To assist you in assigning shortcut keys to your macros,
Capture has reserved the following shortcut-key starting
sequences:

C, T,R,L=[Ct)

A L, T=(At)

S, H,IF, T=(onf)
(Ctri)-+{Alt]

(Ctrl)+{-> Shift]
(CtriJ+{ Alt J+{ <> Shift)
(AltJ+{-> shift]

To use one of the starting sequences, enter the letters on
your keyboard that represent each key in the Keyboard
Assignment text box, add a plus sign (+), then add an
alphanumeric character (for example: CTRL+P). You have
to use the starting sequences in the same order, and in the
same format, as shown in the list above. For example, you
cannot reverse the order of the keys, nor can you use
CONTROL instead of CTRL. You cannot use a shortcut-key
starting sequence by itself. For example, SHIFT by itself
will not function as a shortcut key. Table 5 shows all of the
alphanumeric characters, function keys, punctuation
keys, special keys, and arrow keys that you can use with
the shortcut key starting sequences listed above.

Any shortcut keys you assign to your
macros take precedence over the shortcut
keys assigned to other Capture functions.
For example, you can use (Ctrl}+{Del] as
a key combination for a macro, even
though it is the key combination assigned
to clear the Capture session log. To restore
an original shortcut key assignment (in this
example, restoring (Ctrl)+Del] o its
original function of clearing the session
log), assign a different shortcut key to your
macro using the Keyboard Assignment text
box in the Configure Macro dialog box,
click Save, then click Close.
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Table 5 Valid shortcut keys

Type of key Available keys

Alphabetic character through (2], inclusive

Numeric character @ through @, inclusive

Function key F1 through F24, inclusive

Punctuation key [I], , , , , , / , /
Special key (Esc), (Ins), (Del), (PgUp), (PgDn), (Home),
Arrow key ), =2.01)

Caution Do not open a Capture macro
with Visual Basic. Visual Basic will add
formatting to the file if you save it.
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Sample macros

Provided with Capture are a number of sample macros
that you can use. These files are saved in the

\ORCAD\ CAPTURE\MACROS directory when you do
a typical installation. Open them with a text editor to view
or edit them.



Changing your view of a
schematic page

There are several ways to change your view of a schematic
page. They include zooming to a smaller or larger view of
the schematic page, centering a view on a particular

position, and moving to a different location. You can also
choose whether or not to display a grid or grid references.
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Note If you choose an editing function,
then choose a command to change the
view, your next mouse click implements the
editing function. For example, if you select
the circle tool and then zoom in or out, your
next mouse click starts a circle.
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Zooming

In the schematic page editor and in the part editor, you
can look closely at a particular area by using the Zoom In
command on the View menu. Conversely, you can change
your viewing perspective to increase the portion of the
drawing board that is visible by using the Zoom Out
command. When you zoom in or out, Capture centers
your view on the current pointer position, if possible. If
the pointer is outside the window, or if you choose the
Zoom In or Zoom Out toolbar button, Capture centers
your view on any selected objects. Otherwise, Capture
zooms in or out on the center of the active window.

To zoom in

1 From the View menu, choose Zoom, then choose In.
or
Choose the zoom in tool on the toolbar.

The current zoom scale is multiplied by the zoom factor.
With a zoom factor of two, zooming in makes the image
twice as large and displays half the area of the previous

view.

To zoom out

1 From the View menu, choose Zoom, then choose Out.
or
Choose the zoom out tool on the toolbar.

The current zoom scale is divided by the zoom factor.
With a zoom factor of two, zooming out halves the image
size and shows twice the area of the previous view.

To change the zoom factor

1 From the Options menu, choose Preferences, then
choose the Pan and Zoom tab.

2 In the Zoom Factor text box, enter the new zoom
factor. Note that you can specify separate values for
the schematic page editor and the part editor.

3 Click OK.



Looming

“Zooming fo a specified scale

The Zoom Scale dialog box provides predefined scales
(25%, 50%, 100%, 200%, 300%, and 400%). You can also
type in a custom scale value (as a percentage). The scaling
limits the size of the schematic page that appears (for
example, if 1 unit = .01", then you can display: 320" at
100%, 160" at 200%, 80" at 400%, and so on).

To zoom to a specific scale

1 From the View menu, choose Zoom, then choose
Scale. The Zoom Scale dialog box appears.

Select one of the preset scales, or enter a custom scale.

3 Click OK.

Other viewing options

You can view a selected area or the entire page, or you can
center your view.

To view a selected area

1 From the View menu, choose Zoom, then choose Area.

or
Choose the zoom area tool on the toolbar.

Move the pointer to one corner of the area to view.

Press and hold the left mouse button as you move the
pointer to the opposite corner of the area to view.

4 Release the mouse button. The area expands to fill the
window.

Tip You can view the current scale in the
status bar at the bottom of the schematic
page editor window. It displays to the left of
the X and Y coordinates.
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To view the entire page or part

1 From the View menu, choose Zoom, then choose All.
or
Choose the zoom all tool on the toolbar.

The entire schematic page or part shrinks or expands
to fit the window.

To center the view on an object or area
1 Select objects or an area.

2 From the View menu, choose Zoom, then choose
Selection.

The display scrolls so that the selected objects or selected
area is in the center of the window. The zoom scale does
not change.

To center the view on your pointer

1 Press (< Shift)+C).

The display scrolls so that the pointer’s selection is in the
center of the window. The zoom scale does not change.



Moving to a new location

Moving to a new location

There are several different ways you can move to a new
location on a schematic page. To move using the methods
listed below, use the Go To command and dialog box. You
can:

e Move to a particular set of X, Y coordinates or to an X,
Y location offset from the pointer’s current position.

e Move to a grid reference area, as indicated by the
horizontal and vertical grid reference headings.

e Move to alocation previously marked by a bookmark.

From the View menu, choose Go To to display the Go To
dialog box, which has three tabs labeled Location, Grid
Reference, and Bookmark, shown below and on the next

page.

Moving to an X, Y location

The X and Y coordinates of your pointer’s current location
appear on the right side of the status bar.

To move to a specific location

1 From the View menu, choose Go To. The Go To dialog
box appears.

Choose the Location tab.

3 Enter the X and Y values, select the Absolute option,
then click OK. The coordinates are measured in inches
or millimeters, depending on what you have
configured in the Page Size tab on the Schematic Page
Properties dialog box. Your pointer moves to the new
coordinates.
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To move a speific distance

1 From the View menu, choose Go To. The Go To dialog
box appears.

Choose the Location tab.

Enter the X and Y values that you want the pointer to
move, select the Relative option, then click OK. The
jump distance is measured in inches or millimeters,
depending on what you have configured in the Page
Size tab on the Schematic Page Properties dialog box.
Your pointer moves the specified distance.

Go To dialog box, Location tab

lGo To

Figure 57 Location tab of the Go To dialog box
X Specifies the X-axis coordinate for the jump.
Y Specifies the Y-axis coordinate for the jump.

Absolute and Relative Specifies the jump as absolute
(to the indicated coordinates) or relative (the coordinates
are offset to the pointer’s current position).
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Jumping to a specific grid reference

Grid references appear on the left and upper edges of the
schematic page.

To jump to a reference area

1 From the View menu, choose Go To. The Go To dialog
box appears.

2 Choose the Grid Reference tab.

3 Select a horizontal grid reference from the Horizontal
drop-down list.

4 Select a vertical grid reference from the Vertical
drop-down list.

5 Click OK.

Go To dialog box, Grid Reference tab

= :

Figure 58 Grid Reference tab of the Go To dialog box

Horizontal Specifies a horizontal grid reference for the
jump.

Vertical Specifies a vertical grid reference for the jump.
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Jumping fo a marked location

To return repeatedly to a specific area of a schematic page,
or to direct attention to a particular location, you can use
a bookmark. To use a bookmark, you assign it a name and
place it on a schematic page. When you want to return to
it, use the Go To command. You can also reuse existing
bookmarks by selecting them and moving them to new
locations. Bookmarks are saved with your project.

To place a bookmark

1 From the Place menu, choose Bookmark. The Place
Bookmark dialog box appears.

Enter the name of the bookmark, then click OK.

3 Position the pointer where you want the bookmark
and click the left mouse button. The bookmark is
placed, and displays in the selection color.

4 Click an area where there are no parts or objects to
deselect the bookmark.

To rename a bookmark

1 Select the bookmark.

2 From the Edit menu, choose Properties. The Edit
Bookmark dialog box displays.

Enter a new name in the text box.

Click OK.

To move to a specific bookmark

1 From the View menu, choose Go To. The Go To dialog
box appears.

Choose the Bookmark tab.
Enter the name of the bookmark and click OK.



Moving to a new location

Go To dialog box, Bookmark tah

Go To

Figure 59 Bookmark tab of the Go To dialog box

Name Specifies a name of a bookmark for the jump.
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Displaying the grid and grid
references

Note The setfings in the Grid Display tab ~ You can hide the grid display and grid references, then

in the Preferences dialog box (from the display them again later.
Options menu) control whether the grid ) . .
appears as grid dots or lines. The Grid To display or hide the grid

Display tab setting also controls whether 1

/ . From the View menu, choose Grid.
the pointer snaps to grid.

To display or hide the grid references

1 From the View menu, choose Grid References.
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Finding parts in a project

Using the Find command and a part property value, you
can locate a part in a project, schematic folder, or on a
schematic page. In the Find dialog box, you enter a
property value string and specify that you want to find a
part. Capture searches all the parts to find those with a
property value that matches the string. If you aren’t sure
of the exact property value string, you can enter wildcard
characters to constrain the search list, then click OK. Valid
wildcard characters are an asterisk (*) to match multiple
characters and a question mark (?) to match individual
characters.

To find a part on a schematic page

1 Open the schematic page.
From the Edit menu, choose Find.

Enter the property value string that defines the part
you want to search for.

4 Select Parts from the object types in the Scope area.

Click OK to start the search. Parts that have a property
value matching the property value string of step 3 are
selected on the schematic page.

To find a part in a project

1 In the project manager, select the schematic folder or
schematic pages you want to search.

From the Edit menu, choose Find.

Enter the property value string that defines the part
you want to search for.

4 Select Parts from the object types in the Scope area.

Click OK to start the search. Parts that have a property
value matching the property value string of step 3 are
listed in the browse window.

6 Double-click on the part in the browse spreadsheet to
open the schematic page editor with the found part
displayed and selected.

Tip You can edit the properties of multiple
parts when they are selected using the
property editor. From the Edit menu,
choose the Properties command, or choose
Edit Properties from the right mouse
button’s pop-up menu. For information on
using the property edifor, see The property
editor on page 33.
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Part Three

Libraries and parts

Chapter 11, About libraries and parts, describes how the
parts in a design are stored in the design cache, and how
you can replace or update parts in the design cache.

Chapter 12, Creating and editing parts, describes how to
create new parts and store them in a library, how to edit
parts in a library, and how to edit parts after they are
placed on a schematic page.






About libraries and parts

Capture’s libraries contain more than 30,000 parts. This
chapter describes Capture’s libraries, and explains how
parts, packages, and electrical symbols are stored in
libraries.
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Caution [fyou edit a library provided by
Capture, you should give it a new and
unique name so that you will not copy over
your changes when you receive updated
libraries.

For information about printing a part, see
Chapter 5, Printing and plotting. For
general information about using the project
manager, see Chapter 2, The Capture work
environment.

Tip You can also use the Cut, Copy, and
Paste commands on the Edit menu fo move
or copy parts between libraries.
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Libraries

Libraries are files that contain reusable part data. They
contain parts that you can place as instances on schematic
pages. Libraries contain a variety of symbols (such as
power symbols, ground symbols, and so on) and title
blocks that you can reuse in your projects.

The relationship between the library and the parts and
symbols it contains is similar to the relationship between
a schematic folder and its contents. The contents of the
library move with the library and are deleted with the
library.

You can create custom libraries to store any combination
of items. You can, for example, create a library to hold
schematic pages that you use often. There is no need to
create a library for a project, because the design cache
holds all the parts and symbols used in the design.

When you work with a library in Capture, you use the
project manager. The project manager lists the parts and
symbols contained in the library.

To edit a part, double-click on it. The part opens in a part
editor window.

To move a part to a different library, open the source
library and the destination library in separate project
manager windows. Select the part and drag it from one
library to the other.

To copy a part to a different library, follow the same
procedure but hold the key down while you drag the
part.

Because a library is a file, you can work with it in the
Windows Explorer as well as in Capture. When you need
to back up a library, use Windows Explorer to create a

copy.
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Parts

Parts are the basic building blocks of a design. A part may
represent one or more physical elements, or it may
represent a function, a simulation model, or a text
description for use by an external application. A part’s
behavior is described by a PCB footprint, an HDL
statement, or an attached schematic folder.

Parts usually correspond to physical objects—gates, chips,
connectors, and so on—that come in packages of one or
more parts. Packages that have more than one part are
sometimes referred to as multiple-part packages. For
simplicity, Capture usually refers to both parts and
multiple-part packages as parts.

You can specify packaging information when you create a
part, or you can change it in the part editor (from the
Options menu, choose Package Properties).

Each part has graphics, pins, and properties that describe
it. As you place the parts in a package to suit your design
requirements, Capture maintains the identity of the single
physical part—the package—for back annotation,

netlisting, bills of materials, and processes that require it.

The parts in a package may have different pin
assignments, graphics, and user properties. If all the parts
in a package are identical except for the pin, the package
is homogeneous. If the parts in a package have different
graphics, numbers of pins, or properties, the package is
heterogeneous.
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Part instances and occurrences

A part instance is a part you have placed on a schematic
page. A part instance may have occurrences. A part
occurrence is a part that potentially holds property values
for reuse of the schematic page. For example, a 74L.S04
part placed in the HALFADD schematic is reused. As a
result, it requires two distinct annotations (one for the A
side of the hierarchy, and another for the B side of the
hierarchy). Both of these annotations are occurrence
properties for a single part instance placed on a schematic

page.
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The design cache

When you place the first instance of a part in a design, a
copy of the part is created in the design cache. The design
cache stores one copy of every part used in the design.
Normally, all instances of the part refer to this copy in the
design cache.

An original cache part also retains a link to the library part
on which it is based, so you can update all of the parts in
the design cache to synchronize them with the parts in the
libraries. This action is useful for updating your design if

you have made changes to the library the parts came from.

Once you edit a part instance, the link to the original
library no longer exists. This means that:

e The part instance is not affected by the Update Cache
command.

e To restore its link with the original library, choose the
Replace Cache command from the project manager’s
Design menu.

By updating all instances of a part, you create a new part
that replaces the old part in the design cache, and break
the link with the original library. If you update only the

c1irrontly caloctad nart ingtancoe volr croato 3 now Nnark in
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the design cache for this one part instance, and the new
part has no link to the original library.

To replace a design cache part instance with a different library
part

1 Open the project containing the part instance you
want to replace.

2 Open the design cache and select the part instance you
want to replace.

Note Updating or replacing a part in the
design cache affects every instance of the
part in the design, as long as the part
instances have retained their links to their
original libraries.
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Tip You can leave the Part Name and Part 3 From the Design menu, choose Replace Cache. The

Library fields unchanged to update the part Replace Cache dialog box appears.
instance with its original version. This is ' ‘
useful if you have changed the part
instance in the design cache and would like
to use its original version, or if you have
received an update fo a library and want to
use the new version of the library part.

§ Replace Cache .

CADRCADNCAPTUREALIBRARYASDTATTL.OLE

Figure 60 Replace Cache dialog box

The text boxes in the Replace Cache dialog box contain
the name of the part instance you are replacing and its
original source library.

4 In the Part Name text box, type the exact name of the
library part you want to use to replace the selected
part instance, using appropriate upper case and lower
case letters. (The part names are case sensitive.)

5 Usethe Browse button to find the path and filename of
the part's library. Select the library name, and click
Open. The path and library name appear in the Part
Library text box.

6 Click OK. Capture replaces the part instance you
selected in step 2 with the library part you specified in
steps 4 and 5.

190



The design cache

To update selected parts in the design cache so they match their
corresponding library parts

When you update parts in the cache, any user-defined Note User-defined properties include any
properties are preserved. The properties associated with new property you added to the part in the
the part in the library are updated, including added and design as well as the Value, Part Reference,
removed properties and property values. and PCB Footprint.
1 Ifit’snot already open, open the project containing the

parts you want to update.
2 Open the design cache and select the parts you want to

update.
3 From the Design menu, choose Update Cache.

Capture warns you that you will update the selected

~ parts with parts from their original libraries.

4 Click Yes. Capture updates the parts you selected in

step 2 with their corresponding library parts. Other
projects that use these parts are not affected.
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For more information, see Defining the
default hierarchy option for new projects
on page 74.

Note /fyou attach a schematic folder to a
part in a homogeneous package in a
library, the schematic folder is attached to
each part in the package. Once the part is
placed on a schematic page, you can attach
different schematic folders to each part in
the package.
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Primitive and nonprimitive parts

A primitive part contains no hierarchy. A nonprimitive part
has an underlying hierarchical description, such as an
attached schematic folder. In Capture, this characteristic is
defined in a property, called Primitive, on every part
instance. When a part is specified as primitive, all of
Capture’s tools treat it as such. You cannot descend into a
primitive part, even if it has an attached schematic folder.

You can change the Primitive property as often as you like
during the design process. For example, you might create
a part and attach a schematic folder whose schematic
pages describe the part’s gates and wiring, then attach
schematic folders to some of those parts to describe their
transistors.

The following are some guidelines for using the Primitive

property:

e Before you create a netlist for simulation, specify the
parts as nonprimitive, so that Create Netlist can

descend far enough to find the transistor-level
descriptions.

e Before you create a netlist for board layout, specify the
parts as primitive, so that Create Netlist stops at the
gate-level descriptions.

For part instances that have their Primitive property set to
Default, you can set them as primitive or nonprimitive on
a project-wide basis using the Design Properties
command on the Options menu. Choose the Hierarchy
tab, select either Primitive or Nonprimitive in the Parts
group box, then click OK. This is useful when you are
describing and simulating your design at varying levels of
abstraction (as when using top-down design).



Creating and editing parts

In Capture you can create parts and add them to a new or
existing library. You can also edit existing parts in a
library or on a schematic page. All of these processes are
described in this chapter.

To create or edit a part, you use the part editor. There are
many different ways to access the part editor:

e To create a new part, open a new or existing library in
the project manager with the library selected. From
the Design menu, choose the New Part command.

e To edit an existing part, open a library in the project
manager, then double-click on the part.

e To edit a part instance on a schematic page, select it.
From the Edit menu, choose Part.
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Parts and packages:
homogeneous or heterogeneous

A part may be divided into several logical parts all
contained in a single physical package. You can distribute
the individual logical parts throughout your project,
while maintaining the part’s identity as a single physical
part.

Each logical part has graphics, pins, and properties that
describe it. If you define a package in which all the logical
parts are identical except the pins, the package is
homogeneous. For example, a hex inverter is a
homogeneous package. If the logical parts vary in
graphics, number of pins, or properties, the package is
heterogeneous. An example of a heterogeneous package is
a relay with a normally open switch, a normally closed
switch, and a coil.

Both homogeneous and heterogeneous packages may
have shared pins, such as supply pins that are used by
every logical part in the package. Often, these pins are
invisible, but are connected by name to a power or ground
net.
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Creating a new part

You can create your own custom parts and save them in a
library. A custom part can be a single part, or it can be a
package that contains multiple parts. It can contain pins,
graphics, text, and IEEE symbols. Graphics must be
within the part’s body, while text and IEEE symbols can
be either inside or outside the part’s body. Pins are
attached to the part at the part body border, which defines
the size and shape of the region in which you create the
part body.

To create a part, you complete three processes:
¢ Define the part.

e Draw the part.

e Place pins on the part.

This section describes these processes

Defining a part

Before you begin drawing a part, you must provide
Capture with specific information about the part, such as
the part’s name. If the part is a multiple-part package, you
can specify how many parts are in the package and
whether the part is homogeneous or heterogeneous. Once
you provide this information, you can draw the part, place
graphics, and place pins.

To define a new part

1 In the project manager, select the library you want to
add the new part to.

2 From the right mouse button’s pop-up menu, choose
New Part. The New Part Properties dialog box

appears. See New Part Properties dialog box on page 198.

Note If you're creating a multiple-part
package, the part editor window contains
the first part in the package. If you are
creating a homogeneous part, all edits you
make to this part (with the exception of
changes to pin numbers) apply to all parts
in the package. If you are creating a
heterogeneous part, edits you make fo this
part apply to this part only. To edit a

different part in the package, choose Next

Part or Previous Part from the View menu.

To view all the parts in the package, choose
Package from the View menu. You can edit
a part by double-clicking on it in the
package view.

To view all of the package information,
choose Package from the View menu, then
choose Properties from the Edit menu. The
Package Properties spreadsheet appears,
showing the order of the pins, the groups of
pins that are swappable, the pin numbers,
the pin names, the pin types (normal or
convert), and whether the pins are marked
as Ignore.
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Caution Once you designate the package
type as either Homogeneous or
Heterogeneous and click OK to close the
New Part Properties dialog box, the
package type is set, and cannot be
changed.

| B LIBRARY1 - NEWPART

Note For general information about
adding graphics and text, and detailed
information about placing IEEE symbols,
see Adding graphics, text, and [EEE symbols
to a part on page 201. For details about
each of the graphic and text tooks, see
Chapter 8, Adding and editing graphics and
text.
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In the Name text box, type a name for the part you are
creating. You can use the default settings for the other
options on this dialog box, or you can change them to
fit your requirements. For example, if this part is a
multiple-part package, enter the number of parts in
the package. All fields on the New Part Properties
dialog box are described later in this section.

When the part is specified to your requirements, click
OK.

The part editor window appears, showing a dashed
outline, which is the part body border. Pins will be
placed on the part outside of this region, touching the
part body border. The part’s value displays below the
part, and the part’s reference displays above the part.
The part editor window’s title bar shows the name of
the library, followed by the name of the part you are
creating.

To change the size and shape of the part body border,
select the border and drag the selection handles until
the part body border is the size you want. You can
resize the part body border later.

To draw the part

6

Once you have established the part’s border, you can
use the drawing tools on the part editor’s tool palette
to draw the part and place text on the part. All
graphics that make up the part must fit within the
boundaries of the part body border—with the
exception of IEEE symbols and text. If you draw or
place something other than IEEE symbols or text
outside of the part body border, the part’s border
expands to encompass the graphics.
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To place pins on the part

7 You can add pins to the part using the pin tool or the
pin array tool. This is described in Placing pins on a part
on page 202 later in this chapter.

8 Whenyou are done creating the part, you must save it.
From the File menu, choose Save.

If you are creating this part in a new library that hasn’t
yet been saved, the Save As dialog box appears, giving
you the opportunity to name the library file. If you are
creating this part in a library that already exists, the
part is saved in that library.
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Tip After you have defined the part in the
New Part Properties dialog box, you can
edit the part (except for changing the
Package Type) using the Edit Part
Properties dialog box. From the View
menu, choose Package, then from the
Options menu, choose Package Properties.

Caution Once you decide if the part has a
convert view, and click the OK button to
close the dialog box, you cannot add or
delete the convert view.

Note Once the number of parts in a
heterogeneous part s set, it cannot be
changed.
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New Part Properties dialog box

New Part Properties

Figure 61 New Part Properties dialog box

Name The name of the part. This is used as the default
part value when the part is placed on a schematic page.

Part Reference Prefix Specifies the part reference
prefix, such as C for capacitor or R for resistor.

PCB Footprint The PCB physical package name to be
included for this part in the netlist. OrCAD Layout uses
this field to place the correct components on the printed
circuit board.

Create Convert View Some library parts have a
second form, such as a DeMorgan equivalent, as well as
the standard representation. Select this option to give the
part a alternative view. If a part has a convert view, you
can switch between the part’s normal and convert views
once the part is placed on a schematic page.

Parts per Pkg Specifies the number of parts in the
package.
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Homegeneous or Heterogeneous If the partisa
multiple-part package, this specifies whether all the parts
in the package have the same graphical representation
(homogeneous) or different graphical representations
(heterogeneous).

Alphabetic or Numeric If the part is a multiple-part
package, this specifies whether parts in the package are
identified by letter or number. For example:

e U?A (alphabetic)
e U?-1 (numeric—usually used for connectors)

Caution If you use Alphabetic identifiers, you are limited to 26 parts per
package that will use letters. Parts with more than 26 parts will use
numbers as identifiers, instead of doubling up the letters, as in A4,
AB, and so on.

Part Aliases Displays a dialog box that you use to add
or remove part aliases, which are duplicate copies of parts
that use different names in a library. Part aliases use the
same graphics, attached schematic folders, and properties
as the originals, with the exception of the part values.

Attach Implementation Displays a dialog box that
you can use to attach a schematic folder, VHDL entity,

netlist, project, or PSpice model, thus creating a hierarchy.

See Capture’s online help for more
information on creating and using
heterogeneous parts.

Note The path and filename of the library
that contains the part are displayed at the
bottom leff corner of the dialog box.

Tip When you view a list of parts in a
library, any parts that are placed via part
alias display with lines through their
centers.

Caution An attached schematic folder or
other file external to the project or library
is not stored with the project or library. If
you copy or move the project or library to
a new location, you must also move or copy
the attached object to keep them together.
In addition, you may need to edit the path
o the attached schematic folder or file if
you move the project to a new location with
a different directory structure.
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Note Library parts, part instances, part
occurrences, and hierarchical blocks can
have attached schematic folders. This
section provides information about
attaching a schematic folder to a library
part. This information also applies,
however, to part instances, part
occurrences, and hierarchical blocks.

Note For more information about the
primitive and nonprimitive seffings, see
Primitive and nonprimitive parts on page
192.

Tip To define a part instance as
nonprimitive, double-click on it, then set
the Primitive option to No in the Edit Part
dialog box. In this way, you can also set
whether or not to descend the hierarchy on
an occurrence-by-occurrence basis.

Part instances with their Primitive property
set to Defaulf can be changed to primitive
or nonprimitive on a project-wide basis
using the Design Template or Design
Properties commands on the Options menu.
Choose the Hierarchy tab, select either
Primitive or Nonprimitive in the Parts
group box, then click OK.
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Attaching a schematic folder to a part

Attaching a schematic folder to a part creates hierarchy in
Capture. When you attach a schematic folder to a part,
you specify the schematic folder’s name or, optionally,
specify a project containing the schematic folder. If you
don’t, Capture assumes the schematic folder is contained
in the current project. If you attach a schematic folder to a
part, you can move or copy the child schematic folder into
the same library as the part after the schematic folder is
created. This permits the part and attached schematic
folder to be reused in other projects. If you specify an
attached schematic folder, but the schematic folder has
not yet been created, Capture creates the schematic folder
when you descend the hierarchy on the part. To descend
the hierarchy, you must define the part instance as
nonprimitive.

To attach a schematic folder to a part

1 From the project manager’s Design menu, choose
New Part with the library selected. The New Part
dialog box appears.
or
From the part editor’s Options menu, choose Package
Properties. The Edit Part Properties dialog box
appears.

2 Click the Attach Implementation button. The Attach
Implementation dialog box appears.

3 Enter the name of the child schematic folder.

If the child schematic folder is not in the current
project, use the Browse button to locate the project
library, design, VHDL, or EDIF file where the
schematic folder is located.

4 Click OK twice.

1 Select a part instance on a schematic page. From the
schematic page editor’s Edit menu, choose Properties.
The property editor appears.
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2 In the instance’s Implementation Type cell, select the
appropriate implementation type.

3 In the instance’s Implementation cell, enter the name
of the child schematic folder.

If the child schematic folder is not in the current
project, enter the path and filename of the library,
design, VHDL, or EDIF file.

4 Click Apply.

Adding graphics, text, and IEEE symbols o a part

Once you have defined a part, you can draw an outline to
reflect the part’s shape, and you can add graphics to add
detail to the part. To add graphics to a part, you use the
Line, Rectangle, Ellipse, Arc, Polyline, and Picture
commands on the Place menu or the corresponding tools
on the tool palette. You can also add text to the part using
the Text command on the Place menu or the text tool on
the tool palette. '

A part can include IEEE symbols (shown in the lower
right corner). Unlike graphics, IEEE symbols do not have
to be within the part’s body.

To place an IEEE symbol

1 From the part editor’s Place menu, choose IEEE
Symbol.
or :

Choose the IEEE symbol tool from the part editor’s
tool palette.

2 In the Place IEEE Symbol dialog box, select a symbol
from the Symbol list box. The symbol appears in the
preview box. When you have selected the symbol you
want to place, click OK. The IEEE Symbol dialog box
closes.

For details about each of the graphic and
text tools, see Chapter 8, Adding and
editing graphics and fext.

When you place graphics in a part, they
must be within the part’s body. If they don't
fit within the part’s body, the part body
border expands fo enclose the graphics.

Bit map images placed in part bodies create
huge print and plot files, and can slow down
screen redraws due fo the increased volume
of data.

Tip Like the schematic page editor, the
part editor can display the part you are
working on at several levels of detail. Just
use the Zoom command on the View menu
or the right mouse button pop-up menu.

IOowv = T = _T1L
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Tip Once you've placed an IEEE symbol,
you can change ifs size and shape by
selecting it and dragging its selection
handles.

Tip For easy, accurate placement of pins,
confine the movement of your cursor to the
part body border.
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An image of the IEEE symbol is attached to your
pointer. You can press the right mouse button to
display a pop-up menu with commands that you can
use to change the appearance of the symbol before you
place it. You can mirror the symbol horizontally or
vertically, rotate the symbol, or choose another IEEE
symbol to place.

3 Move the pointer on your part to where you want the
symbol and click the left mouse button to place the
symbol. You can place multiple instances of the
symbol by clicking the left mouse button each place
you want the symbol.

4 When you are done placing symbols, choose the
selection tool or press to dismiss the IEEE symbol
tool.

Placing pins on a part

There are several ways you can place pins on a part. You
can use the Pin command on the part editor’s Place menu
or the pin tool on the tool palette to place individual pins;
or you can use the Pin Array command on the Place menu
or the pin array tool on the tool palette to place several
pins at once.

Pins will always connect to the part body border (the
dotted line around the part). If the edge of a part body
coincides with this border, pins can connect directly to the
part body. However, if the part body is inside this border,
you can draw a line between the part body and the pin on
the part body border to make the pin look as though it
connects to the part body.

To place a pin

1 From the part editor’s Place menu, choose Pin.
or
From the part editor’s tool palette, choose the pin tool.
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The Place Pin dialog box appears. You must provide
information about the pin you are placing.

In the Name text box, type a name and pin number for
the pin you are placing. If a pin name is not specified,
Capture generates one, because pins must be named.

You can use the default settings for the other options
on this dialog box or change them to fit your
requirements. When the pin is specified to your
requirements, click OK.

Using the pointer, drag the pin to the desired location
along the part body border.

Click the left mouse button to place the pin. You can
place multiple instances of the pin by clicking the left
mouse button each time you want to place an instance
of the pin. The pin number and name increment
automatically, if they end with a number.

When you are done placing pins, choose End Mode
from the right mouse button pop-up menu, or press
Esc.

Tip To place multiple pins that are slightly
different, you can click the right mouse
button and choose the Edit Properties
command.
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Note Bus pins can only be used for
simulation purposes. They will not netlist
properly for board layout.

Tip You can make each part’s pin names
visible or invisible. From the part editor’s
Options menu, choose Part Properties.
When the User Properties dialog box
appears, set Pin Names Visible o either
True or False.
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Place Pin dialog box

Place Pin

Figure 62 Place Pin dialog box

Name The name of the pin.

If a pin connects to a bus, the pin should be named in the
format busname [range], for example A[0..3]. You can use
two periods (..), a colon (:), or a dash (-) to separate the
numbers in the range. Bus pins are expanded into separate
pins in a netlist, just as a bus is separated into separate
signals.

To enter a pin name with a bar over it (indicating
negation), type a backslash character after each letter you
want a bar over. For example, type R\E\S\E\T\ to
define the name:

RESET
Number The pin’s number.

Width If a pin connects to a wire, select Scalar. If a pin
connects to a bus, select Bus.
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Pin Visible If this option is selected, the pin is visible
when the part is placed on the schematic page. Otherwise,
the pin is not visible on the schematic page. This option is
only available for power pins.

Shape The shape of the pin, as shown in Table 6.

Table 6 Pin shapes

Shape Description

Dot p— An inversion bubble.

Clock +— A clock symbol.

Dot-Clock +— A clock symbol with
an inversion bubble.

Zero B A normal pin with a
lead zero grid units
in length.

Short - A normal pin with a
lead one grid unit in
length.

Line — A normal pin with a
lead three grid units
in length.

Type The type of the pin, as described in Table 7.

User Properties Displays the User Properties dialog
box. You can use this dialog box to define additional
properties for the pin.

205



Chapter 12 Creating and editing parts

Table 7  Pin types

Pin type Description

3-state A 3-state pin has three possible states: low, high, and high impedance.
In its high impedance state, a 3-state pin looks like an open circuit. For
example, the 7415373 latch has 3-state pins.

Bidirectional A bidirectional pin acts as both input and output. For example, pin 2
on the 741.S245 bus transceiver is a bidirectional pin. The value at pin 1
(an input) determines the activity of pin 2, as well as others.

Input An input pin is one to which you apply a signal. For example, pins 1
and 2 on the 741500 NAND gate are input pins.

Open An open collector gate omits the collector pull-up. Use an open

collector collector to make “wired-OR” connections between the collectors of

several gates and to connect with a single pull-up resistor. For
example, pin 1 on the 74LS01 NAND gate is an open collector gate.

Open emitter

An open emitter gate omits the emitter pull-down. The proper
resistance is added externally. ECL logic uses an open emitter gate and
is analogous to an open collector gate. For example, the MC10100 has
an open emitter gate.

Output An output pin is one to which the part applies a signal. For example,
pin 3 on the 74LS00 NAND gate is an output pin.

Passive A passive pin is typically connected to a passive device. A passive
device does not have a source of energy. For example, a resistor lead is
a passive pin.

Power A power pin expects either supply voltage or ground. For example, on

the 74LS00 NAND gate, pin 14 is VCC and pin 7 is GND.
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Caution Power pins set fo visible in the library will not be global in nature
when the part is placed in a design. You will have to connect these
pins to a net. If you want a power pin to be visible on the schematic
page and global in nature, set it to invisible in the library. After
placing the pin, double-click on the part, and set power pins fo be
visible.

Note  Power pins that are invisible are not connected using wires and
buses, but instead are connected globally via name.
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To place several pins at once

1

From the part editor’s Place menu, choose Pin Array.
or

From the part editor’s tool palette, choose the pin
array tool.

The Place Pin Array dialog box appears. This dialog
box is similar to the Place Pin dialog box, with these
exceptions:

e The Starting Name and Starting Number text
boxes are used to specify a name and pin number
that is incremented for each pin that is placed.

e The Number of Pins, Increment, and Pin Spacing
text boxes are used to specify how the pins are
placed.

In the Starting Name text box, enter the name of the
first pin. If the pin name ends in a digit (0-9),
subsequent pin names in the array will be
incremented by the value in the Increment text box.

In the Starting Number text box, enter the number of
the first pin. Subsequent pin numbers will be
incremented by the value in the Increment text box (if
there is no value in the Increment text box, the pin

names are incremented by 1). If you leave the Starting

Number text box blank, the pins are not numbered.

In the Number of Pins text box, specify how many pins
you want to place.

In the Increment text box, specify the number by
which you want to increment the pin name (if it ends
in a digit) and pin number for each pin in the array. If
there is no value in the Increment text box, the pin
names are incremented by 1.

In the Pin Spacing text box, specify the number of grid
units you would like between each pin.

If necessary, change the default settings for Shape and
Type to fit your requirements, then click OK.

Note Pin name and number only
increment if the starfing name or number
ends with a number. Otherwise, all of the
pins in the array have identical names or
numbers.

Note You can specify a negative
increment to decrement instead of
increment the pin numbers.

Tip For easy, accurate placement of pins,
confine the movement of your cursor to the
part body border.
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8 Using the pointer, drag the pin array to the desired
location along the part body border, then click the left
mouse button to place the array. The array is
positioned so that the first pin in the array is at the
pointer.

9 When you are done placing arrays, choose End Mode
from the right mouse button pop-up menu, or press
Esc).

You can place multiple copies of the array by clicking the
left mouse button each time you want to place an array.
Each time you place the array, the pin names and pin
numbers are incremented based on the number of the last
pin placed.

If the pin array is longer than the edge of the part body, the
part body border expands to accommodate the extra pins.

Once you place an array of pins, you can edit their
properties as a group by selecting the pins, then choosing
Properties from the Edit menu. This opens the
spreadsheet editor, which you can use to edit the
information for the pins.
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Place Pin Array dialog box
Place Pin Amray

Figure 63 Place Pin Array dialog box

Starting Name The name of the first pin in the array. If
the name ends with a digit (0-9), each pin in the array is
incremented by the value specified in the Increment text
box.

For a name with a bar over it (indicating negation), type a
backslash character after each letter you want a bar over.
For example, type R\E\S\E\T\ to define the name:

RESET

Starting Number The number of the first pin in the
array. Each pin in the array is incremented by the value
specified in the Increment text box.

Number of Pins The number of pins in the array.

Increment The number by which to increment the pin
name (if it ends in a digit) and pin number for each pin in
the array. This can be a negative number.
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Pin Spacing The number of grid units between each
pin in the array.

Shape The shape of the pins in the array, as described in
Place Pin dialog box on page 204.

Type The type of the pins in the array, as described in
Place Pin dialog box on page 204.

Pins Visible This Options is available only for power
pins. If this option is selected, the pins are visible when the
part is placed on the schematic page. Otherwise, the pins
are not visible on the schematic page.
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About power and ground pins

Both homogeneous and heterogeneous parts may have
shared pins. A common use of shared pins is for supply
pins (power or ground), which are referred to in Capture
as power pins. Normally, power pins are invisible and
global (meaning that they are connected to like-named
power objects, power nets, and invisible power pins
throughout the design).

Merely displaying an invisible power pin does not change
its global nature; however, connecting a wire or other
electrical object to a power pin isolates it from the
design-wide (global) net. For information on displaying
invisible power pins, see Displaying invisible power pins on
page 212.

On heterogeneous parts, power pins usually do not
appear on every part in the package. If you make the
power pins visible, you must place them on at least one
part in the package, then place that part in the design and
connect wires to those pins in order for the power
connections to appear in a netlist.

On homogeneous parts, power pins appear on every part
in the package. The pin names are filled in automatically,
but you must specify the pin numbers. To share the pins,

make sure that the pin names and the numbers are the
same for every part in the package.

Caution If you connect the same pin on
multiple parts in a package, you can
inadvertently short two nefs. Use care to
avoid this, and always run Design Rules
Check before creating a netlist.
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Zero length power pins will only display
their names and numbers. There won't be
an obvious point of connection. If you want
to wire to a new zero length power pin, be
sure snap-to-grid is turned on, and draw
the wire to the edge of the border in the
middle of the pin name.

If you connect to an invisible power pin that
is displayed by this method, the pin is
isolated from the design-wide power net.
Otherwise, the power pins are global even
though Capture displays them.

Note You cannot connect fo an invisible
power pin that is displayed by this method.

Note Power Pin Visible is one of the
properties of your parts that can be turned
on or off from inside the property editor.
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Displaying invisible power pins

You can display power pins on individual part instances
or throughout a design. Merely displaying invisible
power pins on the schematic page does not change their
global nature. The method you choose to display power
pins determines whether you can connect to them.
Invisible power pins are always displayed in the part
editor.

To display invisible power pins on a part instance

1 In the part editor, select a power pin.

2  From the Edit menu, choose Properties. The Pin
Properties dialog box appears.

Select the Pin Visible option.
Click OK.

To display invisible power pins throughout a design

1 From the project manager’s Options menu, choose
Design Properties, then choose the Miscellaneous tab.

2 Select the Display Invisible Power Pins (for
documentation purposes only) option, then click OK.
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Editing an existing part

You can edit an existing part in the library in which it
resides, or you can edit a part after it is placed on a
schematic page.

Editing a part in a library

Once you edit a part in a library, you can update existing
projects with the new part using the Update Cache or
Replace Cache commands on the project manager’s
Design menu.

To edit a part in a library

1

From the File menu, choose Open. A standard Open
dialog box appears.

Choose the library containing the part you want to
edit. The library opens, showing all its parts.

Double-click on the part you want to edit. The selected
part appears in the part editor.

Edit the part.

You can resize it, add or delete graphics or symbols,
and add or delete pins. These processes are all
described in Creating a new part earlier in this chapter.
You can also edit the part’s properties. Editing
properties is described in Chapter 2, The Capture work
environment.

When you are done editing the part, you must save it.
From the File menu, choose Save. The part is saved in
the library.

Tip In the project manager, you can
create a new part from an existing part by
dragging a copy of the part (press the

key while you drag the part) to a new
library and then editing the part.

You can also create an alias of the part by
changing to package view in the part
editor, choosing Package Properties from
the Options menu, then choosing the Part
Alias button. Once you create a part alias,
you must save the part fo have the alias
show up in the library. In the library, part
aliases display with lines through their part
icons.
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Editing a part on a schematic page

Once you edit a part on a schematic page, you can apply
the edits to all instances of the same part in the project, or
you can apply the edits only to the particular part instance
you edit.

Caution Once you edit a part instance on a schematic page, it is no longer

linked to its corresponding library part. In addition, a new part
(with_n appended to the original part name) appears in the design
cache. This means that you can’t perform an Update Cache on an
edited part, since there is no link to the original library.

To edit a part instance on a schematic page

1
2

Select a part instance on a schematic page.
From the Edit menu, choose Part.

The library part that was used to define the part
instance appears in the part editor.

Edit the part.

You can resize it, add graphics or symbols, and add or
delete pins. These processes are all described in
Creating a new part earlier in this chapter. You can also
edit the part’s properties. Editing properties is
described in Chapter 2, The Capture work environment.

When you are done editing the part, you must close it
and save the changes on the schematic page. From the
File menu, choose Close.

A dialog box appears asking if you would like to:

¢ Update only the part instance being edited
(Update Current).

e Update all instances of the part in the project
(Update All).

¢ Discard the edits to the part and return to the
schematic page editor (Discard).

e Cancel the close operation and return to the part
editor to continue making changes to the part
(Cancel).
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After you choose a response, the part editor window
closes. Depending on your response, the change is
reflected in the selected part or in all instances of the
selected part.

A new part (with _n appended to the part name)
appears in the design cache, indicating that the link to
the library part no longer exists.

To display invisible power pins on a part instance

1
2

3
4

In the part editor, select a power pin. For information on adding properties to
) ) _ part instances, see Chapter 2, The Capture
From the Edit menu, choose Properties. The Pin work environment.

Properties dialog box appears.
Select the Pin Visible option.
Click OK.

Displaying power pins in this manner breaks their global
nature. In order for these pins to be included in a netlist,
you must wire them into the circuit.
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Tip When editing a multi-part package, a
quick way to move from one part in a
package to another is to use the Next Part
and Previous Part commands on the View
menu.
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Viewing parts in a package

For a package containing multiple parts, you can use the
Package command on the View menu to view all the parts
in the package at once. You can then choose which part in
the package to edit. If the package is homogeneous, you
can only edit pin names and pin numbers, since each part
in a package must have the same graphic representation.
If the package is heterogeneous, you can make each part
in the package graphically distinct.

To view a package

1 From the part editor’s View menu, choose Package.
The package view window (shown below) replaces
the part editor window.
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Figure 64 Part editor in Package View

2 You can move from part to part using the arrow and
keys. The current selection is indicated by a
thicker black line.

Double-clicking on any of the parts in the package
closes the package view window and opens the partin
the part editor window.
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Editing parts in a package

For a package containing multiple parts, you can use the
Package Properties spreadsheet to edit all the pins in a
given package in the package at once. If the package is
homogeneous, you can only edit pin names and pin
numbers, since each part in a package must have the same
graphic representation. If the package is heterogeneous,
you can make each part in the package graphically
distinct. When a normal and convert part are both
available, the normal and convert names and types will
appear on the spreadsheet.

To edit parts in a package

1 From the part editor’s View menu, choose Package.
The package view window replaces the part editor
window.

2 From the Edit menu, choose Properties. The Package
Properties spreadsheet appears.

3 Edit the pin location, pin order, pin group (for pin
swapping), pin number, pin name, pin type, and
whether the pin is to be ignored (for shared pins) as
needed.

4 After editing pin numbers and names, click the
Validate button to assure each pin is unique.

5 Click OK.
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Note Ifyou're editing a part that doesn’t
have a convert view, the Convert command
is not available.

Note In the package properties
spreadsheet, both normal and convert
views of a part are displayed when a
convert view exisfs.
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Viewing a part’s convert

A convert view is an alternate view of a part. It can be used
for things such as a DeMorgan equivalent of a part. If a
part has a convert view, you can easily switch between the
normal view and convert view in the part editor.

To view a part’s convert

1 From the part editor’s View menu, choose Convert.

2 To go back to the normal view of the part, choose
Normal from the View menu.



Processing your design

Chapter 13, About the processing tools, provides general
guidelines for processing your design and describes when
to use Capture’s different processing tools.

Chapter 14, Preparing to create a netlist, describes the tools
you use to prepare a design for creating a netlist. It
describes the Annotate, Update Properties, Design Rules
Check, and Back Annotate tools.

Chapter 15, Creating a netlist, explains how to create a
netlist using the Create netlist tool.

Chapter 16, Creating reports, explains how to create reports
using the Bill of Materials and Cross Reference tools.

Chapter 17, Exporting and importing schematic data,
describes the Export Properties and Import Properties
tools used to move data into and out of Capture.

Chapter 18, Using Capture with OrCAD Layout, explains
how to perform forward annotation, back annotation, and
cross probing using Capture and Layout.



Chapter 19, Using Capture with OrCAD PSpice, describes
intertool communication between Capture and PSpice,
and explains how to use this feature to debug your
Capture schematic interactively.



About the processing tools

A design process typically involves placing and
connecting parts in the schematic page editor, then using
Capture’s tools to specify how parts are to be packaged
and uniquely identified. You add information for
simulation, synthesis, board layout, purchasing, or other
external functions, then create a netlist and incorporate
back annotation information from external applications.

As shown in the figure at right, you use Annotate, Design
Rules Check, and Cross Reference to package the parts in
your project and to check that there are no invalid
conditions. In practice, you might run these tools several
times before moving on to the next phase.

You can add properties to parts or pins, or change their
values (see The property editor on page 33). If you prefer
editing in a full-featured spreadsheet or database
program, use Export Properties to write data out and
Import Properties to read it back in.

Design
Rules Check

Y Design
capture

Annotate

Cross

Reference

¥

Propetties
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or database

Import
Propetties

Update Export
Properties P"’Pe’“‘
editor
h
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Note You won't be able fo use any of
these tools to modify a schematic design
attached to a hierarchical block if the

design is external to the current project.
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Use Create Netlist to convey project information to
Layout, PSpice, or Express Simulate. Layout can create a
back annotation file detailing packaging changes that are
needed because of routing or manufacturing constraints.
Use Back Annotate to incorporate this information into
your Capture project. Use Bill of Materials to create a list
of the parts.

After you do this, you may need to make additional
changes to your project, then repeat some or all phases of
the design process. In addition, you may want to analyze
your project using intertool communication to
communicate interactively with Layout for cross probing,
with Express Simulate to view signals in Capture as their
states change during simulation, or PSpice to view wave
forms.

Tools overview

After you finish placing and connecting parts in the
schematic page editor, use the project manager’s Tools
menu commands to help you complete the design process.



Tools overview

Table 8 Capture tools overview

Command Overview Described in
Annotate Packages parts by resolving part references  Chapter 14,
and pin numbers, or removes packaging Preparing to
information by resetting part references to  create a netlist
their unassigned values.
Back Swaps pins or gates, or changes packaging, ~ Chapter 14,
Annotate based on a swap file created by you or your  Preparing to
board layout program. create a netlist
Update Adds properties, or changes the values of Chapter 14,
Properties properties, based on an update file you Preparing to
create. create a netlist
Design Reports and flags violations of electrical Chapter 14,
Rules rules and other design constraints. Startsby ~ Preparing to
Check removing existing DRC markers. create a netlist
Create Creates a file that lists the logical Chapter 15,
Netlist interconnections between signals and pins  Creating a
in one of more than thirty standard formats. netlist
Cross Reports the schematic page and location of ~ Chapter 16,
Reference parts (used in developing or documentinga  Creating
project). reports
Bill of Creates a formatted list of electrical and Chapter 16,
Materials other parts in the project. Optionally adds Creating
information, based on an include file you reports
create.
Export Creates a tab-delimited list—for Chapter 17,
Properties manipulation in a spreadsheet or database ~ Exporting and
program—of properties and values foreach  importing
part in the project. schematic data
Import Adds properties, or changes the values of Chapter 17,
Properties properties, based on a tab-delimited listin =~ Exporting and
the format created by the Export Properties  importing

command.

schematic data
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Updating instances and occurrences

Several of Capture’s tools give you the choice of updating
instances or occurrences. The type of property you update
depends on the type of project in which you are working.
If you are working with an FPGA project, or a PSpice
project, then choose to update instances with the
Annotate, Update Properties, and Export Properties tools.
Back Annotate also updates occurrence properties.
Capture automatically selects the preferred updating
choice in each of the dialog boxes for Annotate, Update
Properties, and Export Properties.

Table 9  Updating instances or occurrences

Project type Update instances Update occurrences
PCB No Yes
Schematic No Yes
FPGA Yes No
PSpice Yes No

If you are working within a PCB or Schematic project, then
choose to update occurrences when you use the Annotate,
Update Properties, and Export Property tools.

The EDIF 2 0 0, VHDL, and Verilog netlist formats
generate true hierarchical netlists. When a design is
netlisted with one of these formats, the instance property
values on nets and parts are used. All other netlist formats
in Capture produce flat netlists, and use occurrence
property values.

The instance property value shines through to the
occurrences as long as the occurrence property values
have not been edited in any way. When you explicitly edit
an occurrence property value, or Capture modifies it via
one of the tools, the instance value is overridden by the
occurrence value. Only the occurrence value will be
placed in the netlist.
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Annotating

After you place parts on a schematic page, all parts need
to be uniquely identified using the Annotate command on
the project manager’s Tools menu. This tool assigns
unique part references to each part in a project. You use
Annotate after you've placed all parts and before you use
other Capture tools. You can annotate incrementally (so
that previously assigned part references are not changed),
or you can annotate unconditionally, changing all the
parts across all the schematic pages processed. Using the
Annotate tool, intersheet references can be added to
off-page connectors and hierarchical ports. Intersheet
references indicate the source and destination of
schematic page and schematic symbols in your design.

Caution After you have created a netlist and read it into Layout, if you
make further changes to your Capture design, only use the
Incremental reference update option in the Annotate dialog box
when you annotate. Do not use the Unconditional reference update
option.

14

Note Annotate also assigns individval
parts to a multiple-part package, thereby
assigning unique pin numbers to each part
in a multiple-part package. This process is
sometimes called packaging. For more
information on controlling packaging in
multiple-part packages, see Capture’s
online help.
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Note Parts must be set to primitive in
order for Capture to annotate them. You
can set the primitivity of parts individually,
or globally in the Hierarchy tab of the
Design Properties dialog box. Choose
Design Properties from the Options menu
to display this dialog box.
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Parts are updated in the order in which they appear on a
schematic page, going from left to right and top to bottom,
as shown in Figure 65 and Figure 66.

To annotate

In the project manager, select the schematic pages on
which to annotate.

From the project manager’s Tools menu, choose
Annotate. :

or

Choose the annotate tool from the toolbar.

The Annotate dialog box displays.

Set the options in this dialog box as necessary. You can
specify whether to update the entire project or just the
schematic pages selected in the project manager,
whether to update the part references that haven’t yet
been updated, update all part references, or reset part
references so that they have question marks in their
names. These options are described in the section
Annotate dialog box.

When the Annotate dialog box has the settings you
want, click OK to begin the update.



Annotating

Annotate dialog box

Figure 67 Annotate dialog box

Scope Specifies whether to update all the part
references in the design or just those on the selected
schematic pages.
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Caution This can result in duplicate
reference numbers if the highest numbered
part for each reference prefix is not
represented in the schematic pages you
have selected. If you suspect you have
duplicate reference numbers, run Design
Rules Check before you attempt o create a
netlist.

Tip The properties that contain the page
number (Page Number and Page Count)
are part of the fitle block. If you create
custom fitle block, you can give it these two
properties, so that they are updated when
you run Annotate.
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Action Specifies the action to be taken on reference
designators or intersheet references in the selected
schematic pages. Designs can be annotated
unconditionally (affecting currently annotated parts),
annotated incrementally (affecting only unannotated
parts), or have all annotations reset. Intersheet references
can either be added to or removed. Only one action can be
specified at a time.

Mode Specifies whether to update the instance
properties of the parts or nets, or occurrence properties of
the parts or nets. The preferred mode is set automatically
by Capture, and depends on the type of project you are
using.

Physical Packaging Specifies the properties that must
match for Capture to group parts in a single package. See
Capture’s online help for information on how the
Annotate tool packages individual parts into
multiple-part packages, as well as information about
combined property strings.

Reset reference numbers to begin at 1 in each
schematic If this option is selected, Capture numbers
part references beginning with 1 in each schematic folder.
If you don’t instruct Capture to begin the reference
numbers at 1, it looks at the selected schematic pages,
finds the highest part reference number, and begins
numbering from that number.

Do not change the page number The schematic
pages are renumbered during annotation, based on their
order in the project manager. If you select this option, the
pages are not renumbered.
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Updating properties

If you need to edit the properties for a few parts or nets,
you can do so in the schematic page editor. If, however,
you want to make the same changes to a number of parts
or nets, in a number of different designs, the Update
Properties tool is much quicker and easier than
hand-editing each property you’d like to change. You can
use Update Properties to edit any properties except part
reference, net name, and net ID.

You can also use Update Properties to add properties. In
essence, it is a search-and-add-or-replace tool.

To update properties, you create a file, called an update file,
with one line for each part or net to change. The leftmost
column identifies the part or net (by specifying the
property value to match), and the remaining columns
provide the new property value. The format of the update
file is described in Update file format on page 232.

To update part or net properties

1 Using a text editor, create an update file, as described
in Update file format on page 232.

2 To process only part of your design, select the pages to
process in the project manager.

3 From the project manager’s Tools menu, choose
Update Properties.

The Update Properties dialog box displays.

4 Setthe optionsin this dialog box as necessary. You can
specify whether to process the entire project or just the
schematic pages selected in the project manager, and
whether to update parts or nets. You can customize
your update further by specifying that your
comparison and update strings be converted to
uppercase. You can also have Capture create a report
file listing the properties that it changes. You must
specify the name of the update file containing the
properties to match and the text to place in the
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specified properties. These options and others are
described in the section Update Properties dialog box.

5 Click the Browse button to the right of the Property
Update File text box to locate your update file.

6 When the dialog box has the settings you want, click
OK. Capture updates the properties you specified. If
you set up the dialog box to create a report file, you
can use a text editor to view the file when the Update
Properties tool is done.
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Update Properties dialog box

Update Properties

-\program files\orcad\capture\designsifulladd\fulladd. |

Figure 68 Uipdate Properties dialog box

Scope Specifies whether to process the project or what is
selected.

Mode Specifies whether to update the instance
properties of the parts or nets, or occurrence properties of
the parts or nets. The preferred mode is set automatically
by Capture, and depends on the type of project you are
using.

Update parts or Update nets Specifies whether to
update the properties of parts or nets.

Use case insensitive compares Matches the
combined property string with update properties without
regards to case sensitivity.
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Convert the update property to uppercase
Converts the update property to uppercase before it is
placed in an object’s property.

Unconditionally update the property By default, a
property is updated only if it is empty: properties with
values are not updated. If this option is selected, the
specified property is changed, regardless of whether it’s
empty. '

Do not change updated properties visibility
Specifies that the visibility of the updated properties is not
changed.

Make the updated property visible /invisible
Specifies that the updated property is to be made visible
or invisible. Instance properties can be changed, but the
visibility of occurrence properties cannot be changed.

Create a report file Specifies whether or not Capture
creates a report file. If you select this option, enter the
name of the report file in the Report File text box.

Report File Specifies a report filename and path, if the
Create a report file option is selected.

Property Update File The name of the update file
containing the properties to match, the properties to
update, and the values to use to update the properties.
Update Part Properties looks for a file with an extension of
.UPD, but any file extension can be specified.
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Update file format

The update file is an ASCII text file that you create to
specify the properties to match, the properties to update,
and the values to use to update the properties. The file can
include comments—any text to the right of a semicolon is
ignored by the Update Properties tool.

The first line of the update file has this format:

CombinedPropString PropToUpdatel PropToUpdate? ...

The first field is a combined property string specifying Note For information about combined
which properties to combine into a match string (note that property strings, see Capture’s online help.
property names in a property string must be enclosed in

braces). The remaining fields in the line are the properties

to update on each part or net to be updated. The combined

property string and the property names entered in these

fields must be enclosed in quotation marks.

Subsequent lines of the update file have this format:

MatchStringl Updatel Update2 .
MatchString2 Updatel Updatez ...

The match string is the text used to compare with the
values of the properties specified by the combined
property string in the first line. The update fields are the
values placed in the properties specified in the first line, if
the match string matches the expanded combined
property string. These values must also be enclosed in
quotation marks. For example:

"{Value}" "PCB Footprint"
"741500" "14DIP300"
"741.5138" "16DIP300"
"7415163" "16DIP300"
"8259A" "28D1P600"

This indicates that the property to use as a match string is
Value. Each time an object’s Value matches the value
listed in the left column of the update file, the
corresponding text in the right column is placed in the
object’s PCB Footprint property. In this example, each
time a part has a value of 74LS00, the text 14DIP300 is
placed in the part’s PCB Footprint property; each time a
part has a Value of 74L.5138, 16DIP300 is placed in the
part’s PCB Footprint property, and so on. You can also use
Import Properties and Export Properties on the Tools
menu, or use Capture CIS, to make changes.
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Caution You should ALWAYS run Design
Rules Check before you create a netlist.

Note When Design Rules Check checks for
unconnected nets, it looks for nets with less
than two connection points. Thus, a net can
still have unconnected endpoints (dangling

endpoints) that aren't reported by Design
Rules Check.
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Checking for design rules
violations

The Design Rules Check tool scans schematic designs and
checks for conformance to basic design and electrical
rules. The results of this check are marked on the
schematic pages with DRC markers, and are also listed in
a report. This makes it easy to locate and fix design or
electrical errors. You can search for DRC markers using
the Browse command on the project manager’s Edit
menu, and then double-click on any item in the resulting
list to go immediately to the location of the marker on
your schematic page. Once you are viewing the marker on
the schematic page, you can display the marker’s text by
double-clicking on it.

You can specify the conditions that cause errors to be
generated. Optional checks performed by the Design
Rules Check tool include off-grid parts; unconnected nets,
pins, ports, and off-page connectors; identical part
references; type mismatch parts; and design elements that
are not compatible with OrCAD’s Schematic Design Tools
(SDT 386+) product.

The Design Rules Check is helpful in preparing your
project for use with other tools. For example, you can use
the Design Rules Check tool to catch problems such as bus
contention or shorted power pins before you generate a

netlist to be used by simulation or synthesis tools.

The Design Rules Check reports two categories of
electrical rules violations:

e Errors that should be fixed.

e Warnings of situations that may or may not be
acceptable in your project.
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You can control whether electrical rules violations are
reported as errors or warnings in the ERC Matrix tab of
the Design Rules Check dialog box. Errors are always
marked with DRC markers on the schematic page.
Warnings are also marked with DRC markers if you select
the Create DRC markers for warnings option in the
Design Rules Check dialog box. In the report generated by
Design Rules Check, however, the problems are
categorized as WARNING or ERROR so that you can
immediately identify the more critical problems.

Once the Design Rules Check begins, it first removes
existing DRC markers from the schematic pages being
processed. This means that each time you run this process,
the error markers on your schematic pages reflect the
current state of your project. You can also use the Design
Rules Check tool to remove DRC markers from schematic
pages, but not do any further checking. Just select the
Delete existing DRC markers option on the Design Rules
Check dialog box.

To check for design rules violations

1 Inthe project manager, select the schematic pages that
you want to check for design rules violations.

2 From the project manager’s Tools menu, choose
Design Rules Check.
or
Choose the design rules check tool from the toolbar.

The Design Rules Check dialog box appears.

3 Select the settings you want in the Design Rules Check
tab and in the ERC Matrix tab. For information about
the settings in these tabs, see Design Rules Check dialog
box, Design Rules Check tab on page 237 and Design
Rules Check dialog box, ERC Matrix tab on page 240.

4 When both tabs of the Design Rules Check dialog box
have the settings you want, click OK.
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Tip To view the information contained in a
DRC report with an external text editor or
word processor, set up a file association
using the Open With dialog box in Windows
Explorer. By doing this, you can open the
DRC report by double-clicking on it in
Windows Explorer.
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As Capture checks your project, it displays status
information about the check. If you stop the design
rules check midstream (by choosing the Cancel button
in the status information dialog box), the schematic
pages thathave already been processed will have DRC
markers marking any error situations that were
encountered.

Once the design rules check is complete, there are
three ways to view the results:

You can double-click on the file in the project
manager to bring it up in the text editor.

You can open the DRC report file by using a text
editor or word processor. This file has a default
extension of .DRC. The session log also contains
the same information.

You can use the Browse command on the project
manager’s Edit menu to display a list of all DRC
markers in the project.

This list gives information about each error and
warning. Each DRC marker on a schematic page
displays this same information. Once this list
displays in the browse window, you can
double-click on an item to go directly to it on its
schematic page. Once you are viewing the marker
on the schematic page, you can display the
marker’s text by double-clicking on it. You can
also use the schematic page editor’s Find
command to find specific DRC markers. To do
this, you must enter the text associated with the
marker.
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De:ign Rules Check dialog box, Design Rules Check
ta

The Design Rules Check tab contains options for things to
include in the report generated by Design Rules Check.
You can specify if you want to create DRC markers on the
selected schematic pages for both errors and warnings,
create DRC markers just for errors, or delete existing DRC
markers instead of adding new ones. Note that if you
select the option to delete existing DRC markers, the
options that customize the DRC report become dimmed
and aren’t available for selection.

Design Rules Check

\PROGRAM FILES\ORCAD\CAPTUREADESIGNS\FU

Figure 69 Design Rules Check tab of the Design Rules Check
dialog box

Scope Specifies whether to process the entire project or
just the selected schematic page or pages.
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Action Specifies whether to check for design rules
violations or just delete existing DRC markers. Note that
if you select the Check design rules option, Capture
deletes existing DRC markers before it begins the design
rules check.

Report All the remaining options on the dialog box are
report options, and leave messages and reports in the
session log. Selected report options are also included in
the specified report file.

Create DRC markers for warnings Design Rules
Check always places DRC markers on the schematic page
for errors defined in the ERC Matrix tab. If you select this
option, it also places DRC symbols on the schematic page
for warnings defined in the ERC Matrix tab.

Check hierarchical port connections Verifies that
hierarchical pins on schematic pages in the parent
schematic folder match hierarchical ports on schematic
pages in the child schematic folder. Errors are generated if
a hierarchical pin specified on a schematic page in a parent
schematic folder doesn’t have a corresponding
hierarchical port with an identical name on a schematic page
in the child schematic folder; if the number of hierarchical
pins and hierarchical ports are different between the
parent and child schematic folders; and if the type of the
hierarchical pins and hierarchical ports doesn’t match.

Check off-page connector connections Verifies that
off-page connector names on a schematic page match
those on other schematic pages.

Check unconnected nets Checks for these conditions:
nets that aren’t connected to at least two pins or
hierarchical ports; nets that don’t have a driving signal;
and two nets with the same name in a schematic folder,
but no off-page connector or hierarchical port to connect
them.
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Check SDT compatibility Checks for compatibility
with OrCAD’s SDT product in case you plan on saving the
project in SDT format. See Capture’s online help for
information about the rules you should follow if you are
planning to use a Capture project in SDT.

Report identical part references Checks for unique
part references, and reports parts that use the same part
reference. For example, Capture considers two Ul’s to be
identical, two U1A’s to be identical, and U1 and U1A to be
identical.

Report invalid packaging Reports parts that are
packaged into the same physical package, but whose
package properties conflict (primarily source package and
PCB footprint).

Report hierarchical ports and off-page
connectors In the report file, lists all hierarchical ports
and off-page connectors.

Report off-grid objects In the report file, lists the

names and locations of objects that are off grid.

Report all net numes In the report file, lists the Tip Report all net names can be used to
names of all nets. If a net is attached to another net of a locate nets that have been inadvertently

different name, then this option will report the alternative  shorted to other nes.
net name as well.

Report File The name of the report file containing the
information prepared by Design Rules Check. This file
usually has an extension of .DRC. For an example of the
report generated by the Design Rules Check tool, see
Sample Design Rules Check report on page 241.

View Output Specifies to view the result of the DRC
check in a text editor.
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Design Rules Check dialog box, ERC Matrix tab

Figure 70 ERC tab of the Design Rules Check dialog box

Tio You can also type W for warning, E You use the ERC matrix to set the electrical rules that

for error and N for an empty intersection. Design Rules Check uses when testing connections

In addition, you can use the arrow keys to between pins, hierarchical ports, and off-page connectors.

select other infersections. All types of pins, hierarchical ports, and off-page
connectors are listed in the columns and rows in the table.
A test is represented by the intersection of a row and
column. Either the intersection is empty, or it contains a
W, or it contains an E.

e An empty intersection represents a valid connection,
in which case nothing is reported if you specify a
report file.

e A W represents a warning.

e AnE represents an error.
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You can cycle through these settings by pointing to an DRC errors and warnings are explained in
intersection and clicking the mouse button until the greater detail in Capture’s online help.
desired setting appears. For all rows except the Search for Error messages.

Unconnected row, the DRC reports an error or warning
for any net that has two connections as specified in the
ERC matrix. For example, consider the dialog box above.
If a net has an output pin and a bidirectional pin, a
warning is issued based on the W in the intersection of the
Output row and the Bidirectional column. For the
Unconnected row, the DRC checks to see if the specified
pin or port type is unconnected.

Sample Design Rules Check report

* * * *AK * % * * * Kk

*

* Design Rules Check
*

* k% * Kk kkkkokkk kkhkkhkkhkkkhkkhkhkhkhkhkkhhkhkkkk

Checking for Invalid Pins in Package

ERROR [DRC00311] Same Pin Number connected to more than
one net. halfadd_B/U1C/9 Nets: 'N00035_178' and 'N00035'. :
EX6B, EX6B.SCH (5.20, 2.50)

ERROR [DRC00311] Same Pin Number connected to more than
one net. halfadd_B/U1C/10 Nets: 'N00037_179' and 'NO0037'.
EX6B, EX6B.SCH (5.20, 2.70)

ERROR [DRC0O031] Same Pin Number connected to more than
one net. halfadd_B/U1C/8 Nets: 'N0O0013' and 'SUM'. : EX6B,
EX6B.SCH (6.40, 2.60)

ERROR [DRC0O031] Same Pin Number connected to more than
one net. halfadd_B/U2D/9 Nets: 'Y' and 'NO0O013'. : EX6B,
EX6B.SCH (4.00, 3.10)

ERROR [DRC00311] Same Pin Number connected to more than
one net. halfadd_B/U2D/8 Nets: 'N5056796111_183"' and

'N5056796111". : EX6B, EX6B.SCH (4.00, 2.10)
ERROR [DRC0O031] Same Pin Number connected to more than
one net. halfadd_B/U2C/5 Nets: 'X' and 'CARRY_IN'. : EX6B,

EX6B.SCH (3.50, 1.90)

ERROR [DRC0031] Same Pin Number connected to more than
one net. halfadd_B/U2C/6 Nets: 'X_BAR_177' and 'X_BAR'.
EX6B, EX6B.SCH (3.50, 2.90)

ERROR [DRC0031] Same Pin Number connected to more than
one net. halfadd_B/U3D/12 Nets: 'X' and 'CARRY_IN'.
EX6B, EX6B.SCH (4.00, 1.90)
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ERROR [DRC0O031] Same Pin Number connected to more than
one net. halfadd_B/U3D/13 Nets: 'N5056796111_183" and
'N5056796111"'. : EX6B, EX6B.SCH (4.00, 2.10)

ERROR [DRC00311] Same Pin Number connected to more than
one net. halfadd_B/U3D/11 Nets: 'N00035_178' and 'N00035"'.
EX6B, EX6B.SCH (5.20, 2.00)

ERROR [DRC0O0311] Same Pin Number connected to more than
one net. halfadd_B/U4B/4 Nets: 'Y' and 'N0O0O13'. : EX6B,
EX6B.SCH (5.20, 3.80)

ERROR [DRC00311] Same Pin Number connected to more than
one net. halfadd_B/U4B/5 Nets: 'X' and 'CARRY_IN'. : EX6B,
EX6B.SCH (5.20, 4.00)

ERROR [DRC00311] Same Pin Number connected to more than
one net. halfadd_B/U4B/6 Nets: 'N00025' and 'NO0015'.
EX6B, EX6B.SCH (6.40, 3.90)

ERROR [DRC00311] Same Pin Number connected to more than
one net. halfadd_B/U4A/1 Nets: 'Y' and 'NO0013'. : EX6B,
EX6B.SCH (4.00, 3.10)

ERROR [DRC0031] Same Pin Number connected to more than
one net. halfadd_B/U4A/2 Nets: 'X_BAR_177' and 'X_BAR'. :
EX6B, EX6B.SCH (4.00, 3.30)

ERROR [DRC00311] Same Pin Number connected to more than
one net. halfadd_B/U4A/3 Nets: 'NO0037_179' and 'N0O037'. :
EX6B, EX6B.SCH (5.20, 3.20)

Checking Electrical Rules
Checking for Invalid References

Checking for Duplicate References

Checking Electrical Rules
Checking for Invalid References
Checking for Duplicate References

[DRCO010] Duplicate reference halfadd_B/U2C: EX6B,
EX6B.SCH (3.30, 2.20)

[DRCO0O10] Duplicate reference halfadd_B/U2D: EX6B,
EX6B.SCH (3.80, 2.40)

[DRCO0O10] Duplicate reference halfadd_B/U3D: EX6B,
EX6B.SCH (4.30, 1.80)

[DRCO0101 Duplicate reference halfadd_B/U4A: EX6B,
EX6B.SCH (4.30, 3.00)



Checking for design rules violations

[DRCO010]  Duplicate reference halfadd_B/U4B:

EX6B.SCH (5.50, 3.70)

[DRCO010]  Duplicate reference halfadd_B/U1C:

EX6B.SCH (5.50, 2.40)

Checking Electrical Rules
Checking for Invalid References

Checking for Duplicate References
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Note The Back Annotate tool passes
through all the parts, pins, and nets of the
design once. As each is encountered, a
search is made in the swap file for a match.
When a match is found, the part, pin, or net
property is updated.
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Back annotating

Using Back Annotate, you can import changes created by
external tools, such as a PCB layout application. Capture
uses a simple file format (see Swap file format on page 246)
to allow gate swapping, pin swapping, changing pins, and
changing part references. If the external tool creates a back
annotation file, edit the file to match the format described
in Swap file format in this section. Back Annotate only
updates occurrence property values.

When should you use Back Annotate? After you've
completed your schematic design, or while you are
routing a printed circuit board, you might discover that
you can reduce via count, track length, or routing
complexity by exchanging two gates of one part. You
would use the PCB layout tool to rewire the board to
exchange (or swap) the connections of ULA and U1B. To
ensure that your project reflects the rewired board, you
create a swap file using the PCB layout tool and then run
Capture’s Back Annotate. When you look at the schematic
page, you will see that U1A is where U1B was before, and
vice versa.

To back annotate

1 Generally, a swap (or back annotation) file is created
by another application such as OrCAD Layout.
Alternatively, you can create a back annotation file
using a text editor, following the format described in
Swap file format later in this section.

2 To process only part of your project, select the pages to
process in the project manager.

3 From the project manager’s Tools menu, choose Back
Annotate.
or
Choose the Back Annotate tool from the toolbar.

The Back Annotate dialog box appears.



Back annotating

4 Setthe optionsin this dialog box as necessary. You can
specify whether to process the entire project or just the
selected schematic pages. You can also specify the
name of the swap file containing the gates and pins to
swap. These options are described in the section Back
Annotate dialog box.

5 Use the Browse button to locate the current back
annotation file. The Browse dialog box looks for a file
with an extension of .SWP, but any file extension can
be specified.

6 When the dialog box has the settings you want, click
OK. Capture swaps the gates and pins you specified.

Back Annotate dialog box

t Back Annotate

C:APROGRAM FILES\ORCADACAPTUREN

Figure 71 Back Annotate dialog box

Scope Specifies whether to process the entire project or
just the selected schematic page or pages.

Back Annotation File Specifies the swap file. For
more information, see Swap file format.
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Note 0rCAD Layout creates a combined
swap and update file. See Capture’s online
help for more information on creating a
combined swap and update file.

Note Swap files created by OrCAD’s PCB
386+ are was/is files. These files contain
no keyword identifiers; therefore, each line
is assumed to be a CHANGEREF instruction.
In the swap file example above, the line
without a keyword identifier (the second
line) is an example of how changes are
specified in a was/fs file generated by PCB
386+.
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A swap file is an ASCII text file containing old and new
part references. A swap file is typically created by another
application, such as OrCAD Layout. You can also create a
swap (.SWP) file using a text editor that can save the file in
ASCII format. The file can include comments; any text to
the right of a semicolon is ignored by the Back Annotate
tool. Each line in a swap file, unless preceded by a
semicolon, causes one action. The elements of each line
may be separated with any number of space or tab
characters. In general, the first element of the line specifies
the type of swap. If no swap type is specified,
CHANGEREF is assumed. The other swap types are
GATESWAP, PINSWAP, and CHANGEPIN.

The following example illustrates a swap file. The
comments to the right of the semicolons describe what the
swap file will do.

CHANGEREF Ul Uz ;Change part reference Ul to U2

Ulc uzC ;Change part renerence U1C to U2C
GATESWAP ur u2 ;Swap parts Ul and U2
GATESWAP UlA U1B ;Swap gates UA and U1B
CHANEGPIN U7 1 2 ;Change pin 1 to pin 2
CHANGEPIN u7 2 1 ;Change pin 2 to pin 1
CHANGEPIN ~ U5B “DO” “D1” ;Change pin named DO to D1
CHANGEPIN UsB “D1”  “D0” ;Change pin named D1 to Do

Note that there are two CHANGEPIN commands for each
pin swap. If you entered just one line to change pins, for
example:

CHANGEPIN U7 1 2

The original pin 1 is changed to pin 2; however, if you
already have a pin 2, you will end up with two of them,
unless you change the original pin 2 to something else. For
this reason, a second line is needed to go with the first line.
The complete command lines needed to perform a pin
swap between pins 1 and 2 are:

CHANGEPIN U7 1 2
CHANGEPIN U7 2 1
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With the exception of the PINSWAP command, the
commands in a swap file are was/is based. That is, the
commands specify what the original values were and
what the new values will be. For this reason, unlike some
board layout programs, you cannot specify intermediate
steps for the commands, except for PINSWAP.

The PINSWAP command works off the present state of
the pin. For this reason, you can perform intermediate
steps, such as:

PINSWAP Ul 1 2
PINSWAP Ul 2 3

;First swap

;Second swap

After both lines of the example above are processed, what
was pin 1 is now pin 2, what was pin 2 is now pin 3, and
what was pin 3 is now pin 1. The series of changes is
shown in the following figure.

8 ; h 12 . ? 12 = g
G | B 8 O—
3 ] F—1 /

before swap after 1st swap

For PINSWAP and CHANGEPIN, the part reference must
be specified in the swap file, as well as the old and new

values. Pin swaps are limited to pins of the same type and
shape on the same part. For example, you can swap pins

on U5B, but you cannot swap a pin on U5B with a pin on
U5C.

after 2nd swap

GGATESWAP uicC U2B ;Swap gates UlC and U2B

Caution Unlike CHANGEPIN commands,
PINSWAP commands are order-dependent
within the swap file. For this reason, if you
change the order of the PINSWAP
commands, or use both PINSWAP and
CHANGEPIN commands on the same parf,
you may get unexpected resulfs.

Back Annotate does not check fo make sure
that paris are the same type before a swap
is performed. Therefore, if you swap gafes
between dissimilar part types (as shown in
the example below), odd results may occur
in your projecf.
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Creating a netlist

After you create a project, you can create a netlist to
exchange schematic information with other EDA tools.
You can choose from more than 30 industry-recognized
netlist formats. Your choice of netlist depends on the
destination application.

Using the Create Netlist tool

Before you create a netlist, be sure your project is
complete, has been annotated (using Capture’s Annotate
command), and is free from electrical rule violations.
Chapter 14, Preparing to create a netlist describes how to use
Capture’s tools to prepare your design before you create a
netlist.

15

For information on creating a Capture
netlist for use with Layout, see Chapfer 18,
Using Capture with OrCAD Layout.
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The table below summarizes the type of netlist you will
get (flat or hierarchical), depending on the nature of your
design and the netlist format you choose.

EDIF 2 0 0, SPICE, VHDL, Allegro, Layout, PCB 386+,
Verilog, or INF netlist format | OHDL, or Other netlist format
Flat design Flat netlist Flat netlist
Simple Hierarchical netlist Flat netlist

hierarchical design

Complex Hierarchical netlist Flat netlist
hierarchical design

To create a netlist

1 In the project manager, select your design.

2 From the Tools menu, choose Create Netlist. The
Create Netlist dialog box displays.

Create Netlist

{PCE Footpri

Figure 72 Create Netlist dialog box

3 Choose a netlist format tab.
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Using the Create Netlist tool

In the Netlist File text box, enter a name for the output
file. If the selected format creates an additional file
(such as a map file or pinlist file), enter its filename in
the second text box.

If necessary, set the Part Value and PCB Footprint For information Ubo[" using comb'ined

combined property strings to reflect the information properly strings, options for individual

you want in the netlist. netlist formats, and options in the Create
Netlist dialog box, see Capture’s online

If necessary, set the format-specific options in the
Options group box, and click OK to close the Netlist
Options dialog box.

help.

Click OK to create the netlist.
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For information about the characterisfics, Ne“is" formu'l' files

formatting opfions, and an example of
each netlist format, see Capture’s online

help Capture includes over 30 netlist format file types. They

include:

Table 9  Netlist format file types

Accel Algorex Allegro
AlteraADF AppliconBRAVO AppliconLEAP
Cadnetix Calay Calay 90

Case CBDS ComputerVision
DUMP EDIF (flat) EDIF 2 0 0 (hierarchical)
PDUMP EEDESIGNER FutureNet

HiLo Intel ADF Intergraph
Layout Mentor MultiWire
OHDL PADS 2000 PADS-PCB
PCAD PCB PCADnit
PLDNet RacalRedac Scicards

SPICE Tango Telesis

Vectron Verilog VHDL

VST VST Model WireList

RINF XNF
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Netname resolution

In your schematic designs, you can assign a variety of
netnames and aliases to signals that are connected. A
netlist, however, needs exactly one name for each net.

If the Create Netlist tool encounters multiple names for a
single net, higher priority netnames override lower
priority netnames. Priority is determined by the source of
the name, ranked from highest to lowest, as follows:

e Named nets

e Hierarchical port names
e Off-page connectors

e Power object names

e Aliases

e System-generated names

If there are any conflicts at any level of the comparison (if,
for example, there are two power objects on a bus), they
are resolved according to these rules:

e Between netnames of equal precedence, priority
follows alphabetical order.

e If the netis a bus, the net alias assiened to the ereatest

154 DUS, L4dil I 5

number of bus members has hi ghgst priority.

A net may change names several times as Create Netlist Note If you have connected rwb power
works. For example, a net may start with an alias of symbols, like +5V and Ve, together with a
Battery on one page, become ToBattery from an off-page wire, the netlist will show +5V because ifs
connector, change again to become DC as a hierarchical name comes before Vec alphabetically.

port is encountered, and finally change to BatteryBackup
when Create Netlist finds a named net with higher
priority.

253



Chapter 15  Creating a neflist

254



Creating reports

Capture provides two report tools that you can use to
produce lists of the things contained in your project: Bill of
Materials and Cross Reference.

Creating a bill of materials

You can use the Bill of Materials command from the
project manager’s Tools menu to create a bill of materials
in a file which you can then print using a word processor
or text editor. The bill of materials includes the properties
item, quantity, reference, and part value. You can
customize the report to include other properties.

To create a bill of materials

1 If desired, use a text editor to create an include file, as
described in Include file format on page 259.

16

Tip Abill of materials includes parts that
don’t have pins. This makes it possible to
include non-electrical parts such as screws,
washers, and other hardware that you may
have in your project. These parts won't,
however, appear in a netlist because they
don't have pins.
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From the project manager’s Tools menu, choose Bill of
Materials. The Bill of Materials dialog box displays.

Fill in this dialog box as desired. If you want to
customize the information contained in the bill of
materials report, fill in the information in the Line
Item Definition area. If you are using an include file,
be sure to check the Merge an include file with report
check box, enter the combined property string, and
specify the name of the include file.

Click OK when you are ready to create the report.

After the bill of materials is generated, you can
double-click on its name in the Output folder in the
project manager to view it in the text editor. The best
way to view a bill of materials is to open itin a
spreadsheet program such as Microsoft Excel.



Creating a bill of materials

Bill of Materials dialog hox

| Bill of Materials

=
Item}st{Quantity R eferencel iV alue}

\PROGRAM FILES\ORCADNCAPTURENDESI

Figure 73 Bill of Materials dialog box

Scope Processes the entire design or selected schematic
pages.

Header Text placed at the top of the first page. If this
text box is left blank, there is no header on the first page.
You can use this to specify column headers to match the
data reported as defined by the combined property string.
If you want the header items separated by tabs, use the \t
character sequence in the header text box, then insert
corresponding tabs in the Combined property string text
box.
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Note If your include file uses the value
property as the match string, then you only
need { value} inthis combined

property string.

258

Combined property string Specifies which
properties are included in or excluded from the bill of
materials, and formats the output according to the tabs
you insert and the order in which you specify the
properties. When you specify the combined property
string, you enclose property names in curly braces. When
the Bill Of Materials is run, the properties in the curly
braces are substituted with property values for the part (or
left empty if the property is empty or doesn’t exist on the
part). The properties are left justified and separated by the
characters you type outside the curly brackets. To insert a
tab, use \t.

{Referencel\t{Value} prints a part’s reference, a tab
character, and the part’s value.

Place each part entry on a separate line Select
this item if you want each part to be listed on a separate
line.

Merge an include file with report Select this item if
you want to use an include file.

Combined property string Specify the property to
use to match the property value specified in quotes on
each line of the include file. This is the search string, and is
compared with match strings specified in the include file.

Report File The name of the file to contain the bill of
materials report.
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Include file format

You can use an include file to have Bill of Materials add
additional information to each line of the bill of materials.
You create an include (INC) file using any text editor that
saves files in ASCII format.

The first line of an include file is a header. The bill of
materials is always keyed to the part value, so the first line
begins with a pair of single quotes with no spaces or other
characters between them. The rest of the first line contains
any information you want to include to make the file and
the bill of materials more readable—this usually consists
of headers for the values in the rest of the file. If the
include file has combined property strings separated by
spaces, then the properties you specify in curly braces
have to be separated with spaces also.

The rest of the file contains a separate line for each part.
Each line must begin with the property value (as specified
in the Include File Combined property string in the Bill of
Materials dialog box) enclosed in single quotes. This is the
match string, and is compared with the search string
specified in the Include File combined property string in
the Bill of Materials dialog box. Following the property
value (and on the same line) is the information that you
want to add to the bill of materials. You can separate the
part value from the additional information by any number
of spaces or tab characters—Capture will align the first
nonblank character in each line when it creates the bill of
materials.

The following example illustrates an include file.

" DESCRIPTIONPART ORDER CODE

"1K" Resistor 1/4 Watt 5% 10000111003
'4.7K" Resistor 1/4 Watt 5% 10000114703
'22K! Resistor 1/4 Watt 5% 10000112204
"1uF’ Capacitor Ceramic Disk 10000211006
" 1uF’ Capacitor Ceramic Disk 10000211007

Tip You can use an include file from
0rCAD’s Schematic Design Tools (SDT
386+) without modifying it.
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In the example above, the first column contains the match
strings. If a match string matches the Include File
Combined property string for the current part, the rest of
the line (in the example above, the second and third
columns) is tacked on to the end of the line item in the bill
of materials.

To get a property formatted bill of materials using the
sample include file, enter {value} in the include file
match string and add \t to the end of the Header and Line
Item combined property string.

Creating a cross reference report

The Cross Reference tool creates a report of all parts with
their part references and part names. You may specify that
the report also give the coordinates of each part.

To create a cross reference report

1 From the project manager’s Tools menu, choose Cross
Reference. The Cross Reference Parts dialog box
displays.

2 Fill in this dialog box as desired. If you want to
customize the information contained in the cross
reference report, fill in the information in the Report
area.

3 Click OK when you are ready to create the report.
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Cross Reference Parts dialog box

Cross Reference Parts

C:APROGRAM FILESAORCADNCAPTU

Figure 74 Cross Reference Parts dialog box

Scope Specifies whether to process the entire design or
just the selected schematic page or pages.

Sorting Specifies whether to sort output by part value
or part reference.

Report the X and Y coordinates of all parts Ifyou
check this option, the report includes the X and Y
coordinates of all parts.

Report unused parts in multiple part packages 1f
you check this option, the report identifies unused parts in
multiple part packages.

Report File The name of the file to contain the cross
reference report.
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Exporting and importing
schematic data

17

Exporting and importing designs

You use the Export Design command to export a design or
library in an EDIF or a DXF format. You use the Import
Design command to import a design or library in
MicroSim Schematics, EDIF, or custom format.
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Exporting designs

You can export either designs or libraries.

To export a design or library

1 Open the project containing the design or library to
export.

2 If you are exporting a design, select the design’s
folder.
or
If you are exporting a library, select the library’s
folder.

3 From the project manager’s File menu, choose Export
Design. The Export Design dialog box displays.

Export Design B3
L -

Figure 75 Export Design dialog box
4 Choose either the EDIF or the DXF tab.
Specify a path and filename in the Save As text box.

6 If you're using the EDIF tab, locate and select a
configuration (.CFG) file.

7 Click OK. The design or library is exported to a file.
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Importing designs
You can import either designs or libraries.

1 From the project manager’s File menu, choose Import
Design. The Import Design dialog box displays.

Import Design

\Urcad\Céptufe

SWWINN T Smsim.ini

Figure 76 Import Design dialog box
Choose the PSpice, EDIF, or the Custom tab.

Locate and select the file to import in the Open text
box.

Specify a path and filename in the Save As text box.
If you're using the PSpice tab, follow these steps:

a Click the appropriate Browse button to locate
MSIM.INI file.

b Select the Translate Hierarchy option and the
Consolidate all Schematic files into one Design file
option, as appropriate.

6 If you're using the EDIF tab or the Custom tab, follow
these steps:

a Locate and select a corresponding configuration
(.CFG) file.

b If you are using the Custom tab, select the
appropriate translator.

7 Click OK. The design or library is imported into your
project.

For more information about translating
MicroSim Schematics designs and libraries,
see the book Converting MicroSim
Schematics Designs to OrCAD Capture
Designs Quick Start.

Note Use the PSpice tab for importing
MicroSim Schematics designs and libraries.
Use the custom tab for using custom
designed schematic translators.
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Tip Capture can import properties with or
without quotation marks around each field
in the property file. The fields must be
tab-delimited, though— all other
characters, including commas and spaces,
are treated as part of a field's text. Be sure
your spreadsheet or database application
can save in a tab-delimited format.

Caution Do not edit the project or library
from which the properties were exported
until after you import the changed
properties. If you do, and the Import
Properties procedure fails, you will have to
export and edit the properties again.

Tip Itisimportant that you annotate your
design before you export properties.

Note When you use the Export Properties
command, only non-aliased parts are
included in the property file, regardless of
what you've selected; however, once you
run Import Properties, the aliased parts
change to match the non-aliased parts.
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Exporting and importing
properties

You use the Export Properties and Import Properties
commands to change properties of parts and pins in a
spreadsheet application, a database application, or in a
text editor that preserves tab characters. First export the
properties to a property file, edit the property file in the
application of your choice, then import the edited
properties.

Exporting properties

You can export properties from a design or a library.

To export properties

1 Inthe project manager, open the project containing the
part properties to export.

2 If you are exporting properties from a design, select
the schematic folders or schematic pages containing
the properties to export.
or
If you are exporting properties from a library, select
the parts to export.
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3 From the project manager’s Tools menu, choose
Export Properties. The Export Properties dialog box
appears.

i Export Properties

CAPROGRAM FILESNORCADACAPTUREND

Figure 77 Export Properties dialog box

4 Specify whether the property file is to include all
documents in the file, or just the documents you
selected.

5 Specify whether you want to export properties for
parts only, or for parts and pins.

6 Specify a filename for the output file using an .EXP
extension.

7 Specify whether you want to export instance
properties or occurrence properties.

8 Click OK. The property file is created.

Property file format

When you export properties, Capture creates a
tab-delimited list of keywords, identifiers, and properties,
each of which is enclosed in double quotation marks. The
first line of a property file begins with either the keyword
DESIGN or the keyword LIBRARY, to identify the data as
being from either a design or a library. Subsequent lines of
the property file begin with one of the following
keywords: HEADER, PART, PIN, or SYMBOL.

Note Export Properties and Import
Properties use a reference designator as
match string. Therefore these tools cannot
be used to annotate your design. If you
want to swap part references, create a back
annotation file, and then use Back
Annotation.
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Caution If you add, delete, or reorder
lines in a design property file, the file
cannof be imported. If you move a PART
line in a design property file or in a library
property file, be sure to move all the PIN
lines associated with it, and keep them in
the same order; otherwise, importing the
file may fail, or the file may cause
unwanted changes to your project or
library. In every case, it is much safer fo
make changes without adding, deleting, or
reordering the lines in a property file.
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If you export both parts and pins, each PART line is
followed by a PIN line. If you export symbols, there are no
PIN lines following the SYMBOL lines, since symbols
have no pins.

The HEADER lines are compiled from a superset of the
property names found on parts (and pins, if applicable)
from the whole page, or from the whole library. This
means that if part 1 has properties named A, B, and C, part
2 has properties named D, E and F, and a pin has
properties named G, H, and I, then the HEADER line will
have (after the first two columns) nine columns titled A, B,
C,D,E F G, H,and L

Editing a property file

You can edit a property file in a spreadsheet or database
application, or in a text editor as long as it doesn’t convert
the tabs to spaces. Depending on which application you
use, the property file displays as rows and columns of
cells or fields, or as lines of text. There are a few
restrictions on the changes you can make in a property
file:

e You must not change or delete the first line.

e You must not change or delete the first two fields in
any line.

e You must not change the sequence or number of lines.

e Donotdelete a field from a HEADER line without also
deleting the corresponding fields from subsequent
lines.
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Keeping these restrictions in mind, you can generally
make the following changes:

Add a field to a HEADER line and subsequent lines

(add a column). This adds a property to parts and pins
with a value in this field. The name of the property is
the string in the HEADER line, and the value assigned

to the part or pin is the string in the corresponding
field.

Delete a field from a HEADER line and subsequent
lines (delete a column). This has no effect on any part
or pin. Deleting columns for properties you don’t
want to change may make the property file easier to
edit. If you delete a field from a HEADER line without
also deleting the corresponding fields from
subsequent lines, Capture reports an error when you
import the property file.

Change the value of a field. This resets the value of the
property on all parts or pins with that property.

Importing properties

You can use the Import Properties command to import a
file that you created with the Export Properties command
and edited using a spreadsheet, database, or text editor
application.

To import properties

1

In the project manager, open the library or project
containing the parts to import.

Caution (olumn deletion must be done
with care. Columns may be deleted only
from the HEADER line. For example, if you
want to delete column 3 from a property
file, but accidentally include column 3 of
the DESIGN line, Capture reports an error
when you import the property file.
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i Import Properties

2 From the project manager’s Tools menu, choose

Import Properties. The Import Properties dialog box
appears.

TSR

Macros
[ Netforms

Samples
- Tutorial

Figure 78 Import Properties dialog box

3 Select the file containing the properties.

4 Choose the Open button. The properties are imported.



Using Capture with
OrCAD Layout

OrCAD Layout communicates interactively with Capture.
This chapter explains how to use Capture with Layout to
perform back annotation, forward annotation, and cross
probing.

When you make changes to your board in Layout, you can
back annotate some of that information to Capture using
the Backannotation File (SWP) option in Layout’s
Generate Reports dialog box.

Select the Run ECO to Layout option in Capture’s Create
Netlist dialog box to automatically communicate changes
you made in your Capture design to Layout. If the Layout
file is open when you update the netlist file, Layout
displays a dialog box asking if you want to load the new
netlist file. If the Layout file is not open when the netlist
changes, Layout prompts you to load the modified netlist
when you reopen the Layout file.

You can also perform cross probing with Capture and
Layout. With cross probing, you can select a part or net on
a Capture schematic page or Layout board, and the

Tip You can also use Layout's AutoECO
command to forward annotate design
properties, part information, and netlist
changes to Layout from Capture. For
information on using this command, see
AutoECO in Capture’s online help.



Chapter 18 Using Capture with OrCAD Layout

Caution Layout uses reference
designators as identification for forward
and back annotation. For this reason, all
changes to reference designators must be
made in Layout and back annotated to
Capture. Similarly, if you change existing
reference designators in your Capture
design and forward annotate them info
your Layout board, your board will no
longer be usable.
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corresponding object in the other application is
highlighted.

Moving a design from Capture into Layout is a three-part
process:

e Create a valid Capture design with footprints that
Layout supports.

e Generate a netlist in the Layout format.

e Create a Layout board file. You can also transmit
information concerning parts, nets, and pins by
creating user-defined properties on the parts, nets, or
pins.

Maintaining the integration between your Layout board

and your Capture design requires that you periodically
perform these tasks:

e Create an OrCAD Backannotation File (SWP) in
Layout.

e Perform a back annotation in Capture using the back
annotation file.

e Use Layout’s AutoECO command to forward
annotate any edits you make in your Capture design
into Layout.

" When you add new parts to your Capture design, use the

Incremental reference update option in the Update Part
References dialog box (as opposed to the Unconditional
reference update option) when you update part
references.

Any connections added to or deleted from your Layout
board are not back annotated into Capture. For this
reason, when you want to modify connections, make the
changes in Capture and forward annotate them to Layout.

Changes in reference designators must be done in Layout
and back annotated with Capture.



Preparing your Capture design for use with Layout

Preparing your Capture design
for use with Layout

To prepare a Capture design for Layout you must first
modify the design, assigning special properties and
Layout-supported footprints to your parts. The tables in
this section list the part, net, or pin properties supported
by Layout. These three dialog boxes (the Set Layout Part
Properties, Set Layout Net Properties, and Set Layout Pin
Properties dialog boxes) appear when you choose their
corresponding commands on the schematic page editor’s
Macro menu.

To prepare your Capture design for use with Layout

1
2

Create a schematic design using Capture.

Assign values to the appropriate properties in the Set
Layout Part Properties dialog box, the Set Layout Net
Properties dialog box, or the Set Layout Pin Properties
dialog box. These settings transfer part, net, and pin
information to Layout.

Assign PCB footprints to each of your parts. Use only
Layout-compatible footprints, choosing from those in
the OrCAD Layout for Windows Footprint Libraries

document, or those in your custom footprint libraries.

If you are using parts from non-Layout libraries, such
as discrete parts and custom footprints, check that the
pin numbers of your part match the pad numbers of
your Layout footprint. You may need to work with
Capture’s part editor or Layout’s footprint libraries. In
addition, you need to make sure that each pin has a
pin number, as well as a pin name.

Run Design Rules Check (from the Tools menu) to
check for design rule violations.

Note For information about simple and
complex hierarchical designs, see
Chapter 6, Design structure.

Note For illustrations of these three
dialog boxes, and descriptions and
example valves for their respective
properties, see Transferring user-defined
properties to Layout on page 274.

Note Layout doesn’t accept PCB footprint
names or part values that include spaces or
tabs. Use the Capture spreadsheet editor fo
eliminate the spaces or tabs.

273



Chapter 18 Using Capture with OrCAD Layout

274

Transferring user-defined properties to Layout

To transfer part, net, or pin information to Layout, assign
values to the appropriate properties in the Set Layout Part
Properties dialog box, the Set Layout Net Properties
dialog box, or the Set Layout Pin Properties dialog box.

To have the properties in the dialog boxes added to the
parts, nets, or pins, you need to have the appropriate
objects selected on the schematic page before you play any
of the three macros.

The value you enter for each property must be in
uppercase, as shown in Table 10, Table 11, and Table 12.
on pages 275, 278, and 280 respectively.

To add Layout part properties to a part
1 Select a part on the schematic page.

2 From the Macro menu, choose Set Layout Part
Properties. The Set Layout Part Properties dialog box
appears.

3 Enter values for those properties you want to add to
the part, then click OK. The properties are added to the
part.

See Table 10, Layout part properties, on page 275 for a
description and example value for each of the
properties in the dialog box.
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Table 10  Layout part properties

Property name Example valve

Description

COMPFIXED YES

If the value is YES, the part (such
as an edge connector) is
permanently fixed to the board.

COMPGROUP 2

An integer value that assigns the
part to a group for placement.
Assigning components in groups
is useful for placing them in the
Layout board design.

COMPKEY YES

Used to designate a component
as the key component in a given
group. When placing
components in Layout, using
groups, the key component is
placed first, with all the other
components in the group placed
in proximity to it.

COMPLOC [1000, 1000]

Part location on the board as X
and Y coordinates. Use the
following format [X, Y], where X
and Y represent the coordinates.
Both must be integers in mils or
microns.

COMPLOCKED YES

If the value is YES, the part is
temporarily locked in position.

COMPROT 270.00

Part rotation in degrees and
minutes counterclockwise from
the orientation defined in the
Layout library. Use a period (.) to
separate degrees and minutes.

COMPSIDE BOT

Determines which side of a
board a part will reside on, TOP
or BOT.

FOOTPRINT DIP24

An explicit definition of the
footprint name to attach to the
component.
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Table 10 * Layout part properties (continued)

Property name Example value Description

FPLIST DIP24\400 Comma-delimited list of
alternate footprints to attach to
components, to ease switching
between footprints.

GATEGROUP 1 Identifies gate swapping

restrictions within a component.
In order to be swapped, two
gates must belong to the same
gate group.

MIRRORFOOTPR  DIP24-M
INT

An explicit mirror shape for the
component, if you don’t want
Layout to perform mirroring.

PARTNUM 489746

A customer part number that is
generally unique for each
customer and identifies the exact
part, including manufacturer
and case type.

PARTSHAPE 741504

A generic part number (such as
741504 or CKO05) that represents
a certain part throughout the
industry, but may not identify
the manufacturer or case type. If
no footprint is defined, or the
correct footprint isn’t found,
PARTSHAPE's value is
compared to the data in
SYSTEM.PRT (in
ORCADWIN/LAYOUT/DATA)
and the footprint listed in
SYSTEM.PRT is used.

POWERPIN YES

Defines non-wired pins (such as
unusual voltages) as belonging
to a particular net. POWERPIN is
typically used to override the
standard GND or VCC
attachments to particular pins of
an IC.
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To add Layout net properties to a net
1 Select a net on the schematic page.

2 From the Macro menu, choose Set Layout Net
Properties. The Set Layout Net Properties dialog box
appears.

3 Enter values for those properties you want to add to
the net, then click OK.

The properties are added to the net. See Table 11,
Layout net properties, on page 278 for a description and
example value for each of the properties in the dialog
box.
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Table 11 Layout net properties

Property name Example value Description

CONNWIDTH 10 Sets the track
width, leaving
MINWIDTH and
MAXWIDTH at
their defaults.

HIGHLIGHT YES If the value is YES,
the net is

highlighted.

MAXWIDTH 12 Sets the maximum
track width.

MINWIDTH 8 Sets the minimum
track width.

NETGROUP 2 Identifies grouped
nets. Use this to
select or color nets
as a group in
Layout (for editing
or routing).

NETWEIGHT 60 Integer between 1
and 100 assigning
relative priority to
the net. The default
value is 50.

RECONNTYPE ECL Specifies the
reconnect rules for
each type of
reconnect. Values
are STD, HORZ,
VERT, MIN, MAX,
or ECL.

SPACINGBYLAYER  TOP=13, Net spacing for one
BOT=8 or more layers.

TESTPOINT YES If the value is YES,
a test point is
automatically
assigned to the net.
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Table 11

Layout net properties (continued)

Property name

Example valve

Description

THERMALLAYERS

GND

Comma-delimited
list assigning the

net to specific plane

layers.

VIAPERNET

VIA1

Via types allowed
for net.

WIDTH

12

Track width value
assigned to the
MINWIDTH,
MAXWIDTH, and
CONNWIDTH
properties unless
overridden.

WIDTHBYLAYER

TOP=6,
BOT=12

Net width for one
or more layers.

To add Layout pin properties to a pin

1
2

Select a pin on the schematic page.

From the Macro menu, choose Set Layout Pin

Properties. The Set Layout Pin Properties dialog box

appears.

Enter values for those properties you want to add to
the pin, then click OK. The properties are added to the
pin. See Table 12, Layout pin properties, on page 280 for

a description and example value for each of the
properties in the dialog box.
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Table 12 Layout pin properties

Property name Example value Description

ECLTYPE SOURCE Defines a pin as a
Source, Load, or Target
in terms of daisy-chain
reconnection.

PINGROUP 1 Identifies pin swapping

restrictions within a
gate. In order to be
swapped, two pins must
belong to the same gate,
and to the same pin

group.
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Creating a netlist for use in
Layout

After you prepare your design in Capture and it is free
from design rules violations, you can create a netlist
(.MNL) file for use with Layout. A copy of the
LAYOUT.INI file must exist in the same directory as
CAPTURE.EXE to generate a netlist.

To create a netlist for use in Layout

1
2

Open the Capture design.

From the Tools menu, choose Create Netlist. The
Create Netlist dialog box appears.

Click the Layout tab. The Layout tab appears.

In the PCB Footprint group box, ensure that {PCB
Footprint} is displayed in the Combined property

string text box.

In the Netlist File text box, ensure that the path to the
netlist file is correct. The netlist takes the name of the
Capture design and adds a .MNL extension.

Click OK. Capture processes the netlist, then creates
an .MNL file and saves it in the directory you specified
in the previous step.

Tip Save your Capture design before
creating a netlist.

For information about combined property
strings, see Capture’s online help.

Note You may choose to exit Capture at
this time. It is not necessary to run Capture
and Layout simulfaneously fo take
advantage of forward annotation. It takes
a minimum of 64 MB of RAM to run both
Capture and Layout.

If Capture is unable to create an .MNL file,
the errors are written fo the Capture session
log and to the .ERR file in the target
directory for the .MNL file.
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Loading a new netlist into
Layout

For information on loading a new netlist into Layout, see
Capture’s online help topic Creating a new Layout project
from a Capture design.
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Back annotating board
information from Layout

When you add new parts to your Capture design, use the
Incremental reference update option in the Update Part
References dialog box (as opposed to the Unconditional
reference update option) when you update part references.

In Layout, you can back annotate board changes for
Capture using the OrCAD Backannotation File (.SWP).
Once the .SWP file is created, the current Layout file no
longer contains swap information. A copy of the board file
is saved as BACKANNO.MAX.

To back annotate

1 From Layout’s Auto menu, choose Back Annotate. A
dialog box appears that prompts you to save the
Layout design. Saving the design maintains the link
between Layout and Capture.

2 From Capture’s Tools menu, choose Back Annotate.
The Back Annotate dialog box appears.

3 Ensure that the Process entire design option is
enabled.

4 Choose the Browse button, locate and select the back
annotation file you created in Layout
(design_name.SWP), then click OK. The Layout
information is back annotated to the design in
Capture.

Caution Layout uses reference
designators as identification for forward
and back annotation. For this reason, all
changes to reference designators must be
made in Layout and back annotated to
Capture. Similarly, if you change existing
reference designators in your Capture
design and forward annotate them into
your Layout board, your board will no
longer be usable.

Caution Don't create a second .SWP file
without back annotating the first .SWP file
to Capture; otherwise, the swap
information in the first .SWP is overwritten
by the second .SWP file.

Caution If you have renamed your
components in your Layout board and
created a .SWP file, those changes in
reference designators are removed from
the current board file (.MAX). Only the
BACKANNO.MAX file retains the
information on the original and current
reference designators, but it is overwritten
you want to retain the information on
original and current reference designators,
rename the BACKANNO.MAX file.
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Note For information on Layout's
AutoECO options, see AutoECO in Capture’s
online help.

Note You can also bring Capture netlist
information into Layout by using the Run
ECO to Layout aption in the Layout tab in
the Create Netlist dialog box. For
information on this option, see the OrCAD
Layout for Windows User’s Guide.
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Forward annotating schematic
data to Layout

A copy of the LAYOUT.INI file from the Layout directory
must exist in the same directory as CAPTURE.EXE to
correctly perform forward annotation to Layout.

To forward annotate

1 From Capture’s Tools menu, choose Create Netlist.
The Create Netlist dialog box appears.

Choose the Layout tab, then click OK.

3 InLayout’s session frame, choose Tools, then ECO’s,
then one of the AutoECO options. The File A dialog
box appears.

4 Select a . MAX file to which you want to add the new
schematic information, then choose the Open button.
The File B dialog box appears.

5 Locate and select the netlist (MNL) that you created in
step 2, then choose the Open button. The Output
report dialog box appears.

6 Specify a name for the output report (usually
design_name.LIS) and a location, then choose the Save
button. The output report displays in a text editor and
the Merged Output Binary dialog box appears.

7 Specify a name and a location for the merged board,
then choose the Save button. Layout merges the files
based on the type of AutoECO you chose.

8 Read the output report carefully. The changes listed
there should match the edits you made to your
Capture design.
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Cross probing between Capture
and Layout

Using cross probing, you can select an object in Layout or
Capture and have the corresponding object highlight in
the other application. For example, you can select a net on
a schematic page in Capture and see the corresponding
track highlighted in Layout.

Enabling intertool communication between Capture
and Layout

To use cross probing, you must have the same design
open in Layout as in Capture. In Capture you must enable
intertool communication (ITC). It is not necessary to
enable ITC in Layout, because cross probing is always
active in Layout.

To enable ITC in Capture

1 From Capture’s Options menu, choose Preferences.
The Preferences dialog box appears.

2 Choose the Miscellaneous tab, select Enable intertool
communication, then click OK.

Note It is necessary to run Capture and
Layout simultaneously to use cross probing.
It takes a minimum of 64 MB of RAM fo run
both Capture and Layout.

Tip You use Layout's Half Screen
command (from the Window menu) to file
the Capture and Layout windows so that
you can view both on your screen.

Tip Only enable ITC when you want to
crossprobe. If you leave ITC enabled while
editing your design, Capture’s performance
is reduced.
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Cross probing from Capture fo Layout

Note When you use block selection in When ITC is enabled in Capture and you select certain
Capture, cross probing only highlights the ~ items on your s.chematic page, cross probing highlights
last item selected in the block. There is no the corresponding items in Layout. If you select a part or
gate in a multiple-part package in Capture, cross probing
highlights the corresponding module in Layout. If you
select a wire segment or net in Capture, cross probing
highlights the corresponding net (in its entirety) in
Layout.

way to predict the order in which items are
selected in a block selection.

Any action you perform to select an object on your
Capture schematic page (selecting using the mouse, using
the Find command, or performing a browse of parts)
causes the corresponding object in Layout to be
highlighted. For more information, see Table 13.

Table 13 Cross probing from Capture to Layout

Selecting this in Capture Highlights this in Layout

Part Corresponding component
Gate (multiple parts per package) Corresponding component
Wire segment Entire net

Net All routes for the net

Pin on part Corresponding component

To select an object in Capture for cross probing with Layout

1 Open a Capture schematic page and a matching
Layout design.

2 Choose Half Screen from Layout’s Window menu,
then position the Capture and Layout session frames
so that you can see both.

3 From Capture’s Options menu, choose Preferences.
The Preferences dialog box appears.

4 Choose the Miscellaneous tab, select Enable intertool
communication, then click OK.

5 Select an object in Capture. The corresponding object
is highlighted on the board in Layout.
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Cross probing from Layout to Capture

When ITC is enabled in Capture, selecting objects in
Layout causes Capture to highlight the corresponding
items in the schematic page editor. Selecting a component
(or a component pad) causes Capture to highlight all the
parts included in that module. Selecting a track or net
causes Capture to highlight the corresponding net on the
schematic page.

Any action you perform to select an object on your Layout
board (selecting using the mouse, using query, or using
the Find command) causes the corresponding object on
the Capture schematic page to be highlighted. For more
information, refer to Table 14.

Table 14  Cross probing from Layout to Capture

Selecting this in Layout Highlights this in Capture

Component All parts in the package

Track Corresponding wire connection

Net Corresponding nets

Pad on component Corresponding part (if the Manual
Route tool is selected in Layout, the
net is highlighted)

To select an object in Layout for cross probing with Capture
1 Opena Capture design and a matching Layout design.

2 Choose Half Screen from Layout’s Window menu,
then position the Capture and Layout session frames
so that you can see both.

3 From Capture’s Options menu, choose Preferences.
The Preferences dialog box appears.

4 Choose the Miscellaneous tab, select Enable intertool
Communication, then CliCk OK_ No‘e ’n Caprl‘e, 'he S(hemaﬁ( folder
automatically opens and displays the

schematic page on which the corresponding
part is located. Scroll the window until the
selected part is visible.

5 Selectan object in Layout. The corresponding object is
highlighted on the schematic page in Capture.
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General rules

After creating your design in Capture and your board in
Layout, be sure to back annotate into Capture. From that
point on, if you wish to make changes in the reference
designators, gate swaps or pins swaps, do them in Layout
and back annotate the results to Capture. If you need to
change connections, do these in Capture, and forward
annotate the changes into Layout.



Using Capture with
OrCAD PSpice

Overview

This chapter provides guidelines for preparing your
schematic for simulation and references further
information contained in the OrCAD PSpice User’s Guide.

A design that is targeted for simulation with PSpice will
have:

e Parts which have PSpice simulation models available
and configured (refer to Creating parts for models in
Chapter 5 in the OrCAD PSpice User’s Guide).

e Sources of stimulus to the circuit (refer to the Preparing
a design for simulation tables in the Chapter 3 in the
OrCAD PSpice User’s Guide).
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Specifying simulation model
libraries

Refer to the Creating and editing models chapter of the
OrCAD PSpice User’s Guide for information about creating
and configuring simulation model libraries. Most of the
parts that you intend to simulate must have a simulation
model defined. '

To check if a part has a simulation model defined

1 Double-click the part on the schematic page to display
the property editor spreadsheet. If a simulation model
is available for a part, the part will have:

e A PSpiceTemplate property specifying the PSpice
simulation netlisting syntax for the part.

e The implementation type set to PSpiceModel.

¢ Animplementation property specifying the name
of the model or subcircuit.

The simulation model specified by the implementation
property must be contained in a model library that is
configured.
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Creating a design for PSpice A/D
simulation

When creating designs for PSpice A /D simulation, use
Capture’s Analog or Mixed-Mode Project Wizard to assist
you in setting up your project. Only use parts from
libraries specifically created for PSpice, or your own
libraries. These libraries can be found in your
\PROGRAM FILES\ ORCAD\ CAPTURE\LIBRARY \ PSPICE
directory.

For analog circuits, use the “0” ground symbol found in
SOURCE.OLB, or use one of the other ground symbols
and rename it to “0.”

To create a new PSpice A/D design

1 From the File menu, choose New and then Project. The
New Project dialog box appears.

2 Enter a name for your new PSpice project. This name
will also serve as the design’s name.

3 Click the Browse button to specify the new location for
your project and design.

4 Select Analog or Mixed-Signal Circuit Wizard.

3 Click OK. The Analog Mixed-Mode Project Wizard
appears.

6 Select the PSpice part symbol libraries as desired. Add
them by clicking the Add button.

7  Click the Finish button. Capture creates a new project
and design.
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Refer to the Creating and editing models
chapter in the OrCAD PSpice User’s Guide.
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Editing simulation models from
Capture

You can define and edit simulation models directly from
Capture.

Models can be defined using the Model Editor.

The Model Editor is useful for characterizing specific
models from data sheet curves. It includes a text editor
that is useful if model parameters are already defined (for
example, models from a vendor) or if the model is not
supported for extraction by the Model Editor.



Adding and defining stimulus

Adding and defining stimulus

The Stimulus Editor is a utility that enables you to set up
and verify the input waveforms for a transient analysis.
You can create and edit voltage sources, current sources,
and digital stimuli for your circuit. Menu prompts guide
you to provide the necessary parameters, such as the rise
time, fall time, and period of an analog repeating pulse, or
the complex timing relations with repeating segments of a
digital stimulus. Graphical feedback enables you to verify
the waveform.

Placing stimulus sources

Stimulus sources come from the
\LIBRARY \ PSPICE\SOURCSTM.OLB library and are
one of:

e VSTIM—voltage stimulus source for transient
analysis

e ISTIM—current stimulus source for transient analysis
e DIGSTIMn—digital stimulus source

You can place any of these sources in the same way you
place any other part.

Using the Stimulus Editor

For information on using the Stimulus Editor, refer to the
Transient Analysis chapter in the OrCAD PSpice User’s
Guide or to the Stimulus Editor topics in the PSpice online
help.
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For more information, refer to the Starting
Simulation section of the Setting Up
Analyses and Starting Simulation chapter in
the OrCAD PSpice User's Guide.
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Setting up and running analyses

Refer to your PSpice user’s guide for information about
setting up and running the many different analysis types
supported by PSpice A/D.

After creating a simulation profile, you can start the
simulator directly from Capture by choosing Run from
the PSpice menu.



Viewing results

Viewing results

You can use the waveform analysis features of PSpice to
view and perform waveform analysis of the simulation
results.

Viewing results as you simulate

You can configure PSpice to automatically show
waveform results when the simulation has finished, or to
monitor waveforms as the simulation progresses.

Using markers

You can place markers on your schematic page to indicate
the points for which you want to see waveforms displayed
in PSpice.

For more information, refer to the
Analyzing waveforms chapter of the OrCAD
PSpice User’s Guide, or the PSpice online
help.

These procedures are outlined in the
Analyzing waveforms chapter in the OrCAD
PSpice User’s Guide.

For more information on markers, refer to
the OrCAD PSpice User’s Guide.
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Configuring the display of simulation results

To configure what results PSpice displays, select the Probe
Window tab when editing the simulation profile. You are
given the following choices:

Display Probe Windows When the Profile is
Opened—This causes the simulation results to be
automatically added and Probe windows displayed
whenever the simulation is opened in PSpice. '

Display Probe Window—Specifies the following
options:

During Simulation—This opens a Probe window
as soon as the simulation sweep begins, so you can
watch the waveforms develop as the simulation
progresses.

After Simulation has Completed—This opens a
Probe window upon completion of the simulation,
when all of the data is available.

Show Frame—Specifies the following options:

All Markers on Open Schematics—when a Probe
window is automatically opened, it will display
traces corresponding to any markers in currently
open schematics in Capture.

Last Plot—reconstructs the Probe window that
was last used to view results of this simulation
profile.
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Creating designs for PSpice
simulation and board layout

When creating designs for both simulation and printed
circuit board layout, some of the parts you use will be for
simulation only (for example, simulation stimulus parts
like voltage sources), and some of the parts you use will
have simulation models that only model some of the pins
of the real device.

Parts that are to be used for simulation, but not for board
layout, have a PSpiceOnly property. To see an example of
this, double-click a VDC voltage source to display the
property editor spreadsheet.

You can add this (or any) properties to your own custom
parts.

To specify part properties

1 In the schematic page editor, select the part. For more information r;)n Ideﬁningd
i Editii
2 From the Edit menu, choose Properties to display the 5;‘;‘;:;:‘6;0(;?]0{; .sym 0%, see Edlling

property editor spreadsheet.

3 Add a new property named PSpiceOnly, and set its
value to True.

4 Click OK.
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Handling unmodeled pins

Some parts used in PSpice simulation designs have
unmodeled pins that have no electrical significance in a
PSpice simulation, but must be connected to a PCB layout
design. Unmodeled pins have a FLOAT property with a
value of “Unmodeled.” If unmodeled pins are connected
to any other pins, a netlist is generated with a large
resistor connected from the set of pins to ground.
Unmodeled pins must not be referenced in a part’s
PSpiceTemplate property.

Place an instance of the PM741 from OPAMP.OLB library
to see is two unmodeled pins, “OS1” and “OS2.”
Double-click the “OS1” or “OS2” pin to bring up the
property editor. Capture shows the FLOAT property on
the two pins as “Unmodeled.” Only the +, -, OUT, V+, and
V- pins are referenced in the part’s PSpice property

To view a simulation model for a part

1 In the schematic page editor, click the part to select it.

2 From the Edit menu, choose PSpice Model to display
the Model Editor and view an instance of the
simulation model definition.

3 Exit the Model Editor without saving, to avoid
creating a copy of the model.



Glossary

dlias
ANSI

architecture

ascend

ASCll

AutoECO

See net alias, part alias.

Acronym for American National Standards Institute, an
organization formed by industry and the U.S. government
to develop trade and communication standards.
Internationally, ANSI is the American representative to
the ISO (International Standards Organization). See also
ASCII.

VHDL term that describes the behavior of a VHDL design
unit (an entity / architecture pair). The architecture can
also serve to connect other VHDL design units.

In a hierarchical design, to move from the child schematic
folder to the parent schematic page. This is done in the
schematic page editor using the Ascend Hierarchy
command on the View menu. See also child, descend,
parent.

Acronym for American Standard Code for Information
Interchange; a seven-bit code—based on the first 128
characters of the ANSI character set—that assigns
numeric values to letters of the alphabet, the ten decimal
digits, punctuation marks, and other characters such as
Backspace, Carriage Return, and Line Feed. ASCII is the
most widely used character-coding set, and as such
enables different applications and computers to exchange
information. See also ANSI.

Acronym for automatic engineering change order. Layout’s
AutoECO command translates schematic netlist
information from Express to Layout. See also forward
annotate.
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back annotate

bitmap

bookmark

browse spreadsheet

bus

To apply modifications to part properties in a design, such
as updating part references and pin numbers, swapping
gates, or swapping pins. Parts are back annotated in the
project manager, using the Gate and Pin Swap command
or the Update Properties command on the Tools menu. In
Layout: to transmit data, such as gate'and pin swaps, back
to the schematic pages. See also forward annotate.

Bitmaps are graphic images made up of pixels, which are
tiny dots on a computer screen. Each pixel in a bitmap is
represented by a number between 0 and 255, inclusive,
with 0 being the darkest (no luminance) and 255 being the
lightest (full luminance). Bitmaps have a .BMP extension,
and can be placed on a schematic page using the Picture
command on the schematic page editor’s Place menu.

Just as you can place a bookmark in a book to mark a
specific page, you can place a bookmark on a schematic
page to mark a location you would like to return to. To
place a bookmark, use the Bookmark command on the
Place menu in the schematic page editor. To go to a
bookmark when in the schematic page editor, use the Go
To command on the View menu. To go to a bookmark
when in the project manager, use the Browse command on
the Edit menu to display bookmarks in the browse
window, then choose a bookmark. To edit a bookmark,
double-click on it.

This window displays the results of queries done using
the Browse command on the Edit menu. You can
double-click on an object in the browse window to go to
that item on its schematic page.

A group of scalar signals (wires) that is never connected to
a net. A bus name defines the bus signals and connects
those signals to the corresponding nets. For example, the
bus name A[0:3] defines a four-signal bus and connects
the four signals A[0], A[1], A[2], and A[3] with nets A0,
Al, A2, and A3. See also bus pin, bus entry.
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bus entry

bus pin

CAGE code

child

complex hierarchy

convert

cross probing

DeMorgan equivalent

A bus entry is used to tie a signal to a bus. The advantage
of using bus entries instead of wires is that two bus entries
can be connected at the same point on a bus without
connecting the signals. If two wires are run directly to a
bus at the same location, the signals are connected. See
also bus, bus pin.

A pin width that can carry multiple signals, as opposed to
a scalar pin that only carries one signal. A bus pin
represents all the pins for a bus, and they use the same
naming conventions as buses. See also bus, bus entry.

An acronym for Commercial and Government Entity Code. A
number—provided by the federal government to its
suppliers—that can be present in the title block of a
schematic page.

In a hierarchical design, a schematic folder whose
circuitry is represented by a hierarchical block on the
parent schematic page. To move from parent to child is to
descend the hierarchy. A child contains circuitry
referenced by its parent. See also ascend, descend, parent.

A design in which two or more hierarchical blocks (or
parts with attached schematic folders) reference the same
schematic folder. See also hierarchical design, simple
hierarchy.

An alternate form—such as a DeMorgan equivalent—that
can be stored with each part. See also DeMorgan equivalent.

When intertool communication is enabled in Express,
selecting objects in Express causes the corresponding
objects to be highlighted in Layout. Also, selecting objects
in Layout causes the corresponding objects to be
highlighted in Express. Both applications must be open.
See also intertool communication.

An electrically-equivalent part based on the DeMorgan
rules of equivalence. These rules represent the duality of
AND and OR in Boolean expressions: if all AND
operations are changed to OR operations, all OR
operations are changed to AND operations, and all
variables and constants are negated, then the value of the
expression remains unchanged. A DeMorgan equivalent
can be stored in the convert of a part. See also convert.
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descend

design cache

design rules check (DRC)

document

EDA

EDIF

equivalent
ERC

RN

flat design

forward annotate

In a hierarchical design, to open and view the child
schematic folder represented by a hierarchical block on
the parent schematic page. To descend a hierarchical
design, you select a hierarchical block in the schematic
page editor, then choose the Descend Hierarchy
command on the View menu. See also ascend, child, parent.

A local library contained in each project that contains all
the parts and symbols used in the project.

This tool, on the project manager’s Tools menu, checks a
design or part of a design for conformance to a set of
configurable design criteria and electrical rules.

A schematic folder, schematic page, library, part, or
symbol. Each of these is part of a project.

Acronym for Electronic Design Automation. Software and
hardware tools used to ascertain the viability of an
electronic design. These tools perform simulation,
synthesis, verification, analysis, and testing of a project.

Acronym for Electronic Design Interchange Format. A
standard published by the EIA (Electronic Industries
Association) that defines semantics and syntax for an
interchange format that communicates electronic designs.

See convert, DeMorgan equivalent.

Acronym for Electrical Rules Check, a subset of the Design

Rules Check tool. The ERC matrix is used by Design Rules
Check to check for when evaluate connections between
pins, off-page connectors, hierarchical ports and
hierarchical pins.

A schematic structure with no hierarchy (no hierarchical
blocks; no parts with attached schematic folders). A flat
design can include schematic pages in which output
signals of one schematic page connect laterally to input
signals of another schematic page through objects called
off-page connectors. You place these objects using the
Off-Page Connector command on the Place menu in the
schematic page editor. Flat designs are practical for small
designs with few schematic pages. See also hierarchical
design, complex hierarchy, simple hierarchy, off-page connector.

The process of sending netlist data in the form of an .MNL
file from Capture to Layout.
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graphic object

grid reference

heterogeneous package

hierarchical block

hierarchical design

hierarchical pin

hierarchical port

homogeneous package
HPGL

An object drawn or placed on a schematic page or part—
such as an arg, line, rectangle, ellipse, polygon, bitmap,
text, or title block—that has no electrical connectivity.

The border around a schematic page that acts as a visual
reference for the grid. Grid references can be used as a
destination for the Go To command on the View menu,
and can be set to visible or hidden in both the Design
Template and Schematic Page Properties dialog boxes.

A package with multiple parts that are graphically
different or contain different numbers of pins (for
example, a relay). See also. homogeneous package.

A symbol placed on a parent schematic page that refers to
a child schematic folder. Hierarchical pins are placed
within a hierarchical block, and hierarchical ports that
refer to the hierarchical pins are placed on a schematic
page within the child schematic folder. See also hierarchical
pin, hierarchical port.

A design in which design modules are interconnected
vertically with hierarchical blocks (or parts with attached
schematic folders). At least one module, the root module,
contains symbols representing other schematic folders.
See also complex hierarchy, simple hierarchy, flat design,
design module.

A symbol, placed within a hierarchical block, that
represents a signal connected to a like-named hierarchical
port on another schematic page. See also hierarchical block,
hierarchical port.

A symbol, placed outside a hierarchical block, that
represents a signal connected to a like-named hierarchical
pin. Hierarchical ports can also connect to like-named
hierarchical ports. See also hierarchical block, hierarchical
pin.

A package with multiple parts that are graphically
identical. See also heterogeneous package.

Acronym for Hewlett-Packard Graphics Language, which is
a plotter protocol.

Acronym for Institute of Electrical and Electronics Engineers.
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inherent property

instance

instance property

intertool communication (ITC)

junction

library

location

macro

mirror
named net

net

One of the set of properties required for a given object.
Unlike user-defined properties, inherent properties
cannot be removed.

A part or symbol placed on a schematic page. See also
instance property, occurrence.

A property that is attached to an instance, as opposed to a
property that is attached to an occurrence or added to a
partin a library. Instance properties can be overridden by
occurrence properties, which are not reflected on the
instance. See also instance, occurrence.

A capability that allows OrCAD EDA tools to share
information for display and transfer. See also cross probing.

A junction, shown as a small dot, is placed at the
connection point where two perpendicular wires or buses
cross, to give visual confirmation that the items are
electrically connected. If you draw a wire across another
wire at a 90-degree angle, the wires are not electrically
connected unless you create a junction by clicking the left
mouse button on the existing wire as you draw the new
wire across it.

A collection of often-used parts, graphics, schematic
pages, and symbols.

An X, Y coordinate on a schematic page or part. You can
move to a location using the Go To command on the View
menu in the schematic page editor.

A series of commands you can record, then execute by
pressing one key or a combination of keys. Macros greatly
reduce the number of keystrokes required to perform
complex or repetitive actions.

To flip along the X (horizontal) or Y (vertical) axis, or both.

A net with more than one net alias where you choose
which net will be used in the netlist.

The wires, buses, parts, and symbols that are logically
connected via net names, aliases, off-page connectors, and
hierarchical ports.
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net alias

netlist

nonprimitive

occurrence

occurrence property

off-page connector

package

pan

A name used to specify signal connections between
unconnected wires or buses. For example, if you have
wires in two remote locations in a schematic folder, you
can assign each wire an alias (such as ABC) to connect the
signals without physically drawing a wire between them.

A file that lists the interconnections of the project
components by the names of the connected signals, parts,
and pins.

A part with an underlying hierarchy, such as an attached
schematic folder.

An instance placed on a schematic page with one or more
sets of unique property values that may differ from other
occurrences of the same instance. An occurrence typically
appears in a complex hierarchy where a schematic is
reused. Each use of the schematic is an occurrence, while
the schematic itself is the instance. See also instance,
occurrence property.

A property attached to an occurrence, as opposed to a
property attached to an instance or added to a part in a
library. Occurrence properties override instance
properties, but are not reflected on the instance. See also
instance, occurrence.

An object that conducts signals between schematic pages
within the same schematic folder. See also flat design.

A physical part that contains more than one logical part.
For example, a 2N3905 transistor, a fuse, and a 74LS00 are
packages. Each part in a package has a unique part
reference comprised of an alphanumeric prefix common
to all the parts in the package, and a letter unique to each
part. For example, a 74LS00 with a part reference prefix of
U15 would have four parts with part references of U15A,
U15B, U15C, and U15D. See also homogeneous part,
heterogeneous part.

To change the portion of the schematic page or part being
viewed by dragging objects from one location to another.
As you drag an object, the schematic page or part pans
across the active window.

305



Glossary

306

parent

part

part dlias

part editor
part instance
part primitive
PCB

pin

pin swap

pin-to-pin spacing
polygon

A schematic page containing a hierarchical block that
references another schematic folder (called a child). See
also child, hierarchical block.

A part is a basic building block of a project that may
represent one or more physical elements, or a function, a
simulation model, or a text description for use by another
application. A part’s behavior is described by a SPICE
model, an attached schematic folder, HDL statements, or
other means. Parts usually correspond to physical objects
(gates, connectors, and so on) that come in packages of one
or more parts. You can think of these packages as physical
parts and the parts you place on a schematic page as
logical parts. Physical parts with more than one logical
part are sometimes referred to as “multiple-part
packages.” For simplicity, Express usually refers to both
as parts. See also package.

A duplicate copy of a part that uses a different name. A
part alias uses the same graphics, attached schematic
folders, and properties as the original, with the exception
of the part value.

The editor used to create and edit parts and symbols.

An instance of a part. See also instance.

See primitive.

Acronym for printed circuit board.

A pin acts as a point of connectivity for the part it is
attached to. In addition to input and output pins, there are
also 3-state, bidirectional, open collector, open emitter,
passive, and power pins. If a pin connects to a wire, itis a

scalar pin; if it connects to a bus, it is a bus pin. See also
hierarchical pin.

he exchange of identical pins in order to decrease route
lengths.

The physical spacing between pins on a device.

A graphic object made up of polylines (multiple
contiguous segments) whose beginning and end are
attached to form a closed shape that can be filled. See also
polyline. ‘
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polyline

port

primitive

project

project manager

property

root schematic folder

scalar

schematic design

schematic folder

A line with multiple contiguous segments. You place a
polyline using the Polyline command on the Place menu.

A VHDL term for an interface element of a VHDL entity.
Serves as a communication channel between VHDL
design units. Express part pins and hierarchical ports will
produce a VHDL port. See also hierarchical port.

A part or hierarchical block with no underlying hierarchy.

A single file that includes all of the schematic folders,
schematic pages, parts, and symbols that make up a
project. You can view these project elements in the project
manager. A basic project contains one schematic folder
and one schematic page, while a complicated project may
contain an unlimited number of schematic folders, each
with many schematic pages.

The Express window used to perform project-wide tasks,
such as locating objects, creating a netlist, or generating
reports. This window displays the structure of the
schematic folders and schematic pages contained in a
design. See also hierarchical design, simple hierarchy.

A characteristic of an object that can be edited. A property
consists of a name and a value. Examples of property
names are part value and color. Their respective property
values can be something such as capacitor and red.

The schematic folder at the top of a hierarchical design.
The root schematic folder contains a backslash in its folder
icon in the project manager. A project has only one root
schematic folder.

A pin width that carries only one signal, as opposed to a
bus pin that can carry multiple signals.

A graphical representation of a circuit using a set of
electronic symbols, hierarchical blocks, and connections.
Typically used by system and programmable logic
designers to express a structural design description.

A collection of all schematic pages at the same level of
hierarchy in a design. In the project manager, a schematic
folder behaves like a container. See also flat design,
hierarchical design, schematic page, root schematic folder.
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schematic page

schematic page editor
session frame

session log

signal

simple hierarchy

source library

spreadsheet editor
symbol

tabbed dialog box

The pages on which a design is drawn. Schematic pages
display in a window, called the schematic page editor, in
which you can place parts and draw wires.

The editor used to create and edit schematic pages.

The window in which various tool elements—such as the
session log, project manager, schematic page editor, and
part editor—run.

A window that displays text messages generated by
Express or Express Simulate, such as errors and
informational messages. The session log starts empty with
each new session, but you can save its contents to a text
file.

An electrical impulse of a predetermined voltage, current,
polarity, and pulse width. Also, a VHDL term for a local
circuit node that is not visible outside a VHDL design
unit. A wire or bus that is not connected to a hierarchical
port will produce a VHDL signal.

A design in which there is a one-to-one correspondence
between hierarchical blocks (or parts with attached
schematic folders) and the schematic folders they
reference. Each hierarchical block (or part with an
attached schematic folder) represents a unique schematic
folder. See also hierarchical design, complex hierarchy.

The path and filename where a part’s definition resides. A
filename with an .OLB extension indicates that the part
was placed “as is” from the library. A filename with a
.DSN extension indicates that the part no longer matches
the original library part, and the changed part’s definition
only resides in the project where the part was edited.

A window used to edit the properties of multiple objects
at once.

A power or ground object, an off-page connector, a
hierarchical port, or a title block.

A dialog box that has different views that can be displayed
by clicking on tabs at the top of the dialog box.
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TrueType

user-defined property

vertex

wildcard

X axis

Y axis

zoom

zoom factor

zoom scale

A font (typeface) that appears in a printout exactly the
way it appears on the screen. TrueType fonts are scaleable
to any font size, and several of these type of fonts are
installed automatically when you install Windows.

A property you add to an object. Unlike inherent
properties, user-defined properties can be removed. See
also inherent property.

The point at which the sides of an angle meet. You create
this by drawing a wire or line in one direction, then
changing direction to create an L-shaped or V-shaped
wire or line.

A symbol, usually used in searches, that represents a
missing or unknown character or sequence of characters.
In Express, valid wildcard characters are an asterisk (*) to
match multiple characters and a question mark (?) to
match individual characters.

The horizontal or left-to-right direction in a
two-dimensional system of coordinates. The X axis is
perpendicular to the Y axis.

The vertical or bottom-to-top direction in a
two-dimensional system of coordinates. The Y axis is
perpendicular to the X axis.

To change the view of a window, making the objects
appear larger or smaller. When you zoom out, the objects
are smaller and you see more of the schematic page or
part. When you zoom in, the objects are larger, but you see
less of the schematic page or part.

The amount by which the zoom scale is multiplied or
divided when you choose Zoom In or Zoom Out on the
schematic page editor’s View menu. The Zoom factor is
normally 2, but you can change it using the Preferences
command on the Options menu. For example, a zoom
scale of two makes the image of the screen twice as large
when you zoom in and half as large when you zoom out.

The relative size of the image on the screen, as a
percentage of the normal size. For example, a zoom scale
of 250% means the image on the screen is two and one-half
times as large as normal.
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A

adding macros, 165
Annotate
Annotate command, 228
toolbar, 17
Annotate dialog box, 227-228
annotation
back, 283
forward, 284
Arc command
tool palette button, 21
arcs
drawing, 146
resizing, 146
area selection, 27
attached implementation, 113, 123, 199
attached schematic folders, 99, 113, 123, 192, 199-200
descending, 192, 200
homogeneous package, 192, 200
in complex hierarchical designs, 97
in simple hierarchical designs, 95
attaching implementations to hierarchical blocks, 120
auto recovery, 48, 61, 63
AutoECO, 271
autoscrolling, defining, 57

Back Annotate command

toolbar, 17
back annotation, 283
BACKANNO.MAX file, 283
backslash, in root module folder icon, 7, 95
bidirectional, pin type, 205
Bill of Materials

command, 221-222, 255

toolbar, 18

dialog box, 257

include file format, 259
bitmaps

placing, 151

plotting, 89

resizing, 151
Bookmark command, 178
bookmarks

jumping to, 178

placing, 178

properties, 29

renaming, 178
border visibility

defining for new designs, 72
Browse spreadsheet editor, 30
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copying values within, 31
creating properties, 31

removing user-defined properties, 32

Bus command, 137
tool palette button, 20
bus entries, placing, 138
Bus Entry command, 138
tool palette button, 20
buses
editing, 134
names, 134, 137
placing, 134
user-defined properties, 29

C

CAPSYM.OLB, 100
Capture SDT Compeatibility, 77
CAPTURE.INI, 110
character formatting, 157
circles
drawing, 145
resizing, 145
Clear Session Log command, 14
Close Project command, 49
colors
defining for graphics, 61
defining for objects, 55
defining for VHDL syntax, 64

defining preferences, 34
commands

Annotate, 17

Arc, 21

Back Annotate, 17

Bill of Materials, 18

Bus, 20

Bus Entry, 20

Clear Session Log, 14

Close Project, 49

Copy, 16

Create Netlist, 17

Cross References, 17

Cut, 16

Design Properties, 51

Design Rules Check, 17

Design Template, 51

Ellipse, 21

Exit, 49

Export Design, 264
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Export Properties, 266

Find, 14

Ground, 20

Group, 28

Help Topics, 18

Hierarchical Block, 20

Hierarchical Pin, 21

Hierarchical Port, 21

IEEE Symbol, 22

Import Design, 265

Import Properties, 269

Junction, 20

Line, 21

Net Alias, 20

New, 16

No Connect, 21

Off-Page Connector, 21

Open, 16, 45

Part, 20

Paste, 17

Pin, 22

Pin Array, 22

Polyline, 21

Power, 20

Preferences, 51

Print, 16

Rectangle, 21

Redo, 17, 38

Repeat, 38

Save, 16, 48

Schematic Page Properties, 51

Select All, 27

Status Bar, 25

Text, 21

Tool palette, 23

Toolbar, 18

Undo, 17, 38

Ungroup, 28

Wire, 20

Zoom All, 17

Zoom Area, 17

Zoom In, 17

Zoom Out, 17
complex hierarchy, 97
Configure Macro dialog box, 164
configuring macros, 163
Convert command, 198, 218
convert view of a part, 198, 218
Copy command, 150, 153, 157

toolbar, 16
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Create Netlist
command, 192, 200, 221-222
toolbar, 17
dialog box, 251
format files, 252
creating macros, 159
cross probing, 285
Capture to Layout, 286
Layout to Capture, 287
Cross Reference
command, 222
toolbar, 17
dialog box, 261
custom libraries, 186
custom parts, 195
Cut command, 149, 157
toolbar, 16

De Morgan equivalent, 198
defining
auto recovery interval, 61
autoscrolling, 57
Capture settings, 51
colors, 54
colors for graphics, 61
colors for VHDL syntax, 64
fill style for graphics, 61
fonts for VHDL syntax, 64
grid display, 56
grid references, 81
highlighting for VHDL syntax, 64
line style for graphics, 61
line width for graphics, 61
macros
for display on Macro menu, 166
names, 164, 167
shortcut keys, 163, 165, 169
panning, 57
project manager fonts, 61
schematic page size, 80
schematic page units, 80
session log fonts, 61
text editor preferences, 64
TrueType fonts as strokes, 61
zoom factor, 57
deleting an object, 150
descending into attached schematic folders, 192, 200

deselecting, 26
design cache, 190
Design Cache folder, 6
design folder, 6
design process, 221
Design Properties
command, 51
dialog box
Fonts tab, 77
Hierarchy tab, 77
Miscellaneous tab, 79
SDT Compeatibility tab, 77
dialog box, Hierarchy tab, 192
Design Resources folder, 6, 43—44, 265
Design Rules Check
command, 222
toolbar, 17
design rules violations, checking for, 222
design structure
complex hierarchical, 97
flat, 94
hierarchical, 95
simple hierarchical, 95
Design Template
command, 51
dialog box
Fonts tab, 67
Grid Reference tab, 72
Hierarchy tab, 74
Page Size tab, 70
SDT Compeatibility tab, 75
Title Block tab, 68
dialog box, Hierarchy tab, 192
designator, 226
designs
exporting to a file, 264
importing to a project, 265
opening,
dialog boxes
Configure Macro, 164
Export Design
DXF tab, 264
EDIF tab, 264
Exporting Properties, 267
Import Design
Custom tab, 265
EDIF tab, 265
PSpice tab, 265
Import Properties, 270
Macro Name, 163
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displaying invisible power pins, 212
drag, maximum number of objects displayed, 59
drawing

adding fill, 148

arcs, 146

circles, 145

ellipses, 145

lines, 143

polygons, 147

polylines, 147

rectangles, 144

squares, 144
DRC markers, 223

properties, 29
drivers

plotter, 83

printer, 83
DXF, 263

ECO, 271

Run ECO to Layout, 271
EDIF, 263

configuration files, 264-265
editing, 29

ground symbols, 117

hierarchical blocks, 124

off-page connectors, 133

power symbols, 117

properties, 29

property files, 268

user-defined properties, 29
Ellipse command

tool palette button, 21
ellipses

drawing, 145

resizing, 145
Exit command, 49
Export Design

command, 264

dialog box

DXF tab, 264
EDIF tab, 264

Export Properties

command, 222, 266

dialog box, 267
exporting

designs, 264
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libraries, 264
properties, 222, 266
text, 157

extensions for filenames
INT, 51
.OLB, 69

file extensions
INT, 51
MNL, 281
OLB, 69
SWP, 283
file formats
DXF, 263
EDIF, 263
include file, Bill of Materials
command, 259
netlist format files, 252
property file, 267
PSpice, 263
Schematics, 263
File tab, 9
file types
back annotation files, 283
netlist files, 281
swap files, 283
files
auto recovery, 61
BACKANNO.MAX, 283
DXF, 263
EDIF, 263
configuration files, 264—265
LAYOUT.INTI, 281
MSIM.INI, 265
opening, 45
property, 267
PSpice, 263
MSIM.INI, 265
Schematics, 263
fill style, 141
defining for graphics, 61
fill, adding to a graphic object, 148
Find command, 14
finding
parts in a design, 181
parts on a schematic page, 181
flat designs, 94
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off-page connectors, 4
folders
Design Cache folder, 6
design folder, 6
Design Resources, 43—44, 265
Design Resources folder, 6
Library, 265
Library folder, 6
Outputs folder, 6
schematic folders, 6
schematics, 41
fonts
changing placed text, 157
defining for existing designs, 77
defining for new designs, 67
defining for VHDL syntax, 64
project manager, 61
screen, 158
session log, 61
TrueType, 61
footprint, 113, 251, 281
format files
netlist, 252
forward annotation, 284

G

Gate and Pin Swap
command, 222
global power pins, 79
globals, 113, 205, 211
Go To
command, 175
dialog box
Bookmark tab, 179
Grid Reference tab, 177
Location tab, 176
Grid command, 180
grid display
dots or lines, 56
setting visibility, 56
snap-to-grid, 56
grid references
defining for new designs, 72
displaying or hiding, 180
Grid References command, 180
grid spacing, defining, 70
Ground command, 115
tool palette button, 20

ground pins, 211

ground symbols, placing, 117
Group command, 28
grouping, 28

Help Topics command
toolbar, 18
heterogeneous package, 187, 192-194
Hierarchical Block command
tool palette button, 20
hierarchical blocks
attached implementation, 120, 123
complex hierarchical designs, 97
hierarchical designs, 95
nets between schematic folders and schematic
pages, 98
placing, 124
simple hierarchical designs, 95
user-defined properties, 29
hierarchical designs, 95
complex, 97
hierarchical blocks, 95
simple, 95
Hierarchical Pin
command, 128
tool palette button, 21
hierarchical pins, 99
nets between schematic folders and schematic
pages, 98
off-grid, 127
Hierarchical Port command, 125
tool palette button, 21
hierarchical ports, 99
nets between schematic folders and schematic
pages, 98
placing, 125
properties, 29
hierarchy, 95, 192, 200
attached implementation, 113, 120, 199
complex, 97
defining for existing designs, 77
defining for new designs, 74
Hierarchy tab, 9
placing hierarchical blocks, 120
simple, 95
highlighting
defining for VHDL syntax, 64
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homogeneous package, 187, 193-194 exporting to a file, 264
attaching schematic folders, 192 importing to a project, 265
moving parts to a different library, 186
opening, 45
I Library folder, 6, 265

Line command
tool palette button, 21
line style, 141
defining for graphics, 61
line width, defining for graphics, 61

IEEE Symbol command, 201
tool palette button, 22
IEEE symbols
adding to a part, 201

Import Design i
command, 265 mnes .
dialog box drawing, 143
& izing, 143
Custom tab, 265 logi resizing, 9
EDIF tab, 265 ogical mode,
PSpice tab, 265
Import Properties M
command, 222, 269
dialog box, 270 Macro Name dialog box, 163
importing macros
designs, 265 adding, 165
libraries, 265 configuring, 163
properties, 222, 269 creating, 159
text, 156 defining
include file format, 259 for display on Macro menu, 166
input, pin type, 205 shortcut keys, 165, 169
instances, 10, 29, 33-34 defining shortcut keys, 163
in the property editor, 34 naming, 164, 167
intertool communication (ITC) playing, 162
enabling in Capture, 285 recording, 161
enabling in Layout, 785 removing, 165
saving, 165
shortcut key assignments, 169
J temporary, 159
. . Mirror command, 148
jumping modes
to a bookmark, 178 .
to a grid reference, 177 logical, 9
& enes hysical, 9
to a marked location, 178 physicas,

multiple objects, selecting, 26
multiple-part packages, 187
creating, 195

to a new location, 175
Junction command

tool palette button, 20
junctions, 135

I. naming macros, 164, 167

LAYOUT.INI file, 281 Net Alias command
libraries, 186 tool palette button, 20

copying parts to a different library, 186 net aliases, ]%‘;’6] 37
custom, 186 editing,
! net names, 134
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net properties, transferring to Layout, 277
netlist
creating, 222
creating for Layout, 281
creating for simulation, 250
format files, 252
netname
resolution, 253
nets
hierarchical blocks, between schematic folders
and schematic pages, 98
hierarchical pins, between schematic folders
and schematic pages, 98
hierarchical ports, between schematic folders
and schematic pages, 98
off-page connectors, between schematic pages
in a single schematic, 98
properties, 29
user-defined properties, 29
New command
toolbar button, 16
New Part command, 195
New Part Properties dialog box, 198
Next Part command, 216
No Connect command, 118
tool palette button, 21
nonprimitive parts, 106, 192, 200

V)

occurrences, 10, 29-30, 33-34
in the property editor, 34
Off-Page Connector command, 130
tool palette button, 21
off-page connectors, 100
in flat designs, 94
example, 101
nets between schematic pages in a single
schematic, 98
placing, 133
properties, 29
open collector, pin type, 205
Open command, 45
toolbar button, 16
open emitter, pin type, 205
output, pin type, 205
Outputs folder, 6

Package command, 216-217
package view, part editor, 12
packages, 105, 187
editing, 217
heterogeneous, 187,193
homogeneous, 187, 193
attaching schematic folders, 192
plotting, 85
printing, 85
user-defined properties, 29
viewing, 216
page size
defining for new designs, 70
panning, defining, 57
Part command, 107
tool palette button, 20
part editor, 12
package view, 12
part view, 12
tool palette, 22, 141
part instances, 10, 190
editing, 214
user-defined properties, 29
see also instances
part occurrences, 10
see also occurrences
part properties, transferring to Layout, 274
part reference, 226
part view, part editor, 12
parts
attached schematic folders, 95, 97, 99
convert view, 198, 218
copying to a different library, 186
editing
in a library, 213
on a schematic page, 214
finding, 181
heterogeneous package, 187, 193
homogeneous package, 187,193
attaching schematic folders, 192
IEEE symbols, placing, 201
instances, 10, 190
moving to a different library, 186
multiple-part packages, 187
occurrences, 10
packages, 187
part body, 195
part body border, 195
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part reference, 199

PCB footprint, 198

pins, placing, 202

plotting, 85

printing, 85

properties, 29

user-defined properties, 29
passive, pin type, 205
Paste command, 150

toolbar, 17
PCB footprint property, 113, 251, 281
physical mode, 9
Picture command, 151
Pin Array command, 207

tool palette button, 22
Pin command, 202

tool palette button, 22
pin properties, transferring to Layout, 279
pins

connecting to wires, 135

ground, 211

invisible, displaying, 212

name,

number, 204

placing multiple, 207

placing on a part, 202

power, 211

properties, 29

shape, 205

shared, 193, 211

types, 205

user-defined properties, 29

visibility, 204, 211

width, 204
pin-to-pin spacing, defining for new designs, 70
Place Ground Symbol dialog box, 116
Place Hierarchical Block dialog box, 122
Place Hierarchical Pin dialog box, 129
Place Hierarchical Port dialog box, 126
Place Off-Page Connector dialog box, 132
Place Part dialog box, 109
Place Pin Array dialog box, 209
Place Pin dialog box, 204
Place Power Symbol dialog box, 116
placing

bitmaps, 151

bus entries, 138

ground symbols, 117

hierarchical blocks, 124

hierarchical pins, 128
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off-page connectors, 133
power symbols, 117
text, 152
playing macros, 162 -
plotting, 83
bitmaps, 89
drivers, 83, 89
HPGL emulation, 89
parts or packages, 85
pen colors, 89
previewing, 87
rendering TrueType fonts as strokes, 61
scaling output, 88
schematic pages, 84
polygons
drawing, 147
resizing, 147
Polyline command
tool palette button, 21
polylines
drawing, 147
resizing, 147
pop-up menus, 10
power
pins, 211
type, 205
visibility, 79, 113
symbols, 117
Power command, 114
tool palette button, 20
Preferences
command, 51
dialog box
Colors tab, 26
Colors/Print tab, 54
Grid Display tab, 56
Miscellaneous tab, 61
Pan and Zoom tab, 57
Select tab, 27, 59
Text Editor tab, 64
dialog box, Pan and Zoom tab, 172
previewing print output, 87
Previous Part command, 216
primitive parts, 106, 192
Primitive property, 113,192, 200
Default option, 192, 200
on hierarchical blocks, 122
Print command, 84
toolbar, 16
print options, 54
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Print Preview command, §7 Layout part properties, 274
Print Setup command, 83 Layout pin properties, 279
printing, 83 removing,

disabling printing of individual objects, 54
drivers, 83

parts or packages, 85

previewing, 8

rendering TrueType fonts as strokes, 61
scaling output, 88

spreadsheet editor, 221
user-defined, 29

property editor, 33, 112

creating a new property, 35
deleting a property, 36
displaying properties, 36

schematic pages, 84 editing a property value, 35
session log, 86 editing values for all instances and occurrences,
setting up, 83 36
text editor, 86 filters, 34
Programmer’s editor, 13 key points regarding, 35
project manager property file format, 267

File tab, 9 PSpice, 263, 289-298
folders

Design Cache folder, 6

design folder, 6 R

Design Resources folder, 6
Library folder, 6
Outputs folder, 6

font, 61

Hierarchy tab, 9

pop-up menus, 10

schematic folders, 6

schematic pages, 6

recording macros, 161
Rectangle command
tool palette button, 21
rectangles
drawing, 144
resizing, 144
Redo command, 38

toolbar. 18 toolbar, 17
: oto at redoing actions, 38
pro]eac df‘]ina filoe 47 reference designator, 226
"1" 9 “ii)“’ h removing macros, 165
e Ryt commane. &
! repeating actions,
folders

Replace Cache command, 189
replacing a part instance in the design cache, 189

reports
bill of materials, 222, 255

Design Resources, 43-44, 265
Library, 265
schematics, 41

openng, 4 cross reference, 222

Saving, 4 reversing actions, 38
propert1e§ root module, 7, 95

copying, 3] Rotate command, 149

creating, 31, 35
deleting, 36
displaying, 36
editing, 29, 35-36, 221 s
editing a property file, 268
exporting, 266

Run ECO to Layout, 271

Save command, 48
exporting to a file, 222 toolbar button, 16
importing, 269 saving macros, 165
importing from a file, 222 scaling

Layout net properties, 277 plotter output, 88
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printer output, 88
schematic folders, 6, 41
attaching to a part, 200
schematic page editor, 11
displaying the property editor, 33
tool palette, 141
Schematic Page Properties
command, 51
dialog box
Grid References tab, 81
Miscellaneous tab, 81
Page Size tab, 80
schematic page size
defining for new designs, 70
schematic pages, 6
creation date, 81
defining grid references, 81
defining page size, 80
defining units, 80
modification date, 81
plotting, 84
printing, 84
Schematics, 263
screen fonts, 158
scrolling
defining auto scroll percent, 57-58
scroll percent, 57
SDT compatibility with Capture, 75, 77
Select All command, 27
selecting
all objects, 27
area, 27
deselecting, 26
multiple objects, 26
one object, 26
selection border, intersect or enclosed, 59
selection options
defining, 59
session frame, 4
session log, 14
font, 61
printing, 86
shared pins, 193, 211
shortcut key assignments for macros, 169
simple hierarchy, 95
example, 101
simulation
creating a netlist for, 250
single view, 9
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snap-to-grid
toolbar, 18
snap-to-grid, defining, 56
spreadsheet editor, 221
squares
drawing, 144
resizing, 144
status bar, 24
visibility, 25
Status Bar command, 25
swapping gates or pins, 222
symbol, 12
symbol editor, 12

T

tab spacing, defining for text editor, 64
temporary macros; 159
text
bounding box, 154
character formatting, 157
deleting, 154
editing, 154
exporting, 157
finding, 155
importing, 156
moving, 152
placing, 152

rendering TrueType fonts as strokes, 61

replacing, 156
rotating, 153
Text command, 152, 157
tool palette button, 21
text editor, 13
defining preferences, 64
printing, 86
three-state, pin type, 205
title block
properties, 29
title blocks, 186
choosing, 68
default information, 68
defining for new designs, 68
settings, 68
visibility, 68
defining for new designs, 72
tool palette
part editor, 19, 141
IEEE Symbol command, 22
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Pin Array, 22 U
Pin command, 22
schematic page editor, 19, 141 Undo command, 38
Arc command, 21 toolbar, 17
Bus command, 20 undoing actions, 38
Bus Entry command, 20 Ungroup command, 28
Ellipse, 71 unit of measure
Ground command, 20 defining for new designs, 70
Hierarchical Block, 20 Update Cache command, 191
Hierarchical Pin, 21 Update Part References
Hierarchical Port, 21 command, 222
Junction command, 20 Update Properties
Line command, 21 command, 222
Net Alias command, 20 dialog box, 231
No Connect command, 21 updating
Off-Page Connector command, 21 part references, 227
Part command, 20 properties, 227
Polyline command, 21 . selected parts in the design cache, 191
Power command, 20 user-defined properties, 29
Rectangle command, 21
selection tool, 20
Text command, 21 v
Wire command, 20 VHDL files
visibility, 23, 59 creating, 13
Tool palette commands, 23 opening, 45
toolbar, 16 viewing, 13
Annotate command, 17 VHDL syntax
Back Annotate command, 17 defining colors, 64
Bill of Materials command, 18 defining fonts, 64
Copy command, 16 defining highlighting, 64
Create Netlist command, 17 viewing
Cross References command, 17 centering, 174
Cut command, 16 entire page or part, 174
Design Rules Check command, 17 selected area, 173
Help Topics command, 18 visibility
New command, 16 power pins, 79, 113
Open command, 16 status bar, 25
Paste command, 17 tool palette, 23, 59
Print command, 16 toolbar, 18

project manager tool, 18

Redo command, 17

Save command, 16 w
snap-to-grid tool, 18
Undo command, 17
visibility, 18

Zoom All command, 17
Zoom Area command, 17
Zoom In command, 17
Zoom Out command, 17

window
active, 4
part editor, 12
project manager, 6
schematic page editor, 11
session frame, 4
session log, 14
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text editor, 13
Wire command, 135

tool palette button, 20
wires

editing, 134

placing, 134

/ 4

Zoom All command, 174
toolbar, 17

Zoom Area command, 173
toolbar, 17

zoom factor, 172
defining, 57-58

Zoom In command, 172
toolbar, 17

Zoom Out command, 172
toolbar, 17

zoom scale, 173

zooming, 57, 172
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